Subject: [Last-Call] Secdir last call review of draft-ietf-detnet-ip-over-mpls-07

From: Vincent Roca via Datatracker <[email-masked]>
Date: Mon, 07 Sep 2020 04:38:13 -0700

Reviewer: Vincent Roca
Review result: Has Nits

Hello,

I have reviewed this document as part of the security directorate’s ongoing
effort to review all IETF documents being processed by the IESG. These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

Summary: Has Nits

I have no major concern. However I think that the Security considerations section
could and should better leverage on [I-D.ietf-detnet-security] (currently it is mainly
cited but that's all). Indeed, the [I-D.ietf-detnet-security] document is all about 
DetNet security, it introduces the problem in a clear manner, then it discusses with 
much detail both security risks and mitigation technics, providing high level synthesis
tables, and sections 9.1 and 9.2 are even dedicated to IP and MPLS DetNet security. 
This is a MUST read document that provides valuable discussion (perhaps more than
in the present document, sorry).

I also think the  [I-D.ietf-detnet-security] reference (""Deterministic Networking (DetNet)
Security Considerations") should be a Normative Reference (it's currently in the Informative
Reference list).

Minor comments:

- Section 4.1 uses the S-PE acronym when refering to the Relay Node, whereas S-PE is not 
expended in the Abbreviations list of section 2.2.

Regards,    Vincent

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 8 Sep 2020 07:30:34 +0000

Hi Vincent,

Many thanks for your review.
I have updated the document based on your comments 
(i.e., changing to normative reference, fixing abbreviations.)

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Vincent Roca via Datatracker <[email-masked]> 
Sent: Monday, September 7, 2020 1:38 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-detnet-ip-over-mpls-07

Reviewer: Vincent Roca
Review result: Has Nits

Hello,

I have reviewed this document as part of the security directorate’s ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

Summary: Has Nits

I have no major concern. However I think that the Security considerations section could and should better leverage on [I-D.ietf-detnet-security] (currently it is mainly cited but that's all). Indeed, the [I-D.ietf-detnet-security] document is all about DetNet security, it introduces the problem in a clear manner, then it discusses with much detail both security risks and mitigation technics, providing high level synthesis tables, and sections 9.1 and 9.2 are even dedicated to IP and MPLS DetNet security. 
This is a MUST read document that provides valuable discussion (perhaps more than in the present document, sorry).

I also think the  [I-D.ietf-detnet-security] reference (""Deterministic Networking (DetNet) Security Considerations") should be a Normative Reference (it's currently in the Informative Reference list).

Minor comments:

- Section 4.1 uses the S-PE acronym when refering to the Relay Node, whereas S-PE is not expended in the Abbreviations list of section 2.2.

Regards,    Vincent