Subject: Re: [Last-Call] [spring] I-D Action: draft-ietf-spring-srv6-network-programming-19.txt

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Fri, 18 Sep 2020 16:08:15 +0000

Hello,

We have just posted revision 19 of draft-ietf-spring-srv6-network-programming.

This revision addresses the comments received from Brian Weis (SECDIR review) [1,2], Brian Haberman  (INTDIR telechat review) [3,4] and Martin Duke.

Thank you for the reviews and comments.

Regards,
Pablo.

[1] https://mailarchive.ietf.org/arch/msg/last-call/DA1teHRO4fMSCg-7YZKsWqae3tE/
[2] https://mailarchive.ietf.org/arch/msg/last-call/c5V9fbgW1SvPHrHrVwJxvxuOnHk/
[3] https://mailarchive.ietf.org/arch/msg/last-call/9ld_rgqlN6q3VSjZ-7GcGdn4hOQ/
[4] https://mailarchive.ietf.org/arch/msg/last-call/9h8mAe1JcNTvCKTWq8-6nvZk0gk/

-----Original Message-----
From: spring <[email-masked]> On Behalf Of [email-masked]
Sent: viernes, 18 de septiembre de 2020 17:57
To: [email-masked]
Cc: [email-masked]
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-19.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Source Packet Routing in Networking WG of the IETF.

        Title           : SRv6 Network Programming
        Authors         : Clarence Filsfils
                          Pablo Camarillo Garvia
                          John Leddy
                          Daniel Voyer
                          Satoru Matsushima
                          Zhenbin Li
	Filename        : draft-ietf-spring-srv6-network-programming-19.txt
	Pages           : 42
	Date            : 2020-09-18

Abstract:
   The SRv6 Network Programming framework enables a network operator or
   an application to specify a packet processing program by encoding a
   sequence of instructions in the IPv6 packet header.

   Each instruction is implemented on one or several nodes in the
   network and identified by an SRv6 Segment Identifier in the packet.

   This document defines the SRv6 Network Programming concept and
   specifies the base set of SRv6 behaviors that enables the creation of
   interoperable overlays with underlay optimization (Service Level
   Agreements).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-spring-srv6-network-programming/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-spring-srv6-network-programming-19
https://datatracker.ietf.org/doc/html/draft-ietf-spring-srv6-network-programming-19

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-spring-srv6-network-programming-19

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 21 Sep 2020 17:17:48 -0700

Dear Authors, et al.,
I've got a question, probably a very naive one, so my apologies in the
front.
The document in Section 4.16 defines a number of flavors of End, End.X, and
End.T behaviors. Given that this is the SRv6 document and I don't seem to
find analogous definitions for SR-MPLS, is it safe to assume that the
defined flavors, e.g., PSP, can be used in SR-MPLS?

Regards,
Greg

On Fri, Sep 18, 2020 at 9:09 AM Pablo Camarillo (pcamaril) <pcamaril=
[email-masked]> wrote:

> Hello,
>
> We have just posted revision 19 of
> draft-ietf-spring-srv6-network-programming.
>
> This revision addresses the comments received from Brian Weis (SECDIR
> review) [1,2], Brian Haberman  (INTDIR telechat review) [3,4] and Martin
> Duke.
>
> [1]
> https://mailarchive.ietf.org/arch/msg/last-call/DA1teHRO4fMSCg-7YZKsWqae3tE/
> [2]
> https://mailarchive.ietf.org/arch/msg/last-call/c5V9fbgW1SvPHrHrVwJxvxuOnHk/
> [3]
> https://mailarchive.ietf.org/arch/msg/last-call/9ld_rgqlN6q3VSjZ-7GcGdn4hOQ/
> [4]
> https://mailarchive.ietf.org/arch/msg/last-call/9h8mAe1JcNTvCKTWq8-6nvZk0gk/
>
> Subject: [spring] I-D Action:
> draft-ietf-spring-srv6-network-programming-19.txt
>
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 22 Sep 2020 20:03:59 +0000

Hi Greg,

Could you please clarify your question? This document is about SRv6, hence I do not understand your question on SR-MPLS applicability.

Thank you,
Pablo.

From: Greg Mirsky <[email-masked]>
Sent: martes, 22 de septiembre de 2020 2:18
To: Pablo Camarillo (pcamaril) <[email-masked]>
Cc: [email-masked]; [email-masked]; The IESG <[email-masked]>
Subject: Re: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-19.txt

Dear Authors, et al.,
I've got a question, probably a very naive one, so my apologies in the front.
The document in Section 4.16 defines a number of flavors of End, End.X, and End.T behaviors. Given that this is the SRv6 document and I don't seem to find analogous definitions for SR-MPLS, is it safe to assume that the defined flavors, e.g., PSP, can be used in SR-MPLS?

Regards,
Greg

On Fri, Sep 18, 2020 at 9:09 AM Pablo Camarillo (pcamaril) <pcamaril=[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Regards,
Pablo.

-----Original Message-----
From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: viernes, 18 de septiembre de 2020 17:57
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [spring] I-D Action: draft-ietf-spring-srv6-network-programming-19.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 23 Sep 2020 18:34:33 -0700

Hi Pablo,
I apologize for the confusion I've caused on the last-call list. It was not
appropriate to ask my question here.
As for the technical side, I've got good references and have figured it all
out.

Kind regards,
Greg

On Tue, Sep 22, 2020 at 1:04 PM Pablo Camarillo (pcamaril) <
[email-masked]> wrote:

> Hi Greg,
>
>
>
> Could you please clarify your question? This document is about SRv6, hence
> I do not understand your question on SR-MPLS applicability.
>
>
>
> Thank you,
>
> Pablo.
>
>
>
> *From:* Greg Mirsky <[email-masked]>
> *Sent:* martes, 22 de septiembre de 2020 2:18
> *To:* Pablo Camarillo (pcamaril) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; The IESG <[email-masked]>
> *Subject:* Re: [spring] I-D Action:
> The document in Section 4.16 defines a number of flavors of End, End.X,
> and End.T behaviors. Given that this is the SRv6 document and I don't seem
> to find analogous definitions for SR-MPLS, is it safe to assume that the