Subject: [Last-Call] Yangdoctors last call review of draft-ietf-ccamp-otn-tunnel-model-11

From: Radek Krejčí via Datatracker <[email-masked]>
Date: Fri, 16 Oct 2020 06:33:27 -0700

Reviewer: Radek Krejčí
Review result: Ready with Issues

This is my yang doctor review of draft draft-ietf-ccamp-otn-tunnel-model-11
with the ietf-otn-tunnel@2020-03-09 YANG module.

Despite the size of the module, its structure is very simple repeatedly
following a pattern of augmenting ietf-te by groupings defined in
ietf-layer1-types module (except the single grouping defined in the module
itself).

Validation tools report a number of errors in the module. The problem is, that
the module references (in augments)
/te:te/te:tunnels/te:tunnel/te:p2p-primary-paths/ and
/te:te/te:tunnels/te:tunnel/te:p2p-secondary-paths/ which are not present in
current ietf-te@2020-07-12 module (the nodes were removed in
draft-ietf-teas-yang-te-23, the reference in the Section 10 of the draft is to
draft-ietf-teas-yang-te-25 but the module is not in line with this revision).
So the module needs a crucial update. Also please consider if the grouping
otn-tunnel-attributes is reusable in other modules. If the reusability is not
the concern, I don't see any reason to define it instead of specifying the
grouping content directly in the augment.

Regarding the draft, as a reader, I would appreciate a more targeted
description in section 3. Instead of just dumping the tree diagram in section
3.2, it would be useful to split it into several areas with some brief
descriptions and examples.

The list of paths is introduced in Section 6 as "the subtrees and data nodes
and their sensitivity/vulnerability", but I don't see explained/described the
mentioned sensitivity/vulnerability of those paths. Besides that, the paths
include '..' as ellipsis, but '..' has its usual meaning in paths, please unify
it with the format used in ietf-otn-topology and use '...'.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 19 Oct 2020 09:52:44 +0000

Hi Radek,

Thanks a lot for the review, much appreciated. 
We requested a joint review of the OTN tunnel model and the OTN topology model (https://tools.ietf.org/html/draft-ietf-ccamp-otn-topo-yang-11 ).
I'm just checking if you need a bit more time for the OTN topology model (which is perfectly fine) or if the request for the review of both drafts got lost.

Thanks a lot,
Daniele  

-----Original Message-----
From: Radek Krejčí via Datatracker <[email-masked]> 
Sent: den 16 oktober 2020 15:33
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Yangdoctors last call review of draft-ietf-ccamp-otn-tunnel-model-11

Reviewer: Radek Krejčí

Despite the size of the module, its structure is very simple repeatedly following a pattern of augmenting ietf-te by groupings defined in ietf-layer1-types module (except the single grouping defined in the module itself).

Validation tools report a number of errors in the module. The problem is, that the module references (in augments) /te:te/te:tunnels/te:tunnel/te:p2p-primary-paths/ and /te:te/te:tunnels/te:tunnel/te:p2p-secondary-paths/ which are not present in current ietf-te@2020-07-12 module (the nodes were removed in draft-ietf-teas-yang-te-23, the reference in the Section 10 of the draft is to
draft-ietf-teas-yang-te-25 but the module is not in line with this revision).
So the module needs a crucial update. Also please consider if the grouping otn-tunnel-attributes is reusable in other modules. If the reusability is not the concern, I don't see any reason to define it instead of specifying the grouping content directly in the augment.

Regarding the draft, as a reader, I would appreciate a more targeted description in section 3. Instead of just dumping the tree diagram in section 3.2, it would be useful to split it into several areas with some brief descriptions and examples.

The list of paths is introduced in Section 6 as "the subtrees and data nodes and their sensitivity/vulnerability", but I don't see explained/described the mentioned sensitivity/vulnerability of those paths. Besides that, the paths include '..' as ellipsis, but '..' has its usual meaning in paths, please unify it with the format used in ietf-otn-topology and use '...'.

---

From: Radek Krejci <[email-masked]>
Date: Mon, 19 Oct 2020 13:08:09 +0200

Hi Daniele,

I've reviewed both together, just the reviews were split and uploaded
via datatracker to each of the drafts. Both reviews were sent into the
mailing lists (I see them at least in [email-masked]).

Regards,
Radek

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 19 Oct 2020 11:12:44 +0000

Hi Radek,

Indeed i see both of them in the mail archive of the working group.
There must be something wrong with my mailbox or I must have deleted by mistake the topology one.

Thanks once again,
Daniele  

-----Original Message-----
From: Radek Krejci <[email-masked]> 
Sent: den 19 oktober 2020 13:08
To: Daniele Ceccarelli <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Yangdoctors last call review of draft-ietf-ccamp-otn-tunnel-model-11

Hi Daniele,

Regards,
Radek