Subject: [Last-Call] Genart last call review of draft-ietf-lpwan-schc-over-lorawan-10

From: Robert Sparks via Datatracker <[email-masked]>
Date: Fri, 02 Oct 2020 08:16:54 -0700

Reviewer: Robert Sparks
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-lpwan-schc-over-lorawan-10
Reviewer: Robert Sparks
Review Date: 2020-10-02
IETF LC End Date: 2020-10-02
IESG Telechat date: Not scheduled for a telechat

Summary: Ready for publication as a proposed standard but with nits to consider
before publication

Nits/editorial comments:

The abstract says "This is called a profile." It would be better to say
something like "This document specifies a profile of RFC8724."

What does "other Internet networks" mean? Please replace the phrase with
something more descriptive.

The word "efficient" in the last sentence of the introduction is puzzling.
Could it simply be removed?

As the shepherd report notes, there are figures that need to be reworked to
satisfy column constraints.

---

From: Olivier Gimenez <[email-masked]>
Date: Mon, 5 Oct 2020 09:53:34 +0000

Dear Robert,

Thank you for your review. I answered in your email.

Olivier

> -----Original Message-----

> From: Robert Sparks via Datatracker <[email-masked]>

> something like "This document specifies a profile of RFC8724."

I changed the paragraph to the following (commit f6a3ca7<https://github.com/Acklio/schc-over-lorawan/pull/35/commits/f6a3ca7af50f1c468ad7171c4911760434567808>):

This document specifies a profile of [RFC8724] to use SCHC in LoRaWAN networks,

and provides elements such as efficient parameterization and modes of

operation.

> something more descriptive.

Thanks, I rephrased it for: (commit 94823f8<https://github.com/Acklio/schc-over-lorawan/pull/35/commits/94823f864f4e42c6a0ed934bd0e59864cf22e701>)

SCHC provides a generic framework that enables those devices to communicate on

IP networks.

> Could it simply be removed?

Ok (commit 94823f8<https://github.com/Acklio/schc-over-lorawan/pull/35/commits/94823f864f4e42c6a0ed934bd0e59864cf22e701>)

> satisfy column constraints.

Fixed in 8ce2196<https://github.com/Acklio/schc-over-lorawan/pull/35/commits/8ce2196a301a0072c791df1363655453b750eee8> (Also fixes informative RFC which are not normative)

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.