Subject: [Last-Call] Tsvart last call review of draft-ietf-detnet-flow-information-model-11

From: Olivier Bonaventure via Datatracker <[email-masked]>
Date: Fri, 06 Nov 2020 12:56:26 -0800

Reviewer: Olivier Bonaventure
Review result: Almost Ready

This document has been reviewed as part of the transport area review team's
ongoing effort to review key IETF documents. These comments were written
primarily for the transport area directors, but are copied to the document's
authors and WG to allow them to address any issues raised and also to the IETF
discussion list for information.

When done at the time of IETF Last Call, the authors should consider this
review as part of the last-call comments they receive. Please always CC
[email-masked] if you reply to or forward this review.

This review was requested in a very short period of time and I could not read
all the Detnet related materials. I focus on issues that could be relevant for
the transport area.

The introduction indicates that the Detnet architecture supports IP and MPLS
flows, but section 5.4.2 indicates that and IP flow can be specified using the
following attributes :

  a.  SourceIpAddress
   b.  DestinationIpAddress
   c.  IPv6FlowLabel
   d.  Dscp (attribute)
   e.  Protocol
   f.  SourcePort
   g.  DestinationPort
   h.  IPSecSpi

I would personally qualify the flows that include transport layer information
as layer-4 and not IP flows. Maybe a note in the introduction should be
mentioned. In the document, it is unclear to me whether some of these
attributes are optional or can be specified as wild cards. Maybe this is
described in another document.

The information model defines various attributes. Some of the definitions are
very precise and mention the measurement unit. For others, this is less clear.
For example, intervals are defined in units of nanoseconds, but payloadsize is
not defined as a number of bytes.

Some information elements appear unclear to an external observer like me:

5.9.4.  Maximum Loss of the DetNet Flow

   MaxLoss defines the maximum Packet Loss Ratio (PLR) requirement for
   the DetNet flow between the Ingress and Egress(es).

There is no measurement interval define for the packet loss ratio.

5.9.6.  Maximum Misordering Tolerance of the DetNet Flow

The definition is unclear and does not make it easy to measure this value

6.3.1.  Minimum Bandwidth of the DetNet Service

>From the definition, it is unclear to me whether the payload only is used to
compute the bandwidth or whether this includes the headers and if so which

I was surprised by the following paragraph

6.4.  Connectivity Type of the DetNet Service

   Two connectivity types are distinguished: point-to-point (p2p) and
   point-to-multipoint (p2mp).  Connectivity type p2mp is created by a
   transport layer function (e.g., p2mp LSP).  (Note: mp2mp connectivity
   is a superposition of p2mp connections.)

Does the note precludes the utilisation of multicast to support the detnet
service ? If so, I don't think that this restriction should be part of an
information model. It should be specified in an architecture document.

6.6.  Rank of the DetNet Service

   The DnServiceRank attribute provides the rank of a service instance
   relative to other services in the DetNet domain.  DnServiceRank
   (range: 0-255) is used by the network in case of network resource
   limitation scenarios.

>From this description I do not know whether a high value rank gets more
resource than a low value one. I would suggest to clarify this in the
definition of the rank.

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 26 Nov 2020 09:14:36 +0000

Hi Olivier,

Many thanks for your great review. Please see my comments inline (noted <BV>).

Changes are included: https://github.com/detnet-wg/draft-ietf-detnet-flow-information-model/commit/5aed47ec5b0215cf4b6ac16d67271fe7387f7179#diff-649f76b4565f6dacda6b86e0092367053c96a461fb5b114a62facdde502db7e7

Please, let us know if you intend to finetune the resolution of your comments.

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Olivier Bonaventure via Datatracker <[email-masked]> 
Sent: Friday, November 6, 2020 9:56 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Tsvart last call review of draft-ietf-detnet-flow-information-model-11

This document has been reviewed as part of the transport area review team's ongoing effort to review key IETF documents. These comments were written primarily for the transport area directors, but are copied to the document's authors and WG to allow them to address any issues raised and also to the IETF discussion list for information.

When done at the time of IETF Last Call, the authors should consider this review as part of the last-call comments they receive. Please always CC [email-masked] if you reply to or forward this review.

This review was requested in a very short period of time and I could not read all the Detnet related materials. I focus on issues that could be relevant for the transport area.

The introduction indicates that the Detnet architecture supports IP and MPLS flows, but section 5.4.2 indicates that and IP flow can be specified using the following attributes :

  a.  SourceIpAddress
   b.  DestinationIpAddress
   c.  IPv6FlowLabel
   d.  Dscp (attribute)
   e.  Protocol
   f.  SourcePort
   g.  DestinationPort
   h.  IPSecSpi

I would personally qualify the flows that include transport layer information as layer-4 and not IP flows. Maybe a note in the introduction should be mentioned. In the document, it is unclear to me whether some of these attributes are optional or can be specified as wild cards. Maybe this is described in another document.

<BV> Yes, these attributes are defined in [I-D.ietf-detnet-ip] and they can be specified as wild cards. For a given network scenario some of them or all of them may be used. In case of using e, f, and g, for DetNet IP Flow Identification then as you wrote it can be treated as layer-4 flow.
In section 5.4.2. the sentence before the attribute list points explicitly to [I-D.ietf-detnet-ip]. I have added a note at the end of the section.
<NEW Text>
   Using wild cards for these attributes are specified in [I-D.ietf-detnet-ip].
<END>

The information model defines various attributes. Some of the definitions are very precise and mention the measurement unit. For others, this is less clear.
For example, intervals are defined in units of nanoseconds, but payloadsize is not defined as a number of bytes.

<BV> Right. I have added new text to clarify this in section 5.5 in the paragraph after the list of those attributes.
<OLD Text>
  These attributes can be used to describe any type of traffic (e.g.,
   CBR, VBR, etc.) and can be used during resource allocation to
   represent worst case scenarios.
<NEW Text>
   These attributes can be used to describe any type of traffic (e.g.,
   CBR, VBR, etc.) and can be used during resource allocation to
   represent worst case scenarios. Interval is specified as an integer 
   number of nanoseconds. MaxPayloadSize is specified in octets 
   per second.
<END>

<BV> Right. Proposed correction.
<OLD Text>
   MaxLoss defines the maximum Packet Loss Ratio (PLR) requirement for
   the DetNet flow between the Ingress and Egress(es).
<NEW Text>
   MaxLoss defines the maximum Packet Loss Ratio (PLR) requirement for
   the DetNet flow between the Ingress and Egress(es) and the loss 
   measurement interval.
<END>

<BV> Right. Current text add some hints for measurement, but added some more clarification. Proposed correction.
<OLD Text>
   MaxMisordering describes the tolerable maximum number of packets that
   can be received out of order.  The maximum allowed misordering can be
   measured for example based on sequence number.  The value zero for
   the maximum allowed misordering indicates that in order delivery is
   required, misordering cannot be tolerated.
<NEW Text>
   MaxMisordering describes the tolerable maximum number of packets
   that can be received out of order. The value zero for the maximum 
   allowed misordering indicates that in order delivery is required, 
   misordering cannot be tolerated.

   The maximum allowed misordering can be measured for example based 
   on sequence number. The difference of sequence number values in 
   consecutive packets at the Egress cannot be bigger than 
   "MaxMisordering + 1".
<END>

<BV> Right. It excludes additional DetNet header (if any). Proposed clarification.
<OLD Text>
   MinBandwidth is the minimum bandwidth that has to be guaranteed for
   the DetNet service.  MinBandwidth is specified in octets per second.
<NEW Text>
   MinBandwidth is the minimum bandwidth that has to be guaranteed for
   the DetNet service.  MinBandwidth is specified in octets per second and 
   excludes additional DetNet header (if any).
<END>

Does the note precludes the utilisation of multicast to support the detnet service ? If so, I don't think that this restriction should be part of an information model. It should be specified in an architecture document.

<BV> Right, text is rather misleading and not accurate enough. Multicast is allowed. Proposed clarification.
<OLD Text>
   Two connectivity types are distinguished: point-to-point (p2p) and
   point-to-multipoint (p2mp).  Connectivity type p2mp is created by a
   transport layer function (e.g., p2mp LSP).  (Note: mp2mp connectivity
   is a superposition of p2mp connections.)
<NEW Text>
   Two connectivity types are distinguished: point-to-point (p2p) and
   point-to-multipoint (p2mp).  Connectivity type p2mp may be created by a
   forwarding function (e.g., p2mp LSP).  (Note: from service perspective 
   mp2mp connectivity can be treated as a superposition of p2mp 
   connections.)
<END>

>From this description I do not know whether a high value rank gets more
resource than a low value one. I would suggest to clarify this in the definition of the rank.

<BV> Right. :--))) Proposed clarification. Sentence added at the end of the paragraph.
<OLD Text>
   The DnServiceRank attribute provides the rank of a service instance
   relative to other services in the DetNet domain.  DnServiceRank
   (range: 0-255) is used by the network in case of network resource
   limitation scenarios.
<NEW Text>
   The DnServiceRank attribute provides the rank of a service instance
   relative to other services in the DetNet domain.  DnServiceRank
   (range: 0-255) is used by the network in case of network resource
   limitation scenarios. High value rank gets preferred over a low value 
   one.
<END>

---

From: Lou Berger <[email-masked]>
Date: Fri, 27 Nov 2020 08:45:19 -0500

Hi Balázs

Are you sure about this:

           ... High value rank gets preferred over a low value one.

I think this the opposite of what we normally do, for example:

[https://tools.ietf.org/html/rfc3209#section-4.7.1]

     "The value 0 is the highest priority."

[https://tools.ietf.org/html/rfc5440#section-7.11]

     "The value 0 is the highest priority."

[https://tools.ietf.org/html/rfc2328 and 
https://tools.ietf.org/html/rfc1195]

throughout the docs and in the algorithm sections: lowest cost/metric is 
considered better

Lou

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 27 Nov 2020 14:44:40 +0000

Hi Lou,

Yes, that was wrong. Furthermore, it is always great to be in-line with TSN definitions as well.
I will correct it.
<NEW>
"DnServiceRank value 0 is the highest priority."
<END>

Cheers
Bala'zs

-----Original Message-----
From: Lou Berger <[email-masked]> 
Sent: Friday, November 27, 2020 2:45 PM
To: Balázs Varga A <[email-masked]>; Olivier Bonaventure <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Tsvart last call review of draft-ietf-detnet-flow-information-model-11

Hi Balázs

Are you sure about this:

[https://tools.ietf.org/html/rfc2328 and https://tools.ietf.org/html/rfc1195]

throughout the docs and in the algorithm sections: lowest cost/metric is considered better

Lou

On 11/26/2020 4:14 AM, Balázs Varga A wrote:
> Changes are included: 
> https://protect2.fireeye.com/v1/url?k=dee2e172-8179d836-dee2a1e9-861d4
> 1abace8-9257af7700956e47&q=1&e=c6fd3bf1-3566-493c-be5c-8b64514e8a3e&u=
> https%3A%2F%2Fgithub.com%2Fdetnet-wg%2Fdraft-ietf-detnet-flow-informat
> ion-model%2Fcommit%2F5aed47ec5b0215cf4b6ac16d67271fe7387f7179%23diff-6
> 49f76b4565f6dacda6b86e0092367053c96a461fb5b114a62facdde502db7e7
>
> Cc: [email-masked]; 
> [email-masked]; 
> [email-masked]
> Subject: Tsvart last call review of 
> draft-ietf-detnet-flow-information-model-11
>
>     is a superposition of p2mp connections.) <NEW Text>

---

From: Lou Berger <[email-masked]>
Date: Fri, 27 Nov 2020 10:24:09 -0500

Thank you!