Subject: [Last-Call] Genart last call review of draft-ietf-core-echo-request-tag-11

From: Ines Robles via Datatracker <[email-masked]>
Date: Wed, 02 Dec 2020 10:16:55 -0800

Reviewer: Ines Robles
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-core-echo-request-tag-11
Reviewer: Ines Robles
Review Date: 2020-12-02
IETF LC End Date: 2020-12-02
IESG Telechat date: Not scheduled for a telechat

Summary:

This document specifies the Echo option that enables a CoAP server to verify
the freshness of a request or to force a client to demonstrate reachability at
its claimed network address, and specifies also the Request-Tag that allows the
CoAP server to match block-wise message fragments belonging to the same
request. Also, this document updates RFC7252 with respect to the client Token
processing requirements.

The document is well written, I have some minor questions/comments below.

Major issues: None.

Minor issues: None.

Nits/editorial comments:

1.- It would be nice to have the definition of Freshness into the terminology
section.

2.- Figure 1 and Figure 4 have two columns named "U" (Unsafe), is that Ok?, or
should one of these columns be deleted/renamed?

3- Page 26: Please expand IV.

Thank you for this document,

Ines.

---

From: Christian M. Amsüss <[email-masked]>
Date: Wed, 9 Dec 2020 15:10:28 +0100

Hello Ines,

thanks for your comments.

The expansions are done or WIP in our version, and will be part of the
next editing iteration.

> should one of these columns be deleted/renamed?

That's indeed unfortunate; given tables of this format are common in
CoRE, I'll be checking back for the best course of action (but either
way it's to be fixed).

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom