Subject: [Last-Call] Rtgdir last call review of draft-ietf-lsr-yang-isis-reverse-metric-01

From: Michael Richardson via Datatracker <[email-masked]>
Date: Sun, 06 Dec 2020 18:49:50 -0800

Reviewer: Michael Richardson
Review result: Ready

This document is a short YANG module relating to RFC8500, and expertise in that
RFC are required to be sure if all the right control bits are required. It has
reasonable security consideration, although the words, "The lowest NETCONF
layer is the secure transport layer" seems a bit awkward. I would instead
write, "All [NETCONF] transactions run over a secure transport layer, which is
SSH"...

---

From: tom petch <[email-masked]>
Date: Thu, 10 Dec 2020 17:17:49 +0000

From: Lsr <[email-masked]> on behalf of Michael Richardson via Datatracker <[email-masked]>
Sent: 07 December 2020 02:49

<tp>
I think that that would be a mistake.  The text in question is specified by YANG Guidelines RFC8407  and appears in (almost) all I-D with a YANG Module.  The text is the consensus of the NETMOD WG.  The Secure Transport layer is a defined part of the Netconf architecture and can be implemented by at least four protocols.

Tom Petch

_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 10 Dec 2020 17:42:28 +0000

Agreed. There is a boiler plate for Security Considerations that all YANG models should start with. 
Thanks,
Acee

On 12/10/20, 12:18 PM, "Lsr on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    <tp>

    Tom Petch