Subject: [Last-Call] Genart last call review of draft-ietf-detnet-mpls-over-tsn-05

From: Ines Robles via Datatracker <[email-masked]>
Date: Fri, 05 Feb 2021 15:56:42 -0800

Reviewer: Ines Robles
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-detnet-mpls-over-tsn-05
Reviewer: Ines Robles
Review Date: 2021-02-05
IETF LC End Date: 2021-02-05
IESG Telechat date: 2021-02-18

Summary:

This document specifies the Deterministic Networking MPLS data plane when
operating over a TSN sub-network.

I have some minor questions to the authors.

Major issues: None

Minor issues: None

Nits/editorial comments:

- Page 5: Could you please describe what the "TSN treatment" comprise?
- Are the security considerations the same for TSN-unaware that are for
TSN-aware nodes? - How are the privacy considerations for those? It would be
nice to mention explicitly how or where (I-D.ietf-detnet-security???) the
privacy considerations are addressed for TSN-unaware and TSN-aware nodes

Thank you for this document

Ines.

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 8 Feb 2021 20:46:03 +0000

Hi Ines,
Many thanks for your review. 
See my reactions and proposed updates below.
Thanks
Bala'zs

-----Original Message-----
From: Ines Robles via Datatracker <[email-masked]> 
Sent: Saturday, February 6, 2021 12:57 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-detnet-mpls-over-tsn-05

Reviewer: Ines Robles

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Summary:

This document specifies the Deterministic Networking MPLS data plane when operating over a TSN sub-network.

Major issues: None

Minor issues: None

Nits/editorial comments:

<Bala'zs> TSN treatment means to execute TSN functionalities during forwarding. I will extend the text
OLD TEXT:
       ... All these functions have to identify flows those 
       require TSN treatment.
NEW TEXT:
       ... All these functions have to identify flows those 
       require TSN treatment (i.e., applying TSN functions
       during forwarding).
END

- Are the security considerations the same for TSN-unaware that are for TSN-aware nodes? - How are the privacy considerations for those? It would be nice to mention explicitly how or where (I-D.ietf-detnet-security???) the privacy considerations are addressed for TSN-unaware and TSN-aware nodes

<Bala'zs> The I-D.ietf-detnet-security contains DetNet specific security considerations. TSN-unaware nodes are out-of-scope in the draft. TSN-aware nodes are part of both the MPLS and the TSN domain, where both domain has its own security considerations, which must be applied. 

Ines.

---

From: Ines Robles <[email-masked]>
Date: Thu, 11 Feb 2021 13:24:43 +0200

Hi Balázs,

Thank you for your clarifications. It is Ok for me.

BR,
Ines

On Mon, Feb 8, 2021 at 10:46 PM Balázs Varga A <[email-masked]>
wrote:

> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair.  Please treat these comments just like any other last call
> comments.
>
> TSN-aware nodes? - How are the privacy considerations for those? It would
> be nice to mention explicitly how or where (I-D.ietf-detnet-security???)
> the privacy considerations are addressed for TSN-unaware and TSN-aware nodes
>
> <Bala'zs> The I-D.ietf-detnet-security contains DetNet specific security
> considerations. TSN-unaware nodes are out-of-scope in the draft. TSN-aware
> nodes are part of both the MPLS and the TSN domain, where both domain has
> its own security considerations, which must be applied.
>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 17 Feb 2021 16:00:12 -0500

Ines, thanks for your review. Balázs, thanks for your responses. I entered a No Objection ballot.

Alissa

> On Feb 11, 2021, at 6:24 AM, Ines Robles <mariainesrobles=[email-masked]> wrote:
> 
> Hi Balázs,
> 
> On Mon, Feb 8, 2021 at 10:46 PM Balázs Varga A <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Ines,
> From: Ines Robles via Datatracker <[email-masked] <mailto:[email-masked]>> 
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>>.
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art