Subject: [Last-Call] Intdir telechat review of draft-ietf-detnet-mpls-over-tsn-05

From: Tim Chown via Datatracker <[email-masked]>
Date: Sun, 14 Feb 2021 07:33:43 -0800

Reviewer: Tim Chown
Review result: Ready with Nits

Hi,

Re: INT-DIR review of draft-ietf-detnet-mpls-over-tsn-06

This draft details how a DetNet MPLS data plane can run over a TSN sub-network.

I have reviewed this document and believe it is Ready for publication, with
Nits, as listed below.

Nits:

p.2
Loss rates -> loss rate
Provides congestion -> provide congestion
For MPLS-based -> for an MPLS-based

p.3
Include MSRP and RSVP-TE?

p.4
And resources -> and resource

p.5
>From MPLS -> from the MPLS
Does not -> do not
In case of -> In the case of

As per the IP doc, not being familiar with DetNet in detail it might be useful
to expand on the rationale for mapping to multicast given the “directed” flow.

p.7
As per the IP doc, I note it says there are no requirements stated for
TSN-unaware MPLS DetNet nodes in the document, but is it worth adding something
about requirements to ensure the TSN Relay can be reached?

p.8
Implementations -> implementation

P.9
of the document -> of this document
challanges -> challenges
Are member -=> are members
Single hop -> a single hop
In some case -> in some cases

P.10
Regarding the more complicated triggering for TSN-unaware nodes, should further
text be added about this?

--
Tim

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 16 Feb 2021 16:52:10 +0000

Hi Tim,

Many thanks for the review and the nits.
Updates will be done according to comments added inline.

Thanks
Bala'zs

-----Original Message-----
From: Tim Chown via Datatracker <[email-masked]> 
Sent: Sunday, February 14, 2021 4:34 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Intdir telechat review of draft-ietf-detnet-mpls-over-tsn-05

Reviewer: Tim Chown

Hi,

I have reviewed this document and believe it is Ready for publication, with Nits, as listed below.

Nits:

p.2
Loss rates -> loss rate
Provides congestion -> provide congestion For MPLS-based -> for an MPLS-based
<Bala'zs> OK.

p.3
<Bala'zs> OK.

p.4
And resources -> and resource
<Bala'zs> Already fixed in v06.

p.5
Does not -> do not
<Bala'zs> OK.

As per the IP doc, not being familiar with DetNet in detail it might be useful to expand on the rationale for mapping to multicast given the “directed” flow.
<Bala'zs> OK. See IP doc reply.

p.7
As per the IP doc, I note it says there are no requirements stated for TSN-unaware MPLS DetNet nodes in the document, but is it worth adding something about requirements to ensure the TSN Relay can be reached?
<Bala'zs> OK. See IP doc reply.

p.8
<Bala'zs> OK. 

P.9
<Bala'zs> OK.

P.10
Regarding the more complicated triggering for TSN-unaware nodes, should further text be added about this?
<Bala'zs> I see your point, but that is more a control/management plane issue and not a data plane one.
Controller plane discussions recently started in DetNet, so I will keep this comment on the table. :--)))

--
Tim

---

From: Tim Chown <[email-masked]>
Date: Wed, 17 Feb 2021 14:28:11 +0000

> Updates will be done according to comments added inline.

Thanks, that seems fine.

Best wishes,
Tim