Subject: [Last-Call] I18ndir last call review of draft-faltstrom-unicode11-08

From: "Asmus, Inc. via Datatracker" <[email-masked]>
Date: Thu, 04 Mar 2021 19:57:12 -0800

Reviewer: Asmus, Inc.
Review result: Ready with Nits

(1) The math of code points needs to be reviewed in section 4.3. It appears to
not account for a property change for U+111C9

(2) In Section 5, there's a sentence that seems to have a sense destroying edit:

     The code point if being accepted might due ???? to implementations of
     IDNA2008 based on older versions of Unicode than 11.0.0 be rejected.

(3) plural noun/verb mismatch in section 6

    ... new versions [...] is...

(4) Section 8: use of definite article. Drop "the" in front of Unicode Version
(also check other instances)

(5) Usefully, the discussion of SHARADA SANDHI MARK could point out whether it
treated the same or different from other SANDHI marks in related scripts. (From
just looking at the tables, and not the original UCD entries, it looks like
that they are all now treated the same, which would be beneficial under the
"least astonishment" principle - or whatever it's called).

This review based primarily on the diff, with just some look at the full text
to get the complete context for some items.

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 5 Mar 2021 14:46:07 +0000

>    Reviewer: Asmus, Inc.

Who is this?  IETF is individuals, not corporations.

---

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 05 Mar 2021 21:45:58 +0100

Document draft-faltstrom-unicode12 is replacing -11, and as soon as I have the ability to submit version -01 I will do so, and you all can review it when it is posted.

   Patrik

On 5 Mar 2021, at 4:57, Asmus, Inc. via Datatracker wrote:

> (1) The math of code points needs to be reviewed in section 4.3. It appears to not account for a property change for U+111C9
>
> (4) Section 8: use of definite article. Drop "the" in front of Unicode Version (also check other instances)
>
> (5) Usefully, the discussion of SHARADA SANDHI MARK could point out whether it treated the same or different from other SANDHI marks in related scripts. (From just looking at the tables, and not the original UCD entries, it looks like that they are all now treated the same, which would be beneficial under the "least astonishment" principle - or whatever it's called).
>
> This review based primarily on the diff, with just some look at the full text to get the complete context for some items.
>
>
> -- 
> I18ndir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i18ndir