Subject: [Last-Call] Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

From: Qin Wu via Datatracker <[email-masked]>
Date: Fri, 23 Apr 2021 08:19:51 -0700

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu
Review result: Ready with nits

I have reviewed this document as part of the Operational directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written with the intent of improving the operational aspects of
the IETF drafts. Comments that are not addressed in last call may be included
in AD reviews during the IESG review.  Document editors and WG chairs should
treat these comments just like any other last call comments.

This document describes how to convey the RP address information into the MVPN
Source Active route using an Extended Community so this information can be
shared with an existing MSDP infrastructure. It provides an update to RFC6514.

Major issues:
None

Minor issues:
I am wondering how MVPN and MSDP SA Interoperation is back compatible with
existing source  discovery information dissemination methods? Is there any
downside to make MVPN SA and MSDP SA work together.

Section 1:
Suggest to add term for GTM, RPT, C-Multicast

Section 3
When we say MVPN Pes that have one or more MSDP session in a VPN, does this
statement contradict with “VPN-specific MSDP sessions are not required among
the PEs”?

Section 3
What do you mean other MSDP speaker? Do we assume there is one or only one MSDP
speaker in the MSDP mesh group? How MSDP speaker is different from MSDP peer?
Do you mean there is no session to be established between MSDP peer?

Section 3, last paragraph:
When we say ” In that case, if the selected best MVPN SA route does not have
the "MVPN SA RP-address EC" but another route for the same (C-S, C-G) does,
then the best route with the EC SHOULD be chosen.”, which best route is
selected? Selected best MVPN SA route without EC or normal route with the EC?
It looks you assume the normal route with the EC is the best selected route as
well in this context?

Section 3
Can you provide an example of fine grained policy control? Is this related to
local policy? “accepted MSDP SA message when receiving PE’s RP for the C-G is
MSDP peer to which the generated MSDP message is advertised”

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 26 Apr 2021 20:35:20 +0000

Hi Qin,

Thank you for your review and comments. Let me share a diff to see if it addresses the issues, before I post a revision.

Please see zzh> below.

-----Original Message-----
From: Qin Wu via Datatracker <[email-masked]>
Sent: Friday, April 23, 2021 11:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-bess-mvpn-msdp-sa-interoperation-05

[External Email. Be cautious of content]

Reviewer: Qin Wu
Review result: Ready

Reviewer: Qin Wu

Major issues:
None

Minor issues:

Zzh> There is no downside. The RFC6514 specified MSDP SA -> MVPN SA but is missing the other direction (MVPN SA -> MSDP SA), which causes lots of headache. This document is to add the missing part, as explained in introduction section.
Zzh> The only backwards compatibility issue is with a scenario further explained at the end of this message - where PE2 is a legacy PE that does not attach the EC.

Section 1:

Zzh> Added.

Section 3

zzh> The MSDP session that the PEs have are with other non-PE MSDP speakers but not among themselves, so it does not contradict with that quoted text.

Section 3

Zzh> MSDP sessions are established among MSDP speakers/peers. The text here means that the MVPN PEs that are running MSDP (with sessions to other non-PEs)  form a mesh group and that group does not include other MSDP peers that are not PEs.

Zzh> The BGP selected best route may not have the EC. In that case, for MSDP interop purpose, the next best route with the EC should be used.

Section 3

Zzh> Yes I changed it to local policy. We probably don't need examples here - just whatever MSDP policies that can be used in an MSDP deployment.
Zzh> The quoted text is part of the following description: a receiving PE1 receives an SA route from another PE2 who does not attach the EC, so PE1 uses its own local RP address (say R1) to construct that MSDP SA message and advertise to its peer. If that peer happens to be R1, the peer will reject it because PE1 used R1 in constructing the message. To prevent this rejection, R1 should configure MSDP policy to accept the message.
Zzh> Thanks!
Zzh> Jeffrey

Juniper Business Use Only