Subject: Re: [Last-Call] Last Call: <draft-ietf-netmod-geo-location-08.txt> (A YANG Grouping for Geographic Locations) to Proposed Standard

From: Erik Kline <[email-masked]>
Date: Mon, 19 Apr 2021 13:14:11 -0700

<no hats>

Are the vector components expected to be accessed by name in applications,
or is it possible some applications might have to handle a 3-tuple of
doubles?

I only ask this super-nitty question because in my (admittedly limited)
experience, ENU order (or NED for that matter) was more familiar since it
forms a coordinate system that aligns with the right hand rule.

NEU->ENU conversion is obviously trivial.  I was just thinking of possible
errors where the members of the vector aren't accessed by name but by
position.

-ek

On Mon, Apr 19, 2021 at 7:07 AM The IESG <[email-masked]> wrote:

>
> The IESG has received a request from the Network Modeling WG (netmod) to
> consider the following document: - 'A YANG Grouping for Geographic
> Locations'
>   <draft-ietf-netmod-geo-location-08.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-05-03. Exceptionally, comments
> may
> be sent to [email-masked] instead. In either case, please retain the
> beginning
> of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    This document defines a generic geographical location object YANG
>    grouping.  The geographical location grouping is intended to be used
>    in YANG models for specifying a location on or in reference to Earth
>    or any other astronomical object.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/
>
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: Christian Hopps <[email-masked]>
Date: Wed, 21 Apr 2021 09:31:42 -0400

> On Apr 19, 2021, at 4:14 PM, Erik Kline <[email-masked]> wrote:
> 
> <no hats>
> 
> Are the vector components expected to be accessed by name in applications, or is it possible some applications might have to handle a 3-tuple of doubles?

By name only.

Thanks,
Chris.

> 
> I only ask this super-nitty question because in my (admittedly limited) experience, ENU order (or NED for that matter) was more familiar since it forms a coordinate system that aligns with the right hand rule.
> 
> NEU->ENU conversion is obviously trivial.  I was just thinking of possible errors where the members of the vector aren't accessed by name but by position.
> 
> -ek
> 
> On Mon, Apr 19, 2021 at 7:07 AM The IESG <[email-masked] <mailto:[email-masked]>> wrote:
> 
> consider the following document: - 'A YANG Grouping for Geographic Locations'
> [email-masked] <mailto:[email-masked]> mailing lists by 2021-05-03. Exceptionally, comments may
> be sent to [email-masked] <mailto:[email-masked]> instead. In either case, please retain the beginning
> https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/>
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-announce <https://www.ietf.org/mailman/listinfo/ietf-announce>
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod