Subject: Re: [Last-Call] Last Call: <draft-ietf-stir-enhance-rfc8226-02.txt> (Enhanced JWT Claim Constraints for STIR Certificates) to Proposed Standard

From: Donald Eastlake <[email-masked]>
Date: Mon, 31 May 2021 13:58:38 -0400

How about expanding "JWT" in the abstract and on first use in the body
of this document.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Thu, May 27, 2021 at 4:41 PM The IESG <[email-masked]> wrote:
>
>
> The IESG has received a request from the Secure Telephone Identity Revisited
> WG (stir) to consider the following document: - 'Enhanced JWT Claim
> Constraints for STIR Certificates'
>   <draft-ietf-stir-enhance-rfc8226-02.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-06-10. Exceptionally, comments may
> be sent to [email-masked] instead. In either case, please retain the beginning
> of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    RFC 8226 provides a certificate extension to constrain the JWT claims
>    that can be included in the PASSporT as defined in RFC 8225.  If the
>    signer includes a JWT claim outside the constraint boundaries, then
>    the recipient will reject the entire PASSporT.  This document defines
>    an additional way that the JWT claims can be constrained.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-stir-enhance-rfc8226/
>
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Russ Housley <[email-masked]>
Date: Mon, 31 May 2021 14:22:17 -0400

Sure.  JSON Web Token (JWT).  Do you think that JSON needs expanded too?

Russ

> On May 31, 2021, at 1:58 PM, Donald Eastlake <[email-masked]> wrote:
> 
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 31 May 2021 14:34:27 -0400

Hi Russ,

No, I do not think JSON needs expansion but I wouldn't object to it.

Thanks,
Donald

---

From: Ben Campbell <[email-masked]>
Date: Mon, 31 May 2021 13:34:50 -0500

JSON is marked as well-known in the RFC editor’s abbreviation list. JWT is not.

OTOH, there’s no harm in expanding well-known abbreviations ;-)

Ben.

> On May 31, 2021, at 1:22 PM, Russ Housley <[email-masked]> wrote:
>