Subject: [Last-Call] Yangdoctors last call review of draft-ietf-babel-yang-model-09

From: Radek Krejčí via Datatracker <[email-masked]>
Date: Sat, 01 May 2021 13:29:46 -0700

Reviewer: Radek Krejčí
Review result: Ready with Nits

This is my YANG doctor review of draft-ietf-babel-yang-model containing
[email-masked] module. The draft and the module are well written
and I have just two minor comments:

- The copyright year in the YANG module should be probably 2021, not 2020.

- Some values of the specific statements (e.g. min-elements) are quoted despite
it is not necessary (the value must be a number or a single word). I propose to
use pyang/yanglint to generate the module since it also unifies all the
formatting and quoting.

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 6 May 2021 15:07:59 -0700

Hi Radek,

Thanks for reviewing the YANG model. See comments inline.

> On May 1, 2021, at 1:29 PM, Radek Krejčí via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Radek Krejčí

Fixed.

> use pyang/yanglint to generate the module since it also unifies all the

Ok. I ran pyang on the module to addresses statements that should be quoted or not, and fixed all of them. 

p.s. While I was at it, I also fixed the prefix issue as it relates to import of ietf-yang-types that Tom Petch brought up.

Cheers.

Mahesh Jethanandani
[email-masked]