Subject: [Last-Call] Yangdoctors last call review of draft-ietf-rift-yang-03

From: Michal Vaško via Datatracker <[email-masked]>
Date: Thu, 08 Jul 2021 03:09:47 -0700

Reviewer: Michal Vaško
Review result: Almost Ready

Generally, use references where make sense (features, nodes) and use units
and/or standard types (ietf-yang-types) for leaves (such as grouping
neighbor-node/bandwidth). All links are invalid, better to use references
anyway because the module will be used outside the RFC.

Specific problems:

- description - copyright 2020
- typedef ieee802-1as-timestamp-type - reference in description, put separately
- grouping address-families
        - list with a single key can be leaf-list
        - would make sense if meant to be augmented with new nodes
- grouping node-flag
        - used only once, makes sense if meant to be reused by other modules
        - consider using bits type in the leaf
- grouping base-node-info/pod - redundant description, use union of number and
"undefined", or leave out for undefined since it is not mandatory - augment
rift/rx-lie-multicast-address,tx-lie-multicast-address
        - default value in description - should be defined in YANG
                                                              - consider using
                                                              refine on
                                                              "addresses"
        rx-flood-port - redundant default in description, is obvious in YANG
        algorithm-type - empty cases - redundant on their own, are expected to
        be augmented? HAL - use lowercase
        database/tie/negative_disaggregation_prefixes
                - use hyphen instead of underscore
                - consider abbreviated/shorter node names
                - applicable for the following nodes as well

---

From: <[email-masked]>
Date: Fri, 9 Jul 2021 09:00:04 +0800 (CST)

Hi Michal, 
Thank you very much for your review!
We'll update the model according to your comments in next version.
Best regards,
Sandy

------------------原始邮件------------------
发件人：MichalVaškoviaDatatracker
收件人：[email-masked];
抄送人：[email-masked];[email-masked];[email-masked];
日 期 ：2021年07月08日 18:17
主 题 ：[Rift] Yangdoctors last call review of draft-ietf-rift-yang-03
Reviewer: Michal Vaško
Review result: Almost Ready

Specific problems:

_______________________________________________
RIFT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rift