Subject: Re: [Last-Call] Last Call: <draft-ietf-mpls-lsp-ping-ospfv3-codepoint-04.txt> (OSPFv3 CodePoint for MPLS LSP Ping) to Proposed Standard

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Thu, 9 Sep 2021 16:18:26 +0000

HI Tom,

Apologies for the delay. Please see below for our response.

s.6
"   This document specifies that the above code points will be used only
    for OSPFv2."

Perhaps a place for a  'SHALL'.

<Nagendra>  Since the code point should be used only for OSPFv2, should we use “SHOULD”?.

Thanks,
Nagendra

From: tom petch <[email-masked]>
Date: Friday, June 11, 2021 at 5:01 AM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: Last Call: <draft-ietf-mpls-lsp-ping-ospfv3-codepoint-04.txt> (OSPFv3 CodePoint for MPLS LSP Ping) to Proposed Standard
On 07/06/2021 14:40, The IESG wrote:
>
> The IESG has received a request from the Multiprotocol Label Switching WG
> (mpls) to consider the following document: - 'OSPFv3 CodePoint for MPLS LSP
> Ping'
>    <draft-ietf-mpls-lsp-ping-ospfv3-codepoint-04.txt> as Proposed Standard
>

s.6
"   This document specifies that the above code points will be used only
    for OSPFv2."

Perhaps a place for a  'SHALL'.

Tom Petch

> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-06-21. Exceptionally, comments may
> be sent to [email-masked] instead. In either case, please retain the beginning
> of the Subject line to allow automated sorting.
>
> Abstract
>
>
>     IANA has created "Protocol in the Segment IS Sub-TLV" and "Protocol
>     in the Label Stack Sub-TLV of the Downstream Detailed Mapping TLV"
>     registries under the "Multi-Protocol Label Switching (MPLS) Label
>     Switched Paths (LSPs) Ping Parameters" registry.  RFC8287 defines the
>     code points for OSPF and IS-IS.
>
>     This document proposes the code point to be used in the Segment ID
>     Sub-TLV and Downstream Detailed Mapping TLV when the IGP is OSPFv3.
>     This document also updates RFC8287 by clarifying that the existing
>     "OSPF" code point is to be used only to indicate OSPFv2, and by
>     defining the behavior when the Segment ID SUb-TLV indicates the use
>     of IPv6.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-mpls-lsp-ping-ospfv3-codepoint/
>
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
> .
>

---

From: tom petch <[email-masked]>
Date: Mon, 13 Sep 2021 16:58:26 +0100

> <Nagendra>  Since the code point should be used only for OSPFv2, should we use “SHOULD”?.

Well, they are different.  SHALL is the same as MUST in RFC2119, an 
absolute requirement of the specification.

SHOULD allows for valid reasons to ignore the requirement and usually, 
although not always, is accompanied by text indicating when it is valid 
to ignore it.

'will be used only' comes across to me as a SHALL, not a SHOULD (as does 
a read of RFC8287).

Tom Petch