Subject: [Last-Call] Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

From: Reshad Rahman via Datatracker <[email-masked]>
Date: Wed, 29 Sep 2021 20:08:54 -0700

Reviewer: Reshad Rahman
Review result: Ready with Nits

This is my 3rd review of the document. While I have focused on changes done
since my last review, some comments apply to parts of the YANG model which
hasn't changed recently.

Main comments
=============

- Feature immediate-leave mentions “fast leave” in the description. RFC3376
mentions fast leave but not immediate leave. Should the feature, and the leaf
node which depends on it, be renamed to fast-leave?

- Leaf send-query, description says that it cooperates with parameter
querier-source. I believe there should be enforcement that send-query can only
be set if querier-source is also set (must statement)? Also querier-source in
IGMP mentions VLAN, no such mention in MLD, is that correct?

Questions
========

- Feature static-l2-multicast-group. The description mentions L2 multicast
static-group. Is it a static multicast group or a multicast static group? I
believe it’s the former and the description should be changed?

- igmp-version and mld-version are both uint8 with a range (1..3 and 1..2). If
we get a new version someday, the range will have to be changed. I don’t recall
if this was brought up before. Another option is to use an identity. I realize
we don’t spin out a new version frequently so this may not be an issue. And
probably with a new version other changes would be needed anyway…

- Last-reporter is present under the group and also under each source entry. Is
the one under the group the last host from all sources?

- Leaf node require-router-alert. What happens if it’s set to true and the IP
hdr does not contain RA? Consider updating description and/or adding a
reference.

Minor
=====

- Typo in bridge-router-interface: dynamicly.

- No need to mention the leaf name in description, e.g. in l2-service-type

- Leaf “host-address”, rename to “address” since the list is called host (no
need to duplicate host).

Regards,
Reshad.

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 30 Sep 2021 03:25:08 +0000

Hi Reshad,

Thanks a lot for your comments. We will discuss and address them ASAP.

BR/Hongji

-----Original Message-----
From: Reshad Rahman via Datatracker <[email-masked]> 
Sent: 2021年9月30日 11:09
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Reviewer: Reshad Rahman

This is my 3rd review of the document. While I have focused on changes done since my last review, some comments apply to parts of the YANG model which hasn't changed recently.

Main comments
=============

- Feature immediate-leave mentions “fast leave” in the description. RFC3376 mentions fast leave but not immediate leave. Should the feature, and the leaf node which depends on it, be renamed to fast-leave?

- Leaf send-query, description says that it cooperates with parameter querier-source. I believe there should be enforcement that send-query can only be set if querier-source is also set (must statement)? Also querier-source in IGMP mentions VLAN, no such mention in MLD, is that correct?

Questions
========

- Feature static-l2-multicast-group. The description mentions L2 multicast static-group. Is it a static multicast group or a multicast static group? I believe it’s the former and the description should be changed?

- igmp-version and mld-version are both uint8 with a range (1..3 and 1..2). If we get a new version someday, the range will have to be changed. I don’t recall if this was brought up before. Another option is to use an identity. I realize we don’t spin out a new version frequently so this may not be an issue. And probably with a new version other changes would be needed anyway…

- Last-reporter is present under the group and also under each source entry. Is the one under the group the last host from all sources?

- Leaf node require-router-alert. What happens if it’s set to true and the IP hdr does not contain RA? Consider updating description and/or adding a reference.

Minor
=====

- Leaf “host-address”, rename to “address” since the list is called host (no need to duplicate host).

Regards,
Reshad.