Subject: Re: [Last-Call] [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Fri, 10 Sep 2021 18:09:58 +0000

Hi authors,

One question on the draft Page #11, last paragraph;

   "  The ASBRs in an AS originate per-region I-PMSI A-D routes and

      advertise to their external peers to advertise tunnels used to

      carry traffic from the local AS to other ASes.  Depending on the

      types of tunnels being used, the L flag in the PTA may be set, in

      which case the downstream ASBRs and upgraded PEs will send Leaf

      A-D routes to pull traffic from their upstream ASBRs."

How do we originate these per-region I-PMSI?

Is it implied that there are EVI configuration at the ASBR?

Or this is a local decision and is not to be discussed in the standard.

In L23VPN, usually ASBRs do not have VRFs configured. Therefore asking this question.

Thanks,

--Satya

On 8/24/21, 7:38 AM, "BESS on behalf of The IESG" <[email-masked] on behalf of [email-masked]> wrote:

    The IESG has received a request from the BGP Enabled ServiceS WG (bess) to

    consider the following document: - 'Updates on EVPN BUM Procedures'

      <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> as Proposed Standard

    The IESG plans to make a decision in the next few weeks, and solicits final

    comments on this action. Please send substantive comments to the

    [email-masked] mailing lists by 2021-09-07. Exceptionally, comments may

    be sent to [email-masked] instead. In either case, please retain the beginning

    of the Subject line to allow automated sorting.

    Abstract

       This document specifies procedure updates for broadcast, unknown

       unicast, and multicast (BUM) traffic in Ethernet VPNs (EVPN),

       including selective multicast, and provider tunnel segmentation.

       This document updates RFC 7432.

    The file can be obtained via

    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-bum-procedure-updates/

    No IPR declarations have been submitted directly on this I-D.

    _______________________________________________

    BESS mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/bess

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 14 Sep 2021 19:30:51 +0000

Hi Satya,

That is part of the optional procedure to provide backwards compatibility. An implementation would likely to have configuration controlling whether this procedure is used or not.

For the origination of per-region I-PMSI routes, whether it is for the purpose of backwards compatibility or just for the aggregation purpose, some provisioning is needed – at least to enable per-region aggregation (perhaps at per-VPN level). We are adding per-VPN signaling and procedures, so per-VRF configuration should be reasonable (at least on the source ASBRs).

In summary, that is indeed a local implementation issue.

Thanks!
Jeffrey

From: Satya Mohanty (satyamoh) <[email-masked]>
Sent: Friday, September 10, 2021 2:10 PM
To: [email-masked]; IETF-Announce <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

[External Email. Be cautious of content]

Hi authors,

Thanks,

--Satya

On 8/24/21, 7:38 AM, "BESS on behalf of The IESG" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    [email-masked]<mailto:[email-masked]> mailing lists by 2021-09-07. Exceptionally, comments may

    be sent to [email-masked]<mailto:[email-masked]> instead. In either case, please retain the beginning

    Abstract

    BESS mailing list

    [email-masked]<mailto:[email-masked]>

Juniper Business Use Only

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Wed, 15 Sep 2021 00:50:01 +0000

Hi Jeffrey,

Thanks for your reply.
It makes perfect sense.

Am I to assume that the same reasoning applies to Inter-as MVPN as well since EVPN BUM procedures is based significantly on MVPN procedures?

Best Regards,
--Satya

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tuesday, September 14, 2021 at 12:31 PM
To: "Satya Mohanty (satyamoh)" <[email-masked]>, "[email-masked]" <[email-masked]>, IETF-Announce <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

Hi Satya,

Thanks!
Jeffrey

Hi authors,

Thanks,

--Satya

    Abstract

    BESS mailing list

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 15 Sep 2021 21:04:55 +0000

Hi Satya,

Yes it applies to MVPN as well. I am actually in the process of writing a draft to formally extend the inter-region segmentation and per-region aggregation to MVPN, and to do intra-region segmentation for assisted replication purpose.

Jeffrey

From: Satya Mohanty (satyamoh) <[email-masked]>
Sent: Tuesday, September 14, 2021 8:50 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]; IETF-Announce <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

Hi Jeffrey,

Thanks for your reply.
It makes perfect sense.

Best Regards,
--Satya

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 14, 2021 at 12:31 PM
To: "Satya Mohanty (satyamoh)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

Hi Satya,

Thanks!
Jeffrey

From: Satya Mohanty (satyamoh) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 10, 2021 2:10 PM
To: [email-masked]<mailto:[email-masked]>; IETF-Announce <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] Last Call: <draft-ietf-bess-evpn-bum-procedure-updates-09.txt> (Updates on EVPN BUM Procedures) to Proposed Standard

Hi authors,

Thanks,

--Satya

    Abstract

    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-bum-procedure-updates/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-bum-procedure-updates/__;!!NEt6yMaO-gk!Smhs6XNSbkHG1o77T1NpUrm2fzPRSjOHHX7fBEDm_wvWo4RbJZFl8aZvMYPwgZis$>

    BESS mailing list

    https://www.ietf.org/mailman/listinfo/bess<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bess__;!!NEt6yMaO-gk!Smhs6XNSbkHG1o77T1NpUrm2fzPRSjOHHX7fBEDm_wvWo4RbJZFl8aZvMTGb0kLQ$>