Subject: Re: [Last-Call] Last Call: <draft-danyliw-replace-ftp-pointers-03.txt> (Updating References to the IETF FTP Service) to Proposed Standard

From: tom petch <[email-masked]>
Date: Mon, 6 Sep 2021 09:25:31 +0100

On 30/08/2021 15:22, The IESG wrote:
>
> The IESG has received a request from an individual submitter to consider the
> following document: - 'Updating References to the IETF FTP Service'
>    <draft-danyliw-replace-ftp-pointers-03.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-09-27. Exceptionally, comments may
> be sent to [email-masked] instead. In either case, please retain the beginning
> of the Subject line to allow automated sorting.

If I cut and paste the https: URI intoa browser, some fail.  This is to 
be expected as some have been folded over two lines to meet the 
requirements of publication as an RFC.

This is not a new problem.  Indeed, there is a technical solution in the 
shape of RFC8792 which prescribes the use of backslash to denote where 
such folding has occurred.  This technique is not as widely known as it 
might be - I have seen comments on directorate lists on the lines of 
'What is this?' - but it does offer a solution.  I leave it up to the 
author as to whether or not this approach would be an improvement here.

Tom Petch

> Abstract
>
>
>     The IETF FTP service running at ftp.ietf.org, ops.ietf.org and
>     ietf.org will be retired.  A number of published RFCs in the IETF and
>     IAB streams include URIs that reference this FTP service.  To ensure
>     that the materials referenced using the IETF FTP service can still be
>     found, this document updates the FTP-based references in these
>     affected documents with HTTPS URIs.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-danyliw-replace-ftp-pointers/
>
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
> .
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 6 Sep 2021 12:00:01 +0200

On 30. Aug 2021, at 17:36, Roman Danyliw <[email-masked]> wrote:
> 
> The reasoning that motivated this document being PS was that it was updating other PS documents.  No more nuance than that.

Too lazy to check:
Are there any documents being updated that should not be BCPs in the first place?

Maybe this could be one more element of the “updates” discussion — a BCP can update a standards-track document that only became that way because at the time BCP hadn’t been invented yet.

Grüße, Carsten