Subject: [Last-Call] Intdir telechat review of draft-ietf-opsawg-ntf-10

From: Jean-Michel Combes via Datatracker <[email-masked]>
Date: Wed, 24 Nov 2021 03:41:28 -0800

Reviewer: Jean-Michel Combes
Review result: Almost Ready

Hi,

I am an assigned INT directorate reviewer for draft-ietf-opsawg-ntf-10. These
comments were written primarily for the benefit of the Internet Area Directors.
Document editors and shepherd(s) should treat these comments just like they
would treat comments from any other IETF contributors and resolve them along
with any other Last Call comments that have been received. For more details on
the INT Directorate, see https://datatracker.ietf.org/group/intdir/about/
<https://datatracker.ietf.org/group/intdir/about/>.

Based on my review, if I was on the IESG I would ballot this document as
DISCUSS.

I have the following DISCUSS:

The document is well written and gives a good overview of the telemetry
“environment”. But, I am really embarrassed by a sentence – hidden in a section
not always read at the end of the document: “6.  Security Considerations
...
The Network Telemetry Framework is not applicable to networks whose endpoints
represent individual users, such as general-purpose access networks.”

Here are the reasons regarding this DISCUSS
(1)     I assume next IETF works on Telemetry will be based on this document;
(2)     Such a disclaimer should be clearly mentioned at the beginning of the
document to avoid any future IETF proposal, based on this document, in the
scope of this disclaimer; (3)     A clarification of this disclaimer is needed.
Indeed, this disclaimer is closing many useful use-cases like E2E telemetry
(i.e., between customer device/application and provided service) for a service
provider or, if I understand correctly this disclaimer, Telemetry based
management of a personal IoT network (e.g., at home) by an end-user.

The following are minor issues (typos, misspelling, minor text improvements)
with the document:

Some references need to be updated but this should be done during the RFC
Editor process.

Best regards,

JMC.

---

From: Haoyu Song <[email-masked]>
Date: Wed, 24 Nov 2021 18:52:26 +0000

Hi Jean,

Thank you very much for the review! Based on your suggestion,  we'll move the disclaimer to the beginning of the document and provide more clarification. 

Best regards,
Haoyu

-----Original Message-----
From: Jean-Michel Combes via Datatracker <[email-masked]> 
Sent: Wednesday, November 24, 2021 3:41 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Intdir telechat review of draft-ietf-opsawg-ntf-10

Hi,

I am an assigned INT directorate reviewer for draft-ietf-opsawg-ntf-10. These comments were written primarily for the benefit of the Internet Area Directors.
Document editors and shepherd(s) should treat these comments just like they would treat comments from any other IETF contributors and resolve them along with any other Last Call comments that have been received. For more details on the INT Directorate, see https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fgroup%2Fintdir%2Fabout%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C77ca751175644cd8d80108d9af3f5b17%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637733508927650895%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Sqcy5PJgbAQouh7b49rlIOvrGhOAA4tF5wpNf1bE9UM%3D&amp;reserved=0
<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fgroup%2Fintdir%2Fabout%2F&amp;data=04%7C01%7Chaoyu.song%40futurewei.com%7C77ca751175644cd8d80108d9af3f5b17%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637733508927650895%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Sqcy5PJgbAQouh7b49rlIOvrGhOAA4tF5wpNf1bE9UM%3D&amp;reserved=0>.

Based on my review, if I was on the IESG I would ballot this document as DISCUSS.

The document is well written and gives a good overview of the telemetry "environment". But, I am really embarrassed by a sentence - hidden in a section not always read at the end of the document: "6.  Security Considerations ...
The Network Telemetry Framework is not applicable to networks whose endpoints represent individual users, such as general-purpose access networks."

Indeed, this disclaimer is closing many useful use-cases like E2E telemetry (i.e., between customer device/application and provided service) for a service provider or, if I understand correctly this disclaimer, Telemetry based management of a personal IoT network (e.g., at home) by an end-user.

The following are minor issues (typos, misspelling, minor text improvements) with the document:

Some references need to be updated but this should be done during the RFC Editor process.

Best regards,

JMC.