Subject: [Last-Call] Rtgdir last call review of draft-ietf-lsr-isis-flood-reflection-05

From: Michael Richardson via Datatracker <[email-masked]>
Date: Thu, 25 Nov 2021 12:03:56 -0800

Reviewer: Michael Richardson
Review result: Has Issues

Subject: RtgDir Last Call review: draft-ietf-lsr-isis-flood-reflection-05

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The
Routing Directorate seeks to review all routing or routing-related drafts as
they pass through IETF last call and IESG review, and sometimes on special
request. The purpose of the review is to provide assistance to the Routing
ADs. For more information about the Routing Directorate, please see
​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF Last
Call comments that you receive, and strive to resolve them through discussion
or by updating the draft.

Document: draft-ietf-lsr-isis-flood-reflection-05
Reviewer: Michael Richardson
Review Date: 2021-11-25
IETF LC End Date: 2021-12-17
Intended Status: Standards Track

Summary:

This document is basically ready for publication but has nits that should be
considered prior to publication.

(As a person with little ISIS knowledge, but BGP experience, I was able to pick
things up. Good Job!)

Comments:

The use of _L1_/_L2_ is an ISIS terminology, which goes back to RFC1195, I
found. Any reader who is not intimate with ISIS won't know this terminology,
which in RFC1195 is "Level 1" and "Level 2", so please add this to the
glossary, and/or reference 1195.

Major Issues:

No major issues found.

Minor Issues:

I prefer to have the Introduction tell me something about the problem space
before the Glossary floods (pun intended) me with terms, but perhaps document
structure is different in LSR.

Please label the diagram better:
      Figure 1: _Example Topology_
      -> _Example Topology of attempt to extend L2 with L1_

or something like that.  I think it's the thing that doesn't work.
Have you tried running goat on this diagram?  Would look nice in SVG.

Figure 3 does nothave an R22, but it is mentioned in the paragraph on page 6.

Section 4: there are only three bytes in the first line. This is surprising.
        Same in section 5. Maybe something about ISIS stuff I don't know.
   I would have put sections 4,5,6,7 into a Section "Protocol Extensions", but
   that's just me.

Section 9: what happens if the MUSTs on Cluster ID are violated?
        What is the defensive situation?  Does this force flag days?

On the whole, I wonder if this draft hasn't really created an "L3" area, and
calling it that might lead to a clearer situation.

I'm not sure that I agree with _Security Considerations_.
If there are tunnels everywhere in this core, doesn't this present new
opportunities to impersonate devices?

Nits:

I found no obvious nits

---

From: Antoni Przygienda <[email-masked]>
Date: Fri, 26 Nov 2021 18:26:56 +0000

Mike, thanks, all very clever comments in fact, answers inline and addressed in new version  -06 just publihsed

-- tony

On 25/11/2021, 21:04, "Michael Richardson via Datatracker" <[email-masked]> wrote:

    [External Email. Be cautious of content]

    Hello,

    ​https://urldefense.com/v3/__http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir__;!!NEt6yMaO-gk!XQhToJXI4pNYTGrieIkCsFdfXcQ8p41021ar053-BE08veMeJYLJMo9Oq0ZOjQ$

    Summary:

    Comments:

    Major Issues:

    No major issues found.

    Minor Issues:

Prz> I move glossary behind intro and start the intro by indicating that in case of
Unfamiliar terms it can be referenced.

PRz> no ambition to SVG this since I don't think it will clarify much here. We have whole rift in SVG, it was bit of an exercise to get around all its warts ...

Prz> yes, it refers to R22 in figure 2, I added a hint.

Prz> yes, unusual. ISIS is very dense and every byte counts and alignment is often omitted for that reason so we chose to represent it like this. Format is correct. I summarized TLVs in a section called Encodings as you suggest.

Prz> no flag day. Added treatement if Cluster IDs MUST are not met and other cases where the MUST could be violated and a detection/treatement is imaginable.

Prz> no, it does not albeit in a certain sense it "mocks" another level of hierarchy since one could run a 2 level OSPF instead of ISIS L1 here. Those kinds of considerations are outside of the scope of the spec. If someone starts an applicability/deployment-guidelines draft that would be a good place for it maybe.

Prz> added that tunnel auto-discovery is subject to ISIS security/information spoofing and that statically configured tunnels are a possibl attack vector if not secured

Juniper Business Use Only