Subject: Re: [Last-Call] Last Call: <draft-ietf-6man-mtu-option-12.txt> (IPv6 Minimum Path MTU Hop-by-Hop Option) to Experimental RFC

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 7 Feb 2022 16:03:37 +0000

I will repeat what I said; getting this right the first time is trivial and ignoring it the
first time ruins the opportunity to use it for bigger and better purposes for forever.

Bob objects that there has been little uptake in jumbograms, but the correct
statement is that there has been little uptake *until now* - IP Parcels will change
all of that. And, not just for the local link, but over the entire path.

An example: Source -> 4M -> 2M -> 512K -> 256K -> 1M -> 3M -> Destination.
In that case, the MTU option had better report 256K.

I will now briefly take up the subject of bull-throwing. I think many of the people
we have seen in these discussions and elsewhere are very skilled in the art of
throwing the bull. Some virtuous few others are genuine in their approach and
want the best technical outcome. I would say to them be authentic; be genuine;
be yourself, and do not succumb to the ways of the hardcore bull-throwers.

Thanks - Fred

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 7 Feb 2022 16:19:48 +0000

> be yourself, and do not succumb to the ways of the hardcore bull-throwers.

I'm sorry but I also agree with Bob: I don't see that your proposal 
relates to the IPv6 deployment scenario in the IETF-LC. At this time, we 
haven't seen vendors with support for more than 16 KB frames (for 
various reasons I'll let them explain), and despite some deployment in 
DCs we have yet to see many operational Internet paths that allow more 
than ~ 2 KB.

I'll look forward with interest to seeing the level of support to deploy 
4MB MTUs (or whatever size you target) in INTAREA and how challenges 
will be addressed, but I don't see this as a great reason for growing 
the size of the IPv6 HBH PMTU option.

Gorry

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 7 Feb 2022 16:33:59 +0000

Gorry, either you did not read my concluding paragraph or you read it and are
fully on board with it. It is good that we have list archives, which are a close
second to RFCs in terms of being a permanent record.

Thanks - Fred

> -----Original Message-----
> From: Gorry Fairhurst [mailto:[email-masked]]
> Sent: Monday, February 07, 2022 8:20 AM
> To: Templin (US), Fred L <[email-masked]>; Bob Hinden <[email-masked]>; IPv6 List <[email-masked]>; Brian E
> Carpenter <[email-masked]>
> Cc: [email-masked]; [email-masked]; Tom Herbert <[email-masked]>
> Subject: [EXTERNAL] Re: Last Call: <draft-ietf-6man-mtu-option-12.txt> (IPv6 Minimum Path MTU Hop-by-Hop Option) to Experimental RFC
> 
> EXT email: be mindful of links/attachments.
> 
> 
>