Subject: RE: Refering to X.500 editions

From: "Slone, Skip" <[email-masked]>
Date: Fri, 20 Apr 2001 14:30:23 -0400

I'm not sure of the answers to these questions.  I will follow up with Hoyt
and report back.

 -- Skip

-----Original Message-----
From: Kathy Dally [mailto:[email-masked]] 
Sent: Friday, April 20, 2001 9:56 AM
To: Slone, Skip
Cc: ietf-ldapbis
Subject: Re: Refering to X.500 editions

Hi Skip!

The fourth edition has been approved, but not published, as far as I can
tell.  

Does out-of-maintenance mean that the second edition will not be available
from ITU and ISO/ANSI?  Removal of the approved draft text from the
OSIDirectory server is usually an accurate signal.  I think that would be
the biggest concern.

Thanks,
Kathy

"Slone, Skip" wrote:
> 
> Kathy,
> 
> Unless I'm mistaken, when the fourth edition was approved earlier this 
> year, the second edition (1993) went out of maintenance, meaning no 
> further defects will be processed on it.  Is there likely to be a 
> problem referencing an out-of-maintenance standard as the base?
> 
> If it is a problem, we would need to check with Hoyt to confirm my 
> understanding of the maintenance status before making any changes.
> 
>  -- Skip
> 
> -----Original Message-----
> From: Kathy Dally [mailto:[email-masked]]
> Sent: Thursday, April 19, 2001 2:33 PM
> To: ietf-ldapbis
> Subject: Refering to X.500 editions
> 
> Hi All!
> 
> In RFC 2256 the X.500 reference is to 1996.  Unfortunately, this is 
> not an official date (see below).  Since 1997 is closer to 1996 than 
> 1993, the draft replacement for RFC 2256
> (<draft-ietf-ldapbis-user-schema-00.txt>) refers to X.500 (1997).  In 
> fact, RFC 2256 includes some attributes that were introduced in X.520 
> (1997). However, other LDAPv3 core RFCs refer to X.500 (1993).
> 
> In order to align the replacement RFCs, I propose to cite X.500 (1993) 
> in the title and references of 
> <draft-ietf-ldapbis-user-schema-01.txt>.
> In addition, X.520 (1997) should be a separate reference in the I-D, to be
> referred to when describing the new attributes.
> 
> Does this make sense?  Please let me know.
> 
> Below is material about the different X.500 editions and their ISO/IEC 
> 9594 twins.  Credit is given to Hoyt Kesterson, ISO/IEC 9594 Editor, 
> for most of the information.  I hope this will be useful to the WG.
> 
> Thanks,
> Kathy Dally
> 
> ----------------
> 
> Although the X.500 Recommendations and ISO/IEC 9594 were aligned in 
> the first edition and identical ever since, the official dates on the 
> standards are different:
> 
>         *  X.500 Recs (ITU) date is the date of approval.
> 
>         *  ISO/IEC 9594 date is the date of publication.
> 
> Since a considerable amount of preparation is done between approval 
> and publication, the dates of the two standards have been different:
> 
>         *  first edition:  X.500 (1988) and ISO/IEC 9594:1990
> 
>         *  second edition:  X.500 (1993) and ISO/IEC 9594:1995
> 
>         *  third edition:  X.500 (1997) and ISO/IEC 9594:1998
> 
>         *  fourth edition, currently being published:  X.500 (2001) 
> and ISO/IEC 9594:2001,
>            except for X.509 (2000) and ISO/IEC 9594-8:2000
> 
> Note that ISO/IEC also uses "edition" to mean the "issue number" of 
> the part of 9594.  This is the meaning of "Edition" on the face of 
> ISO/IEC 9594 parts.  The key is the DATE.
> 
> The first edition (overall) includes these recommendations and 
> standard
> parts:
> 
>         *  X.500 - ISO/IEC 9594-1
> 
>         *  X.501 - ISO/IEC 9594-2
> 
>         *  X.509 - ISO/IEC 9594-8
> 
>         *  X.511 - ISO/IEC 9594-3
> 
>         *  X.518 - ISO/IEC 9594-4
> 
>         *  X.519 - ISO/IEC 9594-5
> 
>         *  X.520 - ISO/IEC 9594-6
> 
>         *  X.521 - ISO/IEC 9594-7
> 
> The second edition added X.525 - ISO/IEC 9594-9:1995, 1st ed.
> 
> The third edition added X.530 - ISO/IEC 9594-10:1998, 1st ed.
> 
> The fourth edition does not have any additional recommendations or 
> parts.

---

From: "Slone, Skip" <[email-masked]>
Date: Fri, 20 Apr 2001 14:30:23 -0400

-- Skip

-----Original Message-----
From: Kathy Dally [mailto:[email-masked]] 
Sent: Friday, April 20, 2001 9:56 AM
To: Slone, Skip
Cc: ietf-ldapbis
Subject: Re: Refering to X.500 editions

Hi Skip!

Thanks,
Kathy