Subject: RE: implementation quiz: ;binary

From: "Salter, Thomas A" <[email-masked]>
Date: Mon, 16 Apr 2001 08:52:24 -0400

> -----Original Message-----
 > From: Kurt D. Zeilenga [mailto:[email-masked]]
 > Sent: Friday, April 13, 2001 6:14 PM
 > To: [email-masked]
 > Subject: implementation quiz: ;binary
 > 
 > 
 > Please provide a separate response for each application of
 > interest.  There is no need to respond if you have not
 > implemented ;binary transfer of attribute types.  This is
 > only a partial quiz aimed at getting a general idea of the
 > level of interoperability.
 > 
 > Implementor: Unisys Corporation
 > Application: TransIT 500 Directory Server
 > Application Class: [ ] client, [X] server
 > 
 > Have you implemented ;binary transfer of attributes?
 > 
Yes.
 > Is this support specific to particular syntaxes and/or attributes?
 > If so, which syntaxes and attributes?
 > 
No.  ;binary is supported for all attributes and syntaxes.

 > Do you support non-;binary transfer for any syntax and/or
 > attribute which you support ;binary transfer for?
 > 
Yes.  Any attribute for which a string syntax is defined can also
be transfered in BER.
 > Does your application ensure values it sends using ;binary are
 > restricted to a valid BER encoding of the attribute's syntax?
 > 
Yes.

 > Does your application treat non-BER encoded values received
 > using ;binary as an error?  If so, what error?
 > 
Yes.  invalidAttributeSyntax

 > Does your application treat BER encoding of values of incorrect
 > using ;binary as an error?  If so, what error?
 > 
Yes.  invalidAttributeSyntax

 > Does your application expect values to be encoded using a
 > subset of BER?  If so, which subset?
 > 
No.

 > Comments:
 This is an X.500-based directory server.  Since handling BER encoded
attributes is required for DAP, it was natural to handle ;binary for 
all attributes in LDAP.

---

From: "Timothy Hahn" <[email-masked]>
Date: Tue, 17 Apr 2001 15:18:18 -0400

Kurt,

Implementor: IBM
Application:  SecureWay Directory (AIX, NT, Solaris, OS/400, OS/390, z/OS)
Application Class: [X] client, [X] server

Yes

Is this support specific to particular syntaxes and/or attributes?
If so, which syntaxes and attributes?
Yes,
 attributeCertificate,
 authorityRevocationList,
 caCertificate,
 certificateRevocationList,
 crossCertificatePair,
 deltaRevocationList,
 supportedAlgorithms,
 userCertificate,
 userSMIMECertificate only

Do you support non-;binary transfer for any syntax and/or
attribute which you support ;binary transfer for?
No,
 The attributes can be requested without the ";binary"
 option, but what is returned is the binary data for each
 of the values.

Does your application ensure values it sends using ;binary are
restricted to a valid BER encoding of the attribute's syntax?
No.
 Whatever is stored (during the add/modify operation) is what
 is returned.  The values are not checked for a valid BER encoding.

Comments:
It is possible to mark other attributes (Binary syntax only) such
that ";binary" can be requested for those attributes.  This is done
by modifying the schema definition for those attributes.

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681

---

From: "Volpers, Helmut" <[email-masked]>
Date: Wed, 18 Apr 2001 14:05:05 +0200

> Sent: Samstag, 14. April 2001 00:14
> Implementor: Siemens
> Application: DirX 
Yes.
 
> If so, which syntaxes and attributes?
No, in principle you can use it for every attribute

Yes.

Yes.
> using ;binary as an error?  If so, what error?

Yes. unwillingToPerform
> using ;binary as an error?  If so, what error?

I think this doesn't apply to our server. If the BER encoding is correct
the ;binary cannot be used incorrect. ?

No.

Helmut