Subject: Re: Models: Change of structural object class

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 01 Feb 2003 10:45:41 -0800

At 11:57 AM 1/31/2003, Hallvard B Furuseth wrote:
>[Models] 3.3 (The 'objectClass' attribute) says:
>
>  Servers which follow X.500(93) models SHALL restrict modifications of
>  this attribute to prevent the basic structural class of the entry from
>  being changed.  That is, one cannot change a 'person' into a
>  'country'.
>
>This statement is redundant, because 2.4.2 (Structural Object Classes)
>says:
>
>        The structural object class of an entry shall not be changed.

I don't consider these statements as being redundant.  The first
is describing the data model.  The second says servers are
responsible for ensuring this part of the model is adhered to.

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 10 Feb 2003 17:17:38 +0100

> responsible for ensuring this part of the model is adhered to.

Aren't servers responsible for ensuring that all of the model is adhered
to anyway?  If not, I think they should be.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 10 Feb 2003 09:09:50 -0800

At 08:17 AM 2/10/2003, Hallvard B Furuseth wrote:
>to anyway?

Well I think LDAP servers MUST act in accordance with the X.500
model, I don't agree that they are responsible for ensuring all
aspects of the model are adhered to.  At some level, there will
be "garbage in, garbage out" problem.  The solution to that
problem is at the client (which provides the garbage).

Kurt