Subject: RE: Attribute Name Length Bounds

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 17 Jul 2003 17:48:20 +1000

Hi Jim,
 
Is there a point to the 'clarification'? Isn't it like saying that all octets of a JPEG file are significant? Sorry, I don't see the point.
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Thursday, 17 July 2003 07:39
To: [email-masked]
Subject: RE: Attribute Name Length Bounds

All,
 
At this point it seems clear that it would be a good thing to make a clarification to [Protocols]. That clarification would state something like: all octets of a ber-encoded LDAP PDU are significant. No octets may be ignored unless they are part of extended elements that are themselves ignored.
 
Whether or not we want the TS to enforce mandatory minimums for element lengths (such as attribute type names) is an issue in the data model (and/or schema) doc(s).
 
Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 17 Jul 2003 02:35:22 -0600

I think you're right, it doesn't cross the typical mind that one can
silently ignore sections of values. Apparently it did cross the mind of
at least one implementor, as it was pointed out in the IETF57 LDAPBIS
meeting that at least one implementor ignores some octets in certain PDU
values.
 
I believe there is text in X.680 that specifies that all octets are
significant--this clarification would really just be a repetition of
that statement. Maybe another way of looking at it is: this is an item
called out in a reference document that we need to carry into the
referring document because people aren't fully reading or understanding
the reference document.
 
Jim

>>> "Ramsay, Ron" <[email-masked]> 7/17/03 9:48:20 AM >>>

Hi Jim,
 
Is there a point to the 'clarification'? Isn't it like saying that all
octets of a JPEG file are significant? Sorry, I don't see the point.
 
Ron
-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Thursday, 17 July 2003 07:39
To: [email-masked]
Subject: RE: Attribute Name Length Bounds

All,
 
At this point it seems clear that it would be a good thing to make a
clarification to [Protocols]. That clarification would state something
like: all octets of a ber-encoded LDAP PDU are significant. No octets
may be ignored unless they are part of extended elements that are
themselves ignored.
 
Whether or not we want the TS to enforce mandatory minimums for element
lengths (such as attribute type names) is an issue in the data model
(and/or schema) doc(s).
 
Jim

---

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 17 Jul 2003 18:57:01 +1000

Was the implementer actually ignoring octets in the PDU or was the implementer in fact ignoring octets in values taken from the PDU? It would seem strange, nay impossible, to ignore octets in a PDU. This means you would read the ID, read the length, take the first 20 bytes then .. what? Stop? If you stop taking bytes then you may not be at the next tag, so the decode would fail. If you continue taking bytes but don't store them, then you do regard the bytes in the PDU as significant.
 
Therefore, I don't believe you can EVER ignore bytes IN a PDU. You may ignore them after slecting the value from the PDU, but not IN the PDU.
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Thursday, 17 July 2003 18:35
To: Ramsay, Ron; [email-masked]
Subject: RE: Attribute Name Length Bounds

I think you're right, it doesn't cross the typical mind that one can silently ignore sections of values. Apparently it did cross the mind of at least one implementor, as it was pointed out in the IETF57 LDAPBIS meeting that at least one implementor ignores some octets in certain PDU values.
 
I believe there is text in X.680 that specifies that all octets are significant--this clarification would really just be a repetition of that statement. Maybe another way of looking at it is: this is an item called out in a reference document that we need to carry into the referring document because people aren't fully reading or understanding the reference document.
 
Jim

Hi Jim,

Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Thursday, 17 July 2003 07:39
To: [email-masked]
Subject: RE: Attribute Name Length Bounds

All,

 
Jim