Subject: ABNF of numericoid

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 09 Jul 2003 16:45:34 -0600

All,

In [Models], we define:
numericoid = number *( DOT number )

This allows an invalid oid like 23.666.<whatever>

Are there usages of numericoid that need to allow these non-valid oids?
If not, I think it'd be better to show the proper restrictions on the
first two numbers.

Jim

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 10 Jul 2003 13:57:00 +0200

> If not, I think it'd be better to show the proper restrictions on the

Including the restriction that there should be at least two numbers,
IIRC.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 14 Jul 2003 05:54:08 +0200

>If not, I think it'd be better to show the proper restrictions on the

I think it inappropriate to restrict the syntax of a OID
based upon current assignments and assignment practices.
These are subject to change.   numericoid, like the BER
encoding of an OID, needs to be capable of representing
any OID value allowed by X.680.

For example, 3 is a valid representation of an unassigned
OID. It may one day be assigned.  However, assigned or not,
3 may be a reasonable value of an attribute of syntax OID.

I can think of a number of applications where storing
unassigned OIDs in a directory may be useful.  For example,
in an application which tracked usage of unassigned OIDs in
Internet protocols.

Kurt