Subject: RE: Protocol: attribute selection

From: "Ramsay, Ron" <[email-masked]>
Date: Tue, 16 Mar 2004 11:16:32 +1100

You've simply replaced 'election' with 'electors'. How can this help? Also, to preserve alignment with X.500, I think you should retain the word 'selection' for the SEQUENCE.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Kurt D. Zeilenga
Sent: Tuesday, 16 March 2004 08:33
To: Hallvard B Furuseth
Cc: [email-masked]
Subject: Re: Protocol: attribute selection

At 01:09 PM 3/15/2004, Hallvard B Furuseth wrote:
>I think an earlier message about this may have gotten lost:
>
>In [protocol]-22 4.5.1 (Search Request),
>
>the ASN.1 list of attributes has the confusing names
>
>        AttributeSelection ::= SEQUENCE OF selection LDAPString 
>                -- constrained to <attributeSelection> below 
>
>so in plain language, the attributes are a selection of a selection.

Seems it would be better:
        AttributeSelectors ::= SEQUENCE of selector LDAPString
                -- selector constrained to <attributeSelector>

....

Kurt

>Also, it is selection and not AttributeSelection which is constrained to
><attributeSelection>, which is the syntax for _one_ attribute:
>
>     attributeSelection = attributedescription / selectionspecial 
>
>So an AttributeSelection is a sequence of attributeSelections...
>
>I suggest to call the ABNF token and the 'selection' ASN.1 name
>'requestedAttribute', 'searchAttr' or something.
>
>-- 
>Hallvard

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 16 Mar 2004 00:33:44 -0700

>>> Hallvard B Furuseth <[email-masked]> 3/15/04 2:09:43 PM
>>>

I would say it is a sequence of strings, but we may have a different
way of reading things.

><attributeSelection>, which is the syntax for _one_ attribute:

Yes, I'll make that more clear.

>So an AttributeSelection is a sequence of attributeSelections...

No, it's a SEQUENCE OF LDAPString. The identifier 'selection' is just
naming the LDAPString (this was done for
http://www.openldap.org/lists/ietf-ldapbis/200310/msg00007.html). We
could come closer to X.500 and call it select, or as Kurt suggested,
call it selector (except I'd leave the name of the type as
AttributeSelection).
 
I will change the identifier to selector unless anyone objects.
 
Jim