Subject: RE: Distinguished values

From: "Ramsay, Ron" <[email-masked]>
Date: Tue, 16 Mar 2004 11:10:13 +1100

Yes, but you can't match attributes, only attribute values!

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Hallvard B Furuseth
Sent: Tuesday, 16 March 2004 06:36
To: Kurt D. Zeilenga
Cc: [email-masked]
Subject: Re: Distinguished values

Kurt D. Zeilenga writes:
> For instance, 2.2.1's
>   These AVAs are chosen from the attributes of the entry.
> could be replaced with:
>   These AVAs are chosen to match attributes of the entry.
> 
> And 2.5.4's
>   When an attribute is used for naming of the entry, one and only one
>   value of the attribute is selected to appear in the Relative
>   Distinguished Name.  This value is known as a distinguished value.
> 
> could be reworded:
>   When an attribute is used for naming of the entry, one and only
>   one value of that attribute is used in forming the Relative
>   Distinguished Name.  This value is known as a distinguishing
>   value.

Sounds good to me, except s/distinguishing/distinguished/ according to
X.500(1993).

I failed to come up with brief enough wordings myself.

-- 
Hallvard

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 16 Mar 2004 12:11:09 -0700

>>> Hallvard B Furuseth <[email-masked]> 3/16/04 6:38:36 AM
>>>
>> - newrdn: the new RDN of the entry. If an attribute value in the 
>> newrdn does not already exist in the entry (either as part of the 
>^^^^^^^^^^^^^^^^^^^^^
>> old RDN or as a non-distinguished value), it is added. If it
>^^^^^^^
>> cannot be added, an appropriate error is returned. 
>
>But the RDN - and thus the values it contains - is not part of the
>entry. Besides, this wording implies that the values in the RDN must
be
>identical to the distinguished values, not merely equivalent. Maybe:

I don't understand what you're asserting here. As I understand it, each
AVA in the entry's RDN is made up of distinguished attribute values held
in the entry. 
From X.501:
<
Relative Distinguished Names
Each object and entry has a relative distinguished name (RDN). An RDN
of an object or alias entry consists of a set of attribute type and
value pairs, each of which matches, using the equality matching rule, a
distinct distinguished attribute value of the entry. 

Thus, in order for the RDN to contain an AVA, that attribute value (ok,
an attribute value equivalent to the AVA) must exist in the entry. So if
it doesn't, one must be added, thus the language above.

Maybe your definition of "identical" means "the same copy", and you're
asserting that the RDN may use equivalent copies of the distinguished
values held in the entry.

>- newrdn: the new RDN of the entry. Attribute values in the new
>RDN that had no matching values in the entry (and thus did
>not exist in the old RDN), are added to the entry.

I suggest:

- newrdn: the new RDN of the entry. If the operation moves the 
  entry to a new superior without changing its RDN, the old RDN
  is supplied for this parameter.
  Attribute values of the new RDN not matching any attribue value
  of the entry are added to the entry and an appropriate error is 
  returned if this fails.

Jim