Subject: RE: current control combination proposals

From: "Ramsay, Ron" <[email-masked]>
Date: Mon, 17 May 2004 17:03:09 +1000

No, not "so far".

If LDAP is to remain aligned with, or at least interoperable with, X.500, then constraintViolation has to remain an update problem.

Ron

-----Original Message-----
From: Chris Ridd [mailto:[email-masked]]
Sent: Monday, 17 May 2004 16:08
To: Ramsay, Ron
Cc: [email-masked]
Subject: Re: current control combination proposals

On 17/5/04 2:44 am, Ramsay, Ron <[email-masked]> wrote:

> constrainViolation is only appropriate for update operations.

So far.

Cheers,

Chris

---

From: Chris Ridd <[email-masked]>
Date: Mon, 17 May 2004 08:28:37 +0100

On 17/5/04 8:03 am, Ramsay, Ron <[email-masked]> wrote:

> No, not "so far".
> 
> If LDAP is to remain aligned with, or at least interoperable with, X.500, then
> constraintViolation has to remain an update problem.
> 
> Ron

Of course since X.500 doesn't really have controls like LDAPv3, there's no
real possibility of having incompatible controls in X.500. Using
constraintViolation to report incompatible LDAP control permutations
wouldn't break interworking.

It would be much nicer of course if result codes were somehow extensible,
but that's another problem altogether :-)

Cheers,

Chris