Subject: Attribute value syntax in draft-ietf-ldapbis-protocol-22.txt

From: "Manish Baid" <[email-masked]>
Date: Sat, 22 May 2004 15:50:56 +0530

Hi,
Last section of 4.1.5 of draft-ldap-protocol document is:

Clients MUST only send attribute values in a request that are valid according to the syntax defined for the attributes. 
Does it implies, attribute syntax must be similar to the value syntax (used in assertion).

According to X.500, (X.501 8.7.1 
A matching rule is defined through the specification of:  
--- the range of attribute syntaxes supported by the rule;
  --- the specific types of matches supported by the rule; 
 --- the syntax required to express an assertion of each specific type of match;  
--- rules for deriving a value of the assertion syntax from a value of the attribute syntax, if required.
Which means, a matching rule can define the attribute value syntax it can match for associated attribute syntax.

I am fairly new to X.500 and LDAP, please correct me if I am missing out anything.

Regards,
Manish Baid

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 25 May 2004 09:46:54 -0700

>Does it implies, attribute syntax must be similar to the value syntax (used in assertion).

I don't think the sentence implies anything in this area.

>Which means, a matching rule can define the attribute value syntax it can match for associated attribute syntax.

The matching rule specification states which attribute syntaxes
the rule is applicable to and how that rule is applied to those
values of those syntaxes.

There is no requirement that the assertion syntax and attribute
syntax of a matching rule be "similar".
 
Kurt