Subject: Re: I-D ACTION:draft-ietf-ldapbis-protocol-24.txt

From: Steven Legg <[email-masked]>
Date: Tue, 18 May 2004 15:44:59 +1000

Jim,

Jim Sermersheim wrote:
> I'm curious, what's the difference (since it's a CHOICE and only one
> element can appear in the field)? Is it just some ASN.1 thing?

The difference only matters if one is using PER. PER encodes an element
that is before the ellipsis differently from an element that is after
the ellipsis. If the encoder and decoder don't agree on what is before
and what is after then they won't interwork.

All the other ASN.1 encoding rules encode an element the same way regardless
of whether it is before or after an ellipsis, so it doesn't really matter
where it is for them.

Regards,
Steven

> 
> Jim
> 
> 
>>>>Steven Legg <[email-masked]> 5/17/04 10:07:39 PM >>>
> 
> 
> Jim,
> 
> Just a minor ASN.1 detail. The LDAPMessage.protocolOp CHOICE in RFC
> 2251 did not
> include the intermediateResponse alternative so the extension ellipsis
> should
> probably go before the intermediateResponse alternative rather than
> after it,
> i.e.
>      extendedResp          ExtendedResponse,
>      ...,
>      intermediateResponse  IntermediateResponse },
> 
> Regards,
> Steven
> 
> [email-masked] wrote:
> 
>>A New Internet-Draft is available from the on-line Internet-Drafts
> 
> directories.
> 
>>This draft is a work item of the LDAP (v3) Revision Working Group of
> 
> the IETF.
> 
>>	Title		: LDAP: The Protocol
>>	Author(s)	: J. Sermersheim
>>	Filename	: draft-ietf-ldapbis-protocol-24.txt
>>	Pages		: 61
>>	Date		: 2004-5-11
> 
> 
> 
>

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 19 May 2004 11:32:58 +0200

Steven Legg writes:
> the ellipsis.

If intermediateResponse is added after the ellipsis, and a future LDAP
standard adds yet another LDAPMessage type, where should that be added?
Between the ellipsis and intermediateResponse?

-- 
Hallvard

---

From: Steven Legg <[email-masked]>
Date: Thu, 20 May 2004 10:14:43 +1000

Hallvard,

> standard adds yet another LDAPMessage type, where should that be added?

After intermediateResponse. The ellipsis is placed at the end of the alternatives
in the original base definition (which I would take to be the one in RFC 2251).
Each extension thereafter is appended to the end.

Regards,
Steven