Subject: RE: Protocol: control combinations

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 May 2005 10:52:29 +1000

Way-hay-hay. I didn't see any consensus for ignoring non-critical controls. I'm certainly not in favour of it.

Ron

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jim Sermersheim
Sent: Friday, 20 May 2005 00:06
To: [email-masked]
Subject: Protocol: control combinations

Recent Working Group consensus has changed the semantics of control criticality such that a server may ignore non-critical controls at its discretion.
 
This change affects the way we have described control combinations. The current language is this:

"Controls SHOULD NOT be combined unless the semantics of the combination has been specified. The semantics of control combinations, if specified, are generally found in the control specification most recently published. When a combination of controls is encountered whose semantics are invalid, not specified (or not known), the message is considered to be not well-formed, thus the operation fails with protocolError. Additionally, unless order-dependent semantics are given in a specification, the order of a combination of controls in the SEQUENCE is ignored. Where the order is to be ignored but cannot be ignored by the server, the message is considered not well-formed and the operation fails with protocolError."

If a server is allowed to ignore non-critical controls, it should be allowed to ignore non-critical controls in invalid control combinations. If no one disagrees, I will take a stab at fixing this paragraph.

Jim

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 19 May 2005 19:03:46 -0700

>Way-hay-hay. I didn't see any consensus for ignoring non-critical controls. I'm certainly not in favour of it.

On 15 April, I asked Jim to post a summary of changes he
thinks are supported by WG consensus for "brief discussions".
I think Jim's note below can best be regarded stating what he
thinks the WG consensus to be in regards to this issue.  After
review of those discussions, I (as Chair) have to agree with
him.

For clarity, I believe that WG consensus is that servers may
ignore recognized non-critical controls attached to applicable
(per control specification) request in performing the
operation.  That is, the server is not obligated to return an
error in cases where it is unwilling or unable to make use of
a recognized non-critical control attached to an applicable
request, it may instead perform the operation ignoring any
or all non-critical controls.

Kurt, as LDAPBIS co-chair