Subject: Protocol: control combinations

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 May 2005 08:06:03 -0600

Recent Working Group consensus has changed the semantics of control criticality such that a server may ignore non-critical controls at its discretion.
 
This change affects the way we have described control combinations. The current language is this:

"Controls SHOULD NOT be combined unless the semantics of the combination has been specified. The semantics of control combinations, if specified, are generally found in the control specification most recently published. When a combination of controls is encountered whose semantics are invalid, not specified (or not known), the message is considered to be not well-formed, thus the operation fails with protocolError. Additionally, unless order-dependent semantics are given in a specification, the order of a combination of controls in the SEQUENCE is ignored. Where the order is to be ignored but cannot be ignored by the server, the message is considered not well-formed and the operation fails with protocolError."

If a server is allowed to ignore non-critical controls, it should be allowed to ignore non-critical controls in invalid control combinations. If no one disagrees, I will take a stab at fixing this paragraph.

Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 May 2005 18:59:26 -0600

See the thread starting here <http://www.openldap.org/lists/ietf-ldapbis/200503/msg00078.html> and ending (around) here <http://www.openldap.org/lists/ietf-ldapbis/200504/msg00018.html>. 

>>> "Ramsay, Ron" <[email-masked]> 5/19/05 6:52:29 PM >>>
Way-hay-hay. I didn't see any consensus for ignoring non-critical controls. I'm certainly not in favour of it.

Ron

-----Original Message-----
From: [email-masked] 
[mailto:[email-masked]]On Behalf Of Jim Sermersheim
Sent: Friday, 20 May 2005 00:06
To: [email-masked] 
Subject: Protocol: control combinations

Jim

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 May 2005 11:25:16 +1000

Hmmm... I looked at these two messages. They both say that servers may have a tough time deciding whether they support the control "in the context", but neither conclude that the server can choose not to honour a control they recognise. Or is this all you mean? Your original statemet seemed to be much broader. Also, I didn't see "consensus".
 
Could you please indicate the message the indicates consensus?
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 10:59
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

See the thread starting here < http://www.openldap.org/lists/ietf-ldapbis/200503/msg00078.html> and ending (around) here < http://www.openldap.org/lists/ietf-ldapbis/200504/msg00018.html>. 

Ron

-----Original Message-----

Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 May 2005 22:33:17 -0600

To get a sense of consensus, you need to read the entire thread rather than just those two messages.

>>> "Ramsay, Ron" <[email-masked]> 5/19/05 7:25:16 PM >>>

Ron
-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 10:59
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

Ron

-----Original Message-----

Jim

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 May 2005 14:37:52 +1000

My point would be that to get consensus requires more than a number of people on an (arcane) thread reaching agreement.
 
However. Kurt has also said that he sought consensus on this matter.
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 14:33
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

 
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 10:59
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

Ron

-----Original Message-----

Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 May 2005 23:38:54 -0600

What I should have said is that after reading the entire thread (which far from being arcane went on for over a month and was rather hotly debated), you will see that there was only one person (me) who felt that the change was against the intent of RFC 2251. In the end I grumpily yielded (http://www.openldap.org/lists/ietf-ldapbis/200504/msg00020.html). On that thread, I represented 20% of the opinions. I also assume that anyone in the Working Group not bothering to speak up is generally siding with the majority. I figure when 80+% of the people agree with something, it constitutes consensus (whether I like it or not). 
 
That said, if you have arguments which you didn't get to voice before, now would be a good time.

>>> "Ramsay, Ron" <[email-masked]> 5/19/05 10:37:52 PM >>>

 
Ron
-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 14:33
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

 
 
Ron
-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 10:59
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

Ron

-----Original Message-----

Jim

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 May 2005 16:07:19 +1000

Thanks for the opportunity, Jim, but I don't have a strong opinion. The previous (consensus) view of the WG was that criticality was unimportant once the decision was taken to perform a request and it came as a shock to see the converse written down. I've recovered now, though.
 
I'm not sure of the connection between the number of posters and consensus. I didn't post because my views had already been put, probably by you. Generally, I'm not in favour of "me, too" posts. Another problem might be that there seem to be only five posters in this WG in total. But this topic has always been a difficult one, made more so by distribution and the situation that started the thread. Something about sleeping dogs ...
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 15:39
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

What I should have said is that after reading the entire thread (which far from being arcane went on for over a month and was rather hotly debated), you will see that there was only one person (me) who felt that the change was against the intent of RFC 2251. In the end I grumpily yielded ( http://www.openldap.org/lists/ietf-ldapbis/200504/msg00020.html). On that thread, I represented 20% of the opinions. I also assume that anyone in the Working Group not bothering to speak up is generally siding with the majority. I figure when 80+% of the people agree with something, it constitutes consensus (whether I like it or not). 

 
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 14:33
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

 
 
Ron

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 May 2005 10:59
To: Ramsay, Ron; [email-masked]
Subject: RE: Protocol: control combinations

Ron

-----Original Message-----

Jim