Subject: authmeth-17 notes

From: Hallvard B Furuseth <[email-masked]>
Date: Tue, 08 Nov 2005 15:49:16 +0100

Sorry to be so late...

>3.1.2. Client Certificate
>   If a client that has provided a suitable certificate subsequently
>   performs a Bind operation using the SASL EXTERNAL authentication
>   mechanism (section 5.2.1), information in the certificate may
>   be used by the server to identify and authenticate the client.

Why was "may subsequently be used" changed to "may be used" here?

3.1.3.1. Comparison of DNS Names
>   That is, the subject
>   *.example.com matches the server names a.example.com and
>   b.example.com but not the server name example.com.

This example lost one case since authmeth-16.  I suggest:

>   That is, the subject
>   *.example.com matches the server name a.example.com, but not
>   the server names example.com and b.a.example.com.

More of the TLS vs anonymous discussion follows.

-- 
Hallvard

---

From: "Roger Harrison" <[email-masked]>
Date: Tue, 08 Nov 2005 09:08:23 -0700

Thanks for your review. I really appreciate the assistance.
 
> >>> Hallvard B Furuseth <[email-masked]> 11/8/2005 7:49:16
am >>>
> Why was "may subsequently be used" changed to "may be used" here?
 
I removed the phrase because it was redundant. The "subsequently" part
was already in the first part of the sentence, so the 2nd subsequently
wasn't necessary.

> >   the server names example.com and b.a.example.com.
 
Thanks. Good catch. The sentence now reads:
 
"That is, the subject *.example.com matches the server names
a.example.com and b.example.com but does not match example.com or
a.b.example.com."
 
Roger