Subject: Discovery of attribute type option support

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 14 Sep 1999 11:08:54 -0600

Has there been any discussion on the issue of server advertisement of support for attribute type options? Specifically, I'm wondering if there are standard ways for an LDAP client to ask questions like:
"Does this server support language tags? If so, which attributes (or syntaxes) can I expect to use them with?"
"Does this server support the binary option? If so, which syntaxes can I use it with?"

I've seen some servers that include attributes with the binary option in their object class schema definitions, that doesn't seem right. And the inclusion of language tag information in the schema seems problematic.

I suppose the client can just try an operation, and if it fails, infer that it's not supported, but that's not very elegant.

Jim

---

From: Mark Wahl <[email-masked]>
Date: Wed, 15 Sep 1999 19:24:59 -0500

There is currently no mechanism for attribute option advertisement, although 
such a capability is being considered for addition to the next updates to 
2251/2252 as optional root DSE and subschema attributes.  Mainly didn't want
to have it in the first cut of LDAPv3 until we had some experience of which
options were being standardised.

Mark Wahl, Directory Product Architect
Innosoft International, Inc.