Subject: String representation of postalAddress

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Sep 1999 13:59:07 -0600

The RFC2252 representation shows values of this attribute being made up of a list of dstring which is defined as 1 or more utf8 char's.  X.520 says that it's a list of DirectoryStrings with an upper bound (no lower bound).  I'm confused about the lower bound requirement in the RFC. From X.520, it seems like I should be able to have a Postal Address like this: "line1$$line3$line4", but the RFC doesn't allow that.  Am I reading the definition in X.520 wrong?

Jim

---

From: "Salter, Thomas A" <[email-masked]>
Date: Tue, 21 Sep 1999 16:22:34 -0400

I believe X.520 says ALL DirectoryStrings have a lower bound of 1 and some
upper bound.

This is the DirectoryString definition from X.520:

	DirectoryString { INTEGER : maxSize } ::= CHOICE {
	teletexString		TeletexString (SIZE (1..maxSize)),
	printableString		PrintableString (SIZE (1..maxSize)),
	universalString		UniversalString (SIZE (1..maxSize)) }

 > -----Original Message-----
 > From: Jim Sermersheim [mailto:[email-masked]]
 > Sent: Tuesday, September 21, 1999 3:59 PM
 > To: [email-masked]
 > Subject: String representation of postalAddress
 > 
 > 
 > The RFC2252 representation shows values of this attribute 
 > being made up of a list of dstring which is defined as 1 or 
 > more utf8 char's.  X.520 says that it's a list of 
 > DirectoryStrings with an upper bound (no lower bound).  I'm 
 > confused about the lower bound requirement in the RFC. From 
 > X.520, it seems like I should be able to have a Postal 
 > Address like this: "line1$$line3$line4", but the RFC doesn't 
 > allow that.  Am I reading the definition in X.520 wrong?
 > 
 > Jim
 >

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 21 Sep 1999 14:24:50 -0600

You're right, I didn't chase it far enough.  Thanks

>>> "Salter, Thomas A" <[email-masked]> 9/21/99 2:22:34 PM >>>