Subject: Re: draft-ietf-ldapext-ldap-c-api-03 & timeout

From: "Ed Reed" <[email-masked]>
Date: Tue, 28 Sep 1999 13:17:37 -0600

Such higher level APIs are candidates for development in the
Directory Interoperability Forum SDK group, would you agree?

Ed

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 785 0315
[email-masked]

>>> Mark C Smith <[email-masked]> 09/28/1999 09:13:09 >>>
The timeout mechanism provided in the C API draft is very simple.  While
I agree that more complex and full featured timeouts are desirable,
applications are able to implement those themselves on top of the
defined ldap_result() interface.  Therefore, I suggest we defer this
feature for now but revive it as an API extension if there is enough
interest.

-- 
Mark Smith
iPlanet Directory Architect / Sun-Netscape Alliance
My words are my own, not my employer's.   Got LDAP?

Fan Jiao wrote:
> 
> Mark,
> 
> See inlines.
> 
> Mark Wahl wrote:
> 
> > Do you mean as part of the ldap_result() call and the synchronous Bind calls
> > (e.g. ldap_sasl_bind_s), or as a control transmitted over protocol with the
> > requset?
> 
> At least the former - may be both.
> 
> >
> >
> > Also, I am not familiar with the term 'exponential timeout'; could you provide
> > an example, please?
> 
> A simple timeout has the same timeout intervals. For example, one might have
> Retry=3, Timeout=3. Then if client fails to connect to Directory, it will wait for
> 
> 3 secs and try again and so forth. The drawback is that the odds for a client to
> get
> connected to server is not usually very good in a congested network.
> 
> Exponential timeout uses different timeout intervals which are calculated by an
> exponential function. One would define it using integers, Seed,
> Limit, and Retry. For example, S=3, L=60, R=3, a client would wait for 3 secs
> to try to connect first. If it fails, it would wait for say 12 secs, then may be
> 56 secs.
> One would also define the meaning of Retry = 0 - try as many time as it can as
> long
> as calculated interval doesn't exceed the Limit.
> 
> By using such timeout mechanism with ldap bind/ldap result API, some higher level
> APIs which are easy-to-use can be easily designed, for example.
> 
> >
> >
> > Mark Wahl, Directory Product Architect
> > Innosoft International, Inc.

---

From: [email-masked] (Chuck Boatwright)
Date: Tue, 28 Sep 1999 13:18:01 -0700

> Directory Interoperability Forum SDK group, would you agree?

Maybe so, but I haven't seen a draft for what services this SDK would
provide.  Has a list of possible features been posted?  -- did I miss
it?

The reason for keeping the timeout mechanism simple, is to eliminate
some of the nasty complexities of managing the timeout.  A similar
argument can be made for connection pooling.  I am in favor of keeping
the timeout mechanism simple, as the draft specifies, though that
doesn't mean that my opinion can't be swayed.

-ch

---------------------------------------------------------------
Netscape isn't responsible for content, grammar or spelling

---

From: fan jiao <[email-masked]>
Date: Tue, 28 Sep 1999 18:36:09 -0700

Yes I agree.

---

From: fan jiao <[email-masked]>
Date: Tue, 28 Sep 1999 19:05:17 -0700

I agree the simple timeout has less
complexity to manage. But it doesn't
work well in a congested production
network. On the other hand, the
exponential timeout is being widely used
in SNMP world; it has been proven to
increase odds to retry/re-connect to
network devices.