Subject: I-D ACTION:draft-mmeredit-rootdse-vendor-info-00.txt

From: "Mark Meredith" <[email-masked]>
Date: Thu, 18 Nov 1999 10:35:07 -0700

Please review the attached draft on vendor information to be added to the root DSE.

This document specifies two new attributes, vendorName and vendorVersion, that can be included in the root DSE to contain vendor-specific information.

Any comments can be sent through [email-masked] or directly to me [email-masked] 

Thanks,
-Mark

Mark Meredith
Novell Inc
122 E. 1700 S. Provo UT 84606
[email-masked]
801-861-2645
---------------------
A boat in the harbor is safe, 
but that is not what boats are for.
--John A. Shed
---------------------

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 18 Nov 1999 15:28:43 -0800

If published at all, I would suggest it be published as
informational.

I would rather see us define attribute types to document
existence on specific features instead of relying on vendor
naming/version information.  Otherwise, as vendors start implementing
each others features, we'll end up with same ( xxx compatible )
crap that has plagued HTTP services.

Kurt

----
Kurt D. Zeilenga		<[email-masked]>
Net Boolean Incorporated	<http://www.boolean.net/>

---

From: [email-masked] (Gordon Good)
Date: Thu, 18 Nov 1999 15:41:58 -0800

> crap that has plagued HTTP services.

I agree completely. Our experience with this is that once you publish
information about server versions in the root DSE, client implementors
start to do silly things, like refuse to work with any version of your
server other than the one they certified with.