Subject: Re: objectclass of the Root DSE

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 16 Nov 1999 11:29:55 -0700

Shouldn't the root DSE be a subentry? It would be nice if we could standardize the LDAPSubentry class and start subclassing it for things like root DSE and such.

>>> "Kurt D. Zeilenga" <[email-masked]> 11/15/99 5:07:41 PM >>>
At 03:13 PM 11/15/99 -0600, Mark Wahl wrote:
>Yes, that's something that will need to be added to the revision of 2251.
>Probably will make a new object class.

Something like?

	( LDAProotDSEOID NAME 'LDAProotDSE'
		DESC 'Root DSE object class'
		SUP top STRUCTURAL )

where LDAProotDSEOID should be replaced by an assigned OID.

>It doesn't need to be extensible because all the attributes of
>the root DSE are operational attributes,  which can be present
>in any entry.

I had thought that some of the attribute types within the
RootDSE were not operational.  I likely confused attribute
types of one of the RootDSE's subentry.

Thanks for the clarification.

----
Kurt D. Zeilenga		<[email-masked]>
Net Boolean Incorporated	<http://www.boolean.net/>

---

From: Mark Wahl <[email-masked]>
Date: Tue, 16 Nov 1999 13:37:40 -0600

Subentries are administrative entries that are located immediately
subordinate to an administrative point, frequently as a naming context 
boundary or a 'ou'.  The root DSE is not subordinate to anything: it
is in X.500 terms its own DSE type ('root') and not of the subentry
DSE type ('subentry').  The only reason we need an object class for 
this is that in 2251 we said you could do a objectclass=* search on it.
The actual object class value is not relevant. 

Mark Wahl, Directory Product Architect
Innosoft International, Inc.