Subject: integer ordering matching rule and RFC2252

From: "Grimstad, Al" <[email-masked]>
Date: Thu, 4 Nov 1999 19:12:37 -0500

Hi.

Suppose I want to define an integer-valued attribute. In X.500-93
this might look something like:

myCounter ATTRIBUTE ::= {
  WITH SYNTAX INTEGER
  EQUALITY MATCHING RULE id-mr-integerMatch
  ORDERING MATCHING RULE id-mr-integerOrderingMatch
  ID id-at-myCounter }

Now I want to express this thing in the RFC2252 syntax.
As far as I can tell, the IETF hasn't registered an integer
ordering matching rule. It has been suggested that I
could just use the registered rule from X.500. That is,
suppose I write:

( <numerid OID here> 
  NAME 'myCounter'
  DESC 'An attribute to represent a counter'
  EQUALITY integerMatch
  ORDERING mumble
  SYNTAX 1.3.6.1.4.1.1466.115.121.1.27
)

and then the suggestion is that "mumble" can be
id-mr-integerOrderingMatch from X.500. Can I do this?
If I can, why couldn't I use X.500's id-mr-integerMatch
instead of RFC2252's integerMatch?

Thanks for any clarification. -- al

---

From: Mark Smith <[email-masked]>
Date: Fri, 05 Nov 1999 15:46:46 -0500

The integerMatch described in RFC 2252 is X.500's integerMatch (they
have the same OID).  You should be able to use X.500's
integerOrderingMatch as long as the Directory Server implementation you
are working with supports it.  I think convention would be to just use
the matching rule's name (e.g., integerMatch or integerOrderingMatch) in
the RFC 2252-style attribute type definitions rather than the OID
(id-mr-XXX ASN macros).

-- 
Mark Smith
iPlanet Directory Architect / Sun-Netscape Alliance
My words are my own, not my employer's.   Got LDAP?