Subject: RE: Details on TCP sequence numbers (RE: C API: minor comments)

From: "Paul Leach (Exchange)" <[email-masked]>
Date: Tue, 16 Nov 1999 16:26:10 -0800

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: Tuesday, November 16, 1999 4:56 PM

> 
> For unauthenticated CLDAP - yes.
> 
> I still say it does not matter in the present batch of specs.

I'll agree with that. My expectation was that the LDAP API would be usable
pretty much as is for CLDAP, too. Maybe some small mods.

BTW: if the design weren't so far along, I'd have the API _return_ the ID it
used, instaed of having the caller assign them.

Paul

---

From: [email-masked] (Mark C Smith)
Date: Wed, 17 Nov 1999 10:44:42 -0500

> pretty much as is for CLDAP, too. Maybe some small mods.

Probably true, but CLDAP is out of scope in my view until we see a CLDAP
protocol draft.

> used, instaed of having the caller assign them.

The C LDAP API calls do return a message id that is generated by the
underlying implementation.

-- 
Mark Smith
iPlanet Directory Architect / Sun-Netscape Alliance
My words are my own, not my employer's.   Got LDAP?