Subject: Re: IPv6 addressed in LDAP C-API

From: [email-masked] (Mark C Smith)
Date: Wed, 01 Dec 1999 10:40:43 -0500

Morteza Ansari wrote:
> 
> Hi Mark,
> 
> Now that we are doing more work on the c-api, I think we should address
> the IPv6 address issue in section 11.1 as well:
> 
> hostname Contains a space-separated list of hostnames or dotted strings
>          representing the IP address of hosts running an LDAP server to
>          connect to. Each hostname in the list MAY include a port number
>          which is separated from the host itself with a colon (:) char-
>          acter.  The hosts will be tried in the order listed, stopping
>          with the first one to which a successful connection is made.
> 
>    Note: A suitable representation for including a literal IPv6[10]
>    address in the hostname parameter is desired, but has not yet been
>    determined or implemented in practice.
> 
> A somewhat similar draft (draft-ietf-ipngwg-url-literal-04.txt) that
> addresses the same issue for URL's was recently approved by IESG, and I
> think we should adopt the same format for representing IPv6 addresses in
> "hostname".  It essentially states that literal IPv6 addresses should be
> enclosed in '[' and ']'.  An example of this in our case would be:
> 
> hostname = "mirage:7653 129.178.2.54 [1080:0:0:0:8:800:200C:4171]:2353"
> 
> I suggest we change our definition of hostname to include IPv6 addresses
> along with the optional port number as specified in above draft.
> Comments?

I didn't realize that the draft you mention had been approved by the
IESG.  I assume it is Standards Track?  If so, there is no reason not to
reference it from the C API document as you suggest.  I didn't do that
in the last revision of the C API I-D because I didn't want to make it
dependent on another I-D.  Any objections?

-- 
Mark Smith
iPlanet Directory Architect / Sun-Netscape Alliance
My words are my own, not my employer's.   Got LDAP?

---

From: Morteza Ansari <[email-masked]>
Date: Wed, 01 Dec 1999 10:35:27 -0800

Mark C Smith wrote:

Morteza Ansari wrote:

>          representing
the IP address of hosts running an LDAP server to

>          connect to.
Each hostname in the list MAY include a port number

>          which is separated
from the host itself with a colon (:) char-

>          acter.
The hosts will be tried in the order listed, stopping

>          with the first
one to which a successful connection is made.

IESG.  I assume it is Standards Track?  If so, there is no
reason not to

Yes, it was approved as proposed standard.  I didn't bring it
up before either because it was still a draft, but now that we are delayed
and that draft is going to be an RFC soon...

Morteza,