Subject: RE: LDAP C API -> Informational

From: "Paul Leach (Exchange)" <[email-masked]>
Date: Tue, 21 Dec 1999 18:28:07 -0800

Are you saying that its a bad spec, but we should unify under it anyway? Bad
specs for an API mean that code written to it isn't portable, has
implementation dependencies, doesn't work well in error conditions, and all
round just sucks.

Fooey.

If the highest priority is really the need to let LDAPEXT conclude, then we
should just drop the work item from the charter.

Paul

> -----Original Message-----
> From: Kurt D. Zeilenga [mailto:[email-masked]]
> Sent: Tuesday, December 21, 1999 12:25 PM
> To: [email-masked]
> Subject: LDAP C API -> Informational
> 
> 
> Tim, Mark:
> 
> I ask that the working group consider progressing the LDAP C API
> draft as Informational.
> 
> I do not believe that the current LDAP C API specification can
> easily be amended to resolve the numerous technical issues
> (error handling, referral handling, security) raised to the
> authors privately or in the working group.  I believe significant
> time (over a year) and energy will be required to produce an API
> specification worthy of being progressed on the Standard Track.  
> 
> However, the community needs a specification to unify under.
> I believe that an Informational RFC can, as demonstrated by
> RFC 1823, serve the community's immediate need for unification.
> I believe the current draft could be published as Informational
> without significant delay.
> 
> I would support formation of a new WG specifically chartered
> to develop API specifications for LDAP such that LDAPext may
> conclude as scheduled.
> 
> 	Kurt
>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 21 Dec 1999 19:52:26 -0800

At 06:28 PM 12/21/99 -0800, Paul Leach (Exchange) wrote: 
> Are you saying... ?

I am saying the specification is not currently, IMO, suitable
for progressing on the Standard Track and that it will take
signification time and energy to resolve the outstanding issues.

I recognize the need to have a specification we can reference
sooner than later.  I see publishing what we have now as
information provides a specification which we can unify under.
We can resolve the larger issues as a follow-on effort.

> If the highest priority is really the need to let LDAPEXT conclude,
> then we should just drop the work item from the charter.

I actually support spinning off separate working groups for
may items on the current LDAPext charter...  personally, I
like to see LDAPext focus on AuthMeth, StartTLS, and RFC2251bis.

---

From: "Paul Leach (Exchange)" <[email-masked]>
Date: Tue, 21 Dec 1999 21:14:51 -0800

> Sent: Tuesday, December 21, 1999 7:52 PM
> To: Paul Leach (Exchange)
> Cc: [email-masked]
> Subject: RE: LDAP C API -> Informational
> 
> 

I agree.

> We can resolve the larger issues as a follow-on effort.

I agree about the need to resolve the issues. I don't see the need to
publish a spec with all the problems you listed as an Informational; for the
purposes of getting to Proposed, it could remain a draft, and still provide
the needed unification point.

> like to see LDAPext focus on AuthMeth, StartTLS, and RFC2251bis.

I would also be happy with a new WG for LDAP API.

Paul