Subject: Updated Result Code for LDAP Controls draft - draft-armijo-ldap-control-error-01.txt

From: "Michael Armijo" <[email-masked]>
Date: Mon, 5 Feb 2001 12:22:47 -0800

Here is the updated version of the LDAP Control error draft.

Please review and comment on the updated draft.  I would like to pursue
this being progressed as a PS ASAP so we can move forward on the VLV
draft.

thanks,
Michael

---

From: "John Liang" <[email-masked]>
Date: Tue, 6 Feb 2001 16:38:42 -0500

HI Michael,

As in the following part of the draft,

The controlError SHOULD NOT be used to represent any condition that 
can be defined using any existing result code in RFC 2251.

Does that mean for instance, if there is 'noSuchAttribute' error
happened for Server side sorting, both the searchResultDone 
and the sssResponseControl would return 'noSuchAttribute' error?

And only if the error can not be found in RFC 2251 like 
'sortContolMissing' for VLV, this new controlError will be
used in searchResultDone message.

Thanks,
--
John Liang

> -----Original Message-----
> From: Michael Armijo [mailto:[email-masked]]
> Sent: Monday, February 05, 2001 3:23 PM
> To: [email-masked]
> Subject: Updated Result Code for LDAP Controls draft -
> draft-armijo-ldap-control-error-01.txt
> 
>