Subject: RE: Updated Result Code for LDAP Controls draft - draft-armijo-ldap-control-error-01.txt

From: "Michael Armijo" <[email-masked]>
Date: Tue, 6 Feb 2001 16:01:55 -0800

The main goal of this draft is to not overload existing result codes
(like 'other').  Likewise, this result code should not be overloaded.
That is the reason for the 'SHOULD NOT be used to represent... existing
result code' wording.  This is particularly important for controls that
will primarily make use of the operation response field for error
handling.

That said, there will be controls (such as Sort and VLV) that wish to
have control-specific result codes returned via an embedded result
field.  In these cases, the best practice would be to return
controlError in the operation response and to return any results
relevant to the control in the embedded response. 

Re-reading the draft, I can see where there might be some ambiguity
about this.  I will update the wording (pending any more comments) and
send out an updated draft to the list.

Michael

> -----Original Message-----
> From: John Liang [mailto:[email-masked]]
> Sent: Tuesday, February 06, 2001 1:39 PM
> To: Michael Armijo; [email-masked]
> Subject: RE: Updated Result Code for LDAP Controls draft -
> draft-armijo-ldap-control-error-01.txt
> 
> 
> HI Michael,
> 
> As in the following part of the draft,
> 
> The controlError SHOULD NOT be used to represent any condition that 
> can be defined using any existing result code in RFC 2251.
> 
> Does that mean for instance, if there is 'noSuchAttribute' error
> happened for Server side sorting, both the searchResultDone 
> and the sssResponseControl would return 'noSuchAttribute' error?
> 
> And only if the error can not be found in RFC 2251 like 
> 'sortContolMissing' for VLV, this new controlError will be
> used in searchResultDone message.
> 
> Thanks,
> --
> John Liang
> 
> > -----Original Message-----
> > From: Michael Armijo [mailto:[email-masked]]
> > Sent: Monday, February 05, 2001 3:23 PM
> > To: [email-masked]
> > Subject: Updated Result Code for LDAP Controls draft -
> > draft-armijo-ldap-control-error-01.txt
> > 
> > 
> > Here is the updated version of the LDAP Control error draft.
> > 
> > Please review and comment on the updated draft.  I would 
> like to pursue
> > this being progressed as a PS ASAP so we can move forward on the VLV
> > draft.
> > 
> > thanks,
> > Michael
> > 
> 
> 
>

---

From: "Michael Armijo" <[email-masked]>
Date: Mon, 26 Feb 2001 14:23:21 -0800

Are there any additional comments on this draft?

If not, I would like to release a .02 version to be considered for last
call.

I plan to submit the next rev tomorrow (2/27).  Please send any
additional comments on the .01 draft ASAP.

-----Original Message-----
From: Michael Armijo 
Sent: Tuesday, February 06, 2001 4:02 PM
To: [email-masked]; [email-masked]
Subject: RE: Updated Result Code for LDAP Controls draft -

Michael