Subject: Re: psearch, search references, aliases

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 02 Feb 2001 20:17:01 -0700

Kurt's suggestions make implementation much more simple--I vote yes. If we do restrict the search operation deref field to never or finding, there should be a discussion of what the server does in the event that a client sends always or searching.

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 2/2/01 2:23:55 PM >>>
At 04:00 PM 2/2/01 -0500, Mark Smith wrote:
>I will have to think about this one some more.  What are your thoughts?

Well, I think psearch semantics needs to be simple.  Dealing
with aliases and references leads to complex semantics to
which, even if we sorted on the server side semantics,
might not be all that useful to the client.

Hence, my suggestion is to require the server behave as if
ManageDsaIT was provided and require the client to specify
either "never" or "finding" alias dereferencing.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 02 Feb 2001 19:22:14 -0800

>Kurt's suggestions make implementation much more simple--I vote yes. If we do restrict the search operation deref field to never or finding, there should be a discussion of what the server does in t…

protocolError