Subject: Re: psearch, search references, aliases

From: Mark Smith <[email-masked]>
Date: Fri, 02 Feb 2001 16:00:16 -0500

"Kurt D. Zeilenga" wrote:
> 
> What is the behavior of the psearch operation when, in the absence
> of ManageDsaIt, there are subordinate references (in scope)
> are added, deleted, or modified?

This is not specified in the draft of course.  On the surface, it seems
reasonable for the server to make some effort to respect the ManageDSAIT
setting.  On the other hand, it would be a bit messy to return a
continuation reference that has an EntryChangeNotification control
attached to it.  I believe the Netscape/iPlanet implementation acts as
if ManageDSAIT were always present when returning entries in response to
changes.

> What is the behavior of the psearch operation when there are
> aliases within scope and dereferencing during searching is
> enabled?

I will have to think about this one some more.  What are your thoughts?

-- 
Mark Smith
Directory Product Development / Netscape
I speak only for myself.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 02 Feb 2001 13:23:55 -0800

>I will have to think about this one some more.  What are your thoughts?

Well, I think psearch semantics needs to be simple.  Dealing
with aliases and references leads to complex semantics to
which, even if we sorted on the server side semantics,
might not be all that useful to the client.

Hence, my suggestion is to require the server behave as if
ManageDsaIT was provided and require the client to specify
either "never" or "finding" alias dereferencing.

Kurt