Subject: [ldapext] VLV: typedown

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 25 Sep 2002 18:47:27 -0700

The "typedown" mechanism only supports typing down by
values of the primary key, it doesn't allow typedown
via secondary keys (where further typedown of the
primary key is ineffective). 

This limitation should be noted.

In particular, where the I-D says:
	
	Selection of the target entry by this
	means is designed to implement "typedown". 

It should be noted that "typedown" (as specified in
this I-D) can only select entries which whose least
most value(*) is unique within the result set.  For
any typedown value, there may be many entries which
are equal to the value.  Where the number of entries
equal to the value is greater than afterCount, the
desired entry may not be in the result set.

(*) it should also be noted where the user cannot
only select entries by their least most value of
the primary key.

Kurt

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 25 Sep 2002 19:02:56 -0700

>only select entries by their least most value of

The typedown mechanism really begs for duplicate entry
[draft-ietf-ldapext-ldapv3-dupent] support to deal with
the multi-valued ordering cases.

Kurt