Subject: Re: [ldapext] VLV: a particular target entry

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 25 Sep 2002 16:23:50 -0600

Don't you mean the DN is to specify the target entry in an *un*ordered
list? Actually, seems useful for either (ordered or not)

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 09/25/02 04:04PM >>>
At 02:51 PM 2002-09-25, David Boreham wrote:
>> distinguished name.
>
>Ah !
>
>> 
>>         VirtualListViewRequest
>>         ...
>>           CHOICE {
>
>So you're asking for the ability to specify DN in place of
>an attribute name, in the target specification ?

No, I'm asking to specify DN in place of byoffset or
greaterThanOrEqual.

>Seems reasonable. Is there a reason why 'dn' can't
>be submitted as an attribute name ? (I suspect there is,
>I don't know enough about X.500 to undersand why 
>dn is different to other attribute names).

A number of reasons, but most importantly:

The DN is to specify the target entry in an ordered list,
not how to order the list (which what the attribute
name is used for).

Kurt

_______________________________________________
Ldapext mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ldapext
_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 25 Sep 2002 15:44:35 -0700

At 03:23 PM 2002-09-25, Jim Sermersheim wrote:
>list?

No, I mean an *ordered* list.  VLV should always work on an
ordered list of entries.  The DN is selecting a particular
entry in that list.

>Actually, seems useful for either (ordered or not)
>
>Jim
>