Subject: Re: [ldapext] VLV: additional questions?

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 01 Nov 2002 16:56:28 -0700

>>>> "Kurt D. Zeilenga" <[email-masked]> 09/26/02 12:46AM >>>
>VLV:
>>Note that it is possible that no entry satisfies these conditions,
>>in which case there is no target entry.
>
>What does the server return when there is no target entry?

This condition is indicated by the server returning the special value contentCount + 1 in the target position field

>--
>
>Under what circumstances would the server return targetPosition = 0 ?

I don't know. We should probably set the min to 1.

>--
>
>In byoffset:  Is offset > contentCount > 0 an error condition?  protocolError?

Should error, I'll add language.

>--
>
>If 0 > sizelimit > (beforeCount + afterCount + 1), is
>sizeLimitExceeded returned?

Not unless the size limit is exceeded. If sizelimit = 50, offset = 1, beforeCount = 100, afterCount = 10, you will get back 11 entries.

>--
>
>>        Si = Sc * (Ci / Cc)
>
>What if this equation evaluates to zero?

How would that happen?

Jim

>Kurt

_______________________________________________
Ldapext mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ldapext

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 04 Nov 2002 14:07:58 -0800

>>What if this equation evaluates to zero?

Let Sc be zero.