Subject: [ldapext] draft-zeilenga-ldap-adlist-06.txt

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 11 Nov 2003 13:33:54 -0700

This draft allows the search attribute selection list to be specified as
all attributes allowed by a given object class.
 
It may be useful to allow the distinction between all user attributes
allowed by a given obejct class and all operational attributes allowed
by a given object class.
 
We could alter the draft to state that +<objectClass> would specify all
user attributes, while *<objectClass> would specify all operational
attributes.
 
Comments?
 
Jim

---

From: Ludovic Poitou <[email-masked]>
Date: Tue, 11 Nov 2003 22:02:06 +0100

Jim Sermersheim wrote:

> This draft allows the search attribute selection list to be specified 
> as all attributes allowed by a given object class.
>  
> We could alter the draft to state that +<objectClass> would specify 
> all user attributes, while *<objectClass> would specify all 
> operational attributes.

Somehow, it would be better if the + sign and * sign apply to the same 
type of attributes in all cases...
So far * means all users attributes. So *<objectclass> should specific 
all user attributes allowed by the objectclass, and +<objectclass> would 
specify all operational attributes.

Ludovic.

-- 
Ludovic Poitou
Directory Architect.
Directory Server Group, Grenoble, France
Sun Microsystems Inc.

Sun Microsystems requires the following notice:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NOTICE:  This email message is for the sole use of the intended
recipient(s) and may contain confidential and privileged
information.  Any unauthorized review, use, disclosure or
distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy
all copies of the original message.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 13 Nov 2003 09:25:03 -0600

At 02:33 PM 11/11/2003, Jim Sermersheim wrote:
>This draft allows the search attribute selection list to be specified as all attributes allowed by a given object class.
> 
>It may be useful to allow the distinction between all user attributes allowed by a given obejct class and all operational attributes allowed by a given object class.

While that may be useful, I rather keep this mechanism a simple short hand.
That is, I prefer a mechanism where the input can be expanded to the output
list of attribute types identifiers without having to know the particulars
of these attribute types.

Kurt

---

From: Steven Legg <[email-masked]>
Date: Wed, 19 Nov 2003 16:08:51 +1100

In my experience, user defined object classes reference only user attributes
and syntax schema object classes (e.g. subentry) reference mostly operational
attributes. Separate mechanisms for requesting only the user attributes or
only the operational attributes would not seem to achieve very much.

Regards,
Steven

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 18 Nov 2003 21:19:56 -0800

In face-to-face discussions at IETF#58, I learned the concern
was more about the implied semantics of the "+" used in draft.
I agreed to change replace "+" with "@" in this draft to avoid
confusion with "+" other use (zeilenga-ldap-opattrs).  An
new revision will be available soon.

Kurt