Subject: [ldapext] Interpretation of "attribute: <no value>" in LDIF file

From: John McMeeking <[email-masked]>
Date: Mon, 1 Nov 2004 16:06:27 -0600

What is the proper interpretation of a LDIF line consisting of just
"attributetype: " with no value?

As I read 2849, I think it means zero-length value, which is not the same
as no value.  I believe zero-length value is valid for Octet String, IA5
String, Distinguished Name, maybe others.  Others have argued that it means
no value (as in using a modify-replace with no value to delete an attribute
if it is present in an entry).

To use some examples, what do the following do to the value of description?

dn: cn=some entry
changetype: modify
replace: description
description:

dn: cn=another entry
changetype: modify
replace: description

John  McMeeking

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Michael Ströder <[email-masked]>
Date: Mon, 01 Nov 2004 23:57:07 +0100

John McMeeking wrote:
 > as no value.

This would be my understanding too.

Ciao, Michael.