Subject: [ledbat] LEDBAT Status and plan moving forward

From: Murari Sridharan <[email-masked]>
Date: Wed, 9 Jun 2010 15:26:56 +0000

All:

We set out with three goals for this WG with the most important one to put out an experimental congestion algorithm for less-than-best-effort traffic.

Oct 2009 - Submit 'Multiple Transport Connections in Applications Design' to the IESG for consideration as an Informational RFC
Oct 2009 - Submit 'Low Extra Delay Background Transport (LEDBAT)' to the IESG for consideration as an Experimental RFC
Feb 2010 - Submit 'A Survey of Lower-than-Best Effort Transport Protocols' to the IESG for consideration as an Informational RFC

The first draft draft-ietf-ledbat-practices-recommendations isn't converging, Rolf and I are going to have a chat with the authors regarding this draft. We want to hear from the group if they think this document is useful in its present form. We started out with all the right intentions here but this is simply not converging. Unless there is strong interest in keeping draft-ietf-ledbat-practices-recommendations alive we should drop it as a WG document.

draft draft-ietf-ledbat-congestion is in great shape and once a few remaining issues are addressed I think we are ready to recommend this to IESG consideration as an Experimental RFC. Either I or Jana will be working with Stas to make the remaining changes to the draft and address the open issues.

The survey is in a good shape but as Lars pointed out isn't the most important document to work on.

This brings us to the plan for IETF78. Rolf and I had a chat this morning about whether this WG should meet. We want the list to speak up. Our recommendation is to make changes to the ledbat draft and complete the discussion over email, forward the document to IESG and close the WG.

Please speak up, as of now we do not plan to schedule a meeting at the next IETF.

Thanks
Murari & Rolf.

---

From: Michael Welzl <[email-masked]>
Date: Wed, 9 Jun 2010 17:41:48 +0200

Hi,

We're currently working on an update of the survey, which I would  
present at the
next meeting if there is one. I don't think it's necessary to meet  
just for this draft.

Cheers,
Michael

On Jun 9, 2010, at 5:26 PM, Murari Sridharan wrote:

> All:
>
> We set out with three goals for this WG with the most important one  
> to put out an experimental congestion algorithm for less-than-best- 
> effort traffic.
>
> Oct 2009 - Submit 'Multiple Transport Connections in Applications  
> Design' to the IESG for consideration as an Informational RFC
> Oct 2009 - Submit 'Low Extra Delay Background Transport (LEDBAT)' to  
> the IESG for consideration as an Experimental RFC
> Feb 2010 - Submit 'A Survey of Lower-than-Best Effort Transport  
> Protocols' to the IESG for consideration as an Informational RFC
>
> The first draft draft-ietf-ledbat-practices-recommendations isn’t  
> converging, Rolf and I are going to have a chat with the authors  
> regarding this draft. We want to hear from the group if they think  
> this document is useful in its present form. We started out with all  
> the right intentions here but this is simply not converging. Unless  
> there is strong interest in keeping draft-ietf-ledbat-practices- 
> recommendations alive we should drop it as a WG document.
>
> draft draft-ietf-ledbat-congestion is in great shape and once a few  
> remaining issues are addressed I think we are ready to recommend  
> this to IESG consideration as an Experimental RFC. Either I or Jana  
> will be working with Stas to make the remaining changes to the draft  
> and address the open issues.
>
> The survey is in a good shape but as Lars pointed out isn’t the most  
> important document to work on.
>
> This brings us to the plan for IETF78. Rolf and I had a chat this  
> morning about whether this WG should meet. We want the list to speak  
> up. Our recommendation is to make changes to the ledbat draft and  
> complete the discussion over email, forward the document to IESG and  
> close the WG.
>
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat

---

From: Murari Sridharan <[email-masked]>
Date: Wed, 9 Jun 2010 15:54:03 +0000

Great, thanks. 

-----Original Message-----
From: Michael Welzl [mailto:[email-masked]] 
Sent: Wednesday, June 09, 2010 8:42 AM
To: Murari Sridharan
Cc: [email-masked]; [email-masked]
Subject: Re: [ledbat] LEDBAT Status and plan moving forward

Hi,

Cheers,
Michael

On Jun 9, 2010, at 5:26 PM, Murari Sridharan wrote:

> The first draft draft-ietf-ledbat-practices-recommendations isn't

---

From: Joe Touch <[email-masked]>
Date: Wed, 09 Jun 2010 09:09:31 -0700

Hi, all,

Murari Sridharan wrote:
> All:
> 
>  
> 
> We set out with three goals for this WG with the most important one to
> put out an experimental congestion algorithm for less-than-best-effort
> traffic.
> 
...
> regarding this draft. We want to hear from the group if they think this
> document is useful in its present form. We started out with all the
> right intentions here but this is simply not converging. Unless there is
> strong interest in keeping draft-ietf-ledbat-practices-recommendations
> alive we should drop it as a WG document.

I see this as one of the most important documents, since it helps those outside
this community determine the bounds and utility of our solutions.

As one of the co-authors of this doc, I'd be more than glad to contribute
further cycles on this. The past scheduling has been unfortunate (overlapping
with MIF and BEHAVE, among others).

> morning about whether this WG should meet. We want the list to speak up.
> Our recommendation is to make changes to the ledbat draft and complete
> the discussion over email, forward the document to IESG and close the WG.

This might be an opportunity to discuss the potential impact and interactions
between MIF, BEHAVE, MPTCP, and LEDBAT, IMO, as well as to address the concerns
with the practices/recommendations doc.

Provided we can avoid overlaps ;-)

Joe

---

From: Murari Sridharan <[email-masked]>
Date: Wed, 9 Jun 2010 17:16:25 +0000

Joe if you can take the lead and spend cycles on that draft that would be great and it gives me confidence that we may be able to salvage the document.  

Regarding scheduling the actual meeting I am going to wait to see how many people express interest in meeting as a WG. I will include BEHAVE in the conflict list if we do schedule it. If there is not much interest a few of us could still meet and get the documents in shape and send the updates to the list. 

Thanks
Murari 

-----Original Message-----
From: Joe Touch [mailto:[email-masked]] 
Sent: Wednesday, June 09, 2010 9:10 AM
To: Murari Sridharan
Cc: [email-masked]; [email-masked]
Subject: Re: [ledbat] LEDBAT Status and plan moving forward

Hi, all,

...
> there is strong interest in keeping 
> draft-ietf-ledbat-practices-recommendations

I see this as one of the most important documents, since it helps those outside this community determine the bounds and utility of our solutions.

As one of the co-authors of this doc, I'd be more than glad to contribute further cycles on this. The past scheduling has been unfortunate (overlapping with MIF and BEHAVE, among others).

> the discussion over email, forward the document to IESG and close the WG.

This might be an opportunity to discuss the potential impact and interactions between MIF, BEHAVE, MPTCP, and LEDBAT, IMO, as well as to address the concerns with the practices/recommendations doc.

Joe

---

From: Joe Touch <[email-masked]>
Date: Wed, 09 Jun 2010 11:29:44 -0700

Hi, Murari,

Murari Sridharan wrote:
> Joe if you can take the lead and spend cycles on that draft that would be
> great and it gives me confidence that we may be able to salvage the document.

Will do.

> Regarding scheduling the actual meeting I am going to wait to see how many
> people express interest in meeting as a WG. I will include BEHAVE in the
> conflict list if we do schedule it. If there is not much interest a few of us
> could still meet and get the documents in shape and send the updates to the list.

AOK - FWIW, my hard conflicts include:
	TCPM
	SOFTWIRE
	TSVWG
	INTAREA

Others which we should also avoid overlap, IMO:
	BEHAVE
	MIF
	MPTCP
	TSVAREA

Joe

---

From: Jason Livingood <[email-masked]>
Date: Thu, 10 Jun 2010 08:49:06 -0400

>> The first draft draft-ietf-ledbat-practices-recommendations isn¹t

I also think the document provides useful information.  If the authors can
keep working on it, that'd be great.

Jason

---

From: Jason Livingood <[email-masked]>
Date: Thu, 10 Jun 2010 08:52:10 -0400

> could still meet and get the documents in shape and send the updates to the

The first question you should ask is what you want to do with the time.  If
it is to ask for feedback on some open issues for which an author is unsure
how to proceed, or we have a lot of new documents/content, then surely it is
useful.  But, on the other hand, if you mainly need to iterate documents and
make real progress on drafts, then your time may be better served focusing
on writing / editing (which may not be interesting to a room full of
people).

Jason

---

From: Dario Rossi <[email-masked]>
Date: Wed, 16 Jun 2010 16:38:04 +0200

Dear all,

we have been doing some more work on LEDBAT (currently under 
submission), which I think it may be interesting to share on the WG list 
to stimulate the discussion:

#1: investigation of LEDBAT latecomer issue and possible solutions
     http://arxiv.org/abs/1006.3018

#2: comparison of  different "lower than best effort" protocols (i.e. 
LEDBAT, TCP-LP and TCP-NICE)
     http://arxiv.org/abs/1006.3017

for the above work we have been using a custom implementation of LEDBAT 
for the ns2 simulator (notice that  our code can also work as Linux 
kernel module, so that testbed experiments can be done as well), 
available at:
      
http://perso.telecom-paristech.fr/~valenti/pmwiki/pmwiki.php?n=Main.LEDBAT

thus, note that #1 and #2 have not used the uTP library that BitTorrent 
released at the end of may:
     Blog: 
http://blog.bittorrent.com/2010/05/21/%C2%B5tp-open-source-implementation/
     Code: http://github.com/bittorrent/libutp

as of today, we are not sure if we can participate to the IETF78 meeting 
(but in the latter case we would be happy to give presentations of #1 
and #2 if this is of interest for the WG)

Best regards,
D.

-- 
        Dario Rossi
  Oo    Associate Professor
   >     TELECOM ParisTech
  ~     (formerly ENST)

mail:  [email-masked]
phone: +33.1.4581.7563
fax:   +33.1.4581.7158
web:   http://www.enst.fr/~drossi