Subject: [ledbat] status update and way forward

From: Rolf Winter <[email-masked]>
Date: Thu, 30 Sep 2010 01:28:09 +0000

Hi WG,

It has been rather silent on the list for some time and feedback comes in slow. Partly this is due to document progress which is far too slow despite announced updates. Consulting with the ADs, we made a couple of decisions based on the progress and activity level we are seeing. 

1. We assigned an editor to the Congestion Control draft who will bring the document in shape, ready for a last call. This will happen before Beijing. 
2. We decided to drop draft-ietf-ledbat-survey as a milestone. The draft has already expired and has not seen an update since the adoption as a WG item.
3. We believe that draft-ietf-ledbat-practices-recommendations is a valuable document to finish, however this draft has also expired and is not in a good shape. Given the interest in the past and the low activity despite a reasonable number of authors we are not confident that it will progress in a reasonable manner. It is up to the authors what to do with this draft, but as soon as the Congestion Control draft is done, the WG will close.

Feedback as always welcome.

Best,

	Murari & Rolf

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Michael Welzl <[email-masked]>
Date: Thu, 30 Sep 2010 10:14:13 +0200

> 2. We decided to drop draft-ietf-ledbat-survey as a milestone. The  
> draft has already expired and has not seen an update since the  
> adoption as a WG item.

ARGH!! PLEASE!   Without even a comment to us authors?!

I'm terribly sorry for the draft's expiry; this didn't go unnoticed to  
us, and we are trying to get this updated just now, definitely in time  
before the next IETF!
Had we known that you're considering dropping it, we would have of  
course updated it faster!!  I thought it's not a big deal that it  
expired as long as we were going to provide an update by the next  
meeting anyway.

Either way this next one is quite a minor update, as we believe that  
the document is already in quite a good shape. A lot of work has  
already gone into this, before approving it as a WG item
I ask you to PLEASE reconsider this!

Michael

---

From: "Mayutan A." <[email-masked]>
Date: Thu, 30 Sep 2010 11:52:24 +0200

Hi,

I have read the drafts a couple of times and have found it quite useful,
especially in the context of LEDBAT. I personally feel that it is a useful
document to have.

I would recommend adding a section on RAPID:
RAPID, unlike other congestion control protocols is a multi-rate based
protocol
based on the principles of pathChirp. RAPID sends packets with varying
intergap and
uses this intergap to identify available bandwidth. Though RAPID wasn't
designed as a submissive protocol, it can be easily adjusted to be one.

Just my two cents.
Cheers,
Mayutan

On Thu, Sep 30, 2010 at 10:14 AM, Michael Welzl <[email-masked]> wrote:

> 2. We decided to drop draft-ietf-ledbat-survey as a milestone. The draft
>> has already expired and has not seen an update since the adoption as a WG
>> item.
>>
>
> I'm terribly sorry for the draft's expiry; this didn't go unnoticed to us,
> and we are trying to get this updated just now, definitely in time before
> the next IETF!
> Had we known that you're considering dropping it, we would have of course
> updated it faster!!  I thought it's not a big deal that it expired as long
> as we were going to provide an update by the next meeting anyway.
>
> Either way this next one is quite a minor update, as we believe that the
> document is already in quite a good shape. A lot of work has already gone
> into this, before approving it as a WG item
> _______________________________________________
> ledbat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ledbat
>

-- 
Mayutan Arumaithurai
0049-551-2712647 (Home number)
0049-176-20322049 (mobile number)

---

From: Michael Welzl <[email-masked]>
Date: Thu, 30 Sep 2010 13:35:37 +0200

Hi!

Thanks a lot for your comments!
About RAPID, thanks for your suggestion! We'll have to think about this.
We tried to keep focus the draft on work that was designed to be  
submissive (although the MulTCP etc. work is a bit of an exception  
there...) to avoid writing an endless document whose scope isn't  
really clear. MANY protocols could easily be adjusted to work in the  
less-than-best-effort region - e.g. all the delay-based mechanisms  
such as FAST, CTCP etc., so in general, being easy to adjust isn't  
enough to qualify being covered in this draft.

Cheers,
Michael

On Sep 30, 2010, at 11:52 AM, Mayutan A. wrote:

> Hi,
>
> I have read the drafts a couple of times and have found it quite  
> useful, especially in the context of LEDBAT. I personally feel that  
> it is a useful document to have.
>
> RAPID, unlike other congestion control protocols is a multi-rate  
> based protocol
> based on the principles of pathChirp. RAPID sends packets with  
> varying intergap and
> uses this intergap to identify available bandwidth. Though RAPID  
> wasn't designed as a submissive protocol, it can be easily adjusted  
> to be one.
>
> Just my two cents.
> Cheers,
> Mayutan
>
> I'm terribly sorry for the draft's expiry; this didn't go unnoticed  
> to us, and we are trying to get this updated just now, definitely in  
> time before the next IETF!

---

From: "Mayutan A." <[email-masked]>
Date: Thu, 30 Sep 2010 13:55:24 +0200

Hi,

I agree that "easy to adjust" isn't a good criteria for a mechanism to fit
in this document. Based on discussions and simulation results obtained by
our group, it seems that RAPID  would in fact be submissive in nature
(though the authors didn't sell it as a submissive protocol).

Cheers,
Mayutan

On Thu, Sep 30, 2010 at 1:35 PM, Michael Welzl <[email-masked]> wrote:

> We tried to keep focus the draft on work that was designed to be submissive
> (although the MulTCP etc. work is a bit of an exception there...) to avoid
> writing an endless document whose scope isn't really clear. MANY protocols
> could easily be adjusted to work in the less-than-best-effort region - e.g.
> all the delay-based mechanisms such as FAST, CTCP etc., so in general, being
> easy to adjust isn't enough to qualify being covered in this draft.
>
> Cheers,
> Michael
>
>
>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 30 Sep 2010 13:58:04 +0200

That would definitely change the situation. Thanks for this data  
point! We'll take a closer look at it (from the perspective of our  
draft), provided that the draft isn't kicked out...

On Sep 30, 2010, at 1:55 PM, Mayutan A. wrote:

> Hi,
>
> I agree that "easy to adjust" isn't a good criteria for a mechanism  
> to fit in this document. Based on discussions and simulation results  
> obtained by our group, it seems that RAPID  would in fact be  
> submissive in nature (though the authors didn't sell it as a  
> submissive protocol).
>
> Cheers,
> Mayutan
>

---

From: Rolf Winter <[email-masked]>
Date: Thu, 30 Sep 2010 13:19:53 +0000

Hi Michael,

this shouldn't come as a complete surprise. Four (4) months ago we sent an Email to the list about how we could go forward and asked for feedback. Quoting:

"Our recommendation is to make changes to the ledbat draft and complete the discussion over email, forward the document to IESG and close the WG."

After which ALL document authors said that a new version is just around the corner, including you. As you know this has not happened. 

Best,

	Rolf 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Michael Welzl
> Sent: Donnerstag, 30. September 2010 10:14
> To: Rolf Winter
> Cc: [email-masked]; David Ros
> Subject: Re: [ledbat] status update and way forward
>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 30 Sep 2010 15:47:03 +0200

Hi,

I took this message as procedural - that was, I think, regarding the  
necessity to present it at a meeting or not (I think it was because  
LEDBAT didn't meet in Maastricht, and then we wondered how to proceed).
Anyway: indeed we were expecting to get a new version done very soon  
then, but after that it was preempted by things with deadlines in our  
todo list. I really didn't see how urgent this is, I just understood  
that it's ok for you to complete the discussion via email. Had I known  
that this is urgent and you really *need* us to do an update soon, we  
would have quickly done that!

Very sorry for misunderstanding the situation, and for having  
announced an update which then didn't happen for a long time. The  
sense of urgency is crystal clear now, so we would definitely move  
ahead fast - but I hope the document doesn't have to be dropped!

Cheers,
Michael

On Sep 30, 2010, at 3:19 PM, Rolf Winter wrote:

> Hi Michael,
>
> this shouldn't come as a complete surprise. Four (4) months ago we  
> sent an Email to the list about how we could go forward and asked  
> for feedback. Quoting:
>
> "Our recommendation is to make changes to the ledbat draft and  
> complete the discussion over email, forward the document to IESG and  
> close the WG."
>
> After which ALL document authors said that a new version is just  
> around the corner, including you. As you know this has not happened.
>
> Best,
>
> 	Rolf
>
>
>
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,  
> London W3 6BL | Registered in England 2832014
>
>
>> to

---

From: Rolf Winter <[email-masked]>
Date: Thu, 30 Sep 2010 15:10:33 +0000

Michael,

The plan is to close the WG once the congestion control draft is done. If you can finish the document before that and get consensus on this list then that would be great. I also hope something similar can be done for the other remaining draft that we have. Given the little feedback recently, I would like to have at least three (3) people to commit to reviewing the document thoroughly though.

Do you think this is a workable way forward?

Best,

	Rolf

> From: Michael Welzl [mailto:[email-masked]]
> Sent: Donnerstag, 30. September 2010 15:47
> To: Rolf Winter

---

From: Michael Welzl <[email-masked]>
Date: Thu, 30 Sep 2010 17:29:54 +0200

Absolutely! We'll do our best, promise!!

Cheers,
Michael

On Sep 30, 2010, at 5:10 PM, Rolf Winter wrote:

> Michael,
>
> The plan is to close the WG once the congestion control draft is  
> done. If you can finish the document before that and get consensus  
> on this list then that would be great. I also hope something similar  
> can be done for the other remaining draft that we have. Given the  
> little feedback recently, I would like to have at least three (3)  
> people to commit to reviewing the document thoroughly though.
>

---

From: Murari Sridharan <[email-masked]>
Date: Thu, 30 Sep 2010 17:07:58 +0000

Michael, to reiterate what Rolf said if you can pull this off prior to Beijing that would be great. We went through several deliberations at our end these past months and given the lack of activity both from authors and in the WG mailing lists and given the fact that our most important deliverable is the congestion control draft we decided to proceed forward trying to complete just that. 

Thanks

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Welzl
Sent: Thursday, September 30, 2010 8:30 AM
To: Rolf Winter
Cc: [email-masked]; David Ros
Subject: Re: [ledbat] status update and way forward

Cheers,
Michael

On Sep 30, 2010, at 5:10 PM, Rolf Winter wrote:

> Michael,
>
> The plan is to close the WG once the congestion control draft is done. 
> If you can finish the document before that and get consensus on this 
> list then that would be great. I also hope something similar can be 
> done for the other remaining draft that we have. Given the little 
> feedback recently, I would like to have at least three (3) people to 
> commit to reviewing the document thoroughly though.
>
>> that it's ok for you to complete the discussion via email. Had I 
>> known that this is urgent and you really *need* us to do an update 
>> soon, we would have quickly done that!
>>
>>>> to us, and we are trying to get this updated just now, definitely 
>>>> in time before the next IETF!
>>>> Either way this next one is quite a minor update, as we believe 
>>>> that the document is already in quite a good shape. A lot of work 
>>>> has already gone into this, before approving it as a WG item I ask 
>>>> you to PLEASE reconsider this!
>>>>
>>>> Michael
>>>>

---

From: David Ros <[email-masked]>
Date: Thu, 30 Sep 2010 22:14:18 +0200

Rolf, Murari & all,

I'd like to add my apologies to Michael's. As he said, we were aware of the draft's expiry, were really planning to updating it before Beijing, but hadn't grasped the urgency. Our original plan was (still is!) to have an update ready no later than the end of next week -- I hope this is OK.

Mayutan: thanks a lot for the pointer to RAPID. I was aware of this paper but hadn't considered it for the reasons Michael explained. In light of what you said, we'll definitely take a good look at it.

Again, very sorry for the delay...

Best regards,

David.

>>>>> you to PLEASE reconsider this!

=================================================================
David ROS
http://www.rennes.enst-bretagne.fr/~dros/

I love deadlines. I like the whooshing sound they make as they fly by. -- Douglas Adams