Subject: Re: [lemonade] CATENATE, URLAUTH and RFC 2192bis

From: Randall Gellens <[email-masked]>
Date: Tue, 20 Dec 2005 14:43:21 -0800

At 4:35 PM -0800 11/30/05, Mark Crispin wrote:

>  On Wed, 30 Nov 2005, Ken Murchison wrote:
>>  In other words, the client has no way of knowing whether the 
>> server supports partial fetches.
>
>  Unless we want to pull URLAUTH back from the RFC Editor queue, we 
> will need a new new IMAP capability which announces support for 
> ipartial in URLs.
>
>  Is ipartial in URLs a LEMONADE requirement?  I forget if it is or not.
>
>>  The solution would be to make RFC 2192bis the normative reference 
>> for both CATENATE and URLAUTH.
>
>  I think that this is a bad idea for URLAUTH.  I hope that 2192bis 
> will replace both RFC 2192 and URLAUTH by incorporating URLAUTH; 
> but to do 2192bis properly will require time.

Can it be done in time for Profile v2?  If so, we could do a revision 
of CATENATE and URLAUTH that makes 2192bis the normative reference, 
and publish 2192bis, CATENATEbis, URLAUTHbis, and profile bis at the 
same time.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
A child of five would understand this.  Send somebody to
fetch a child of five.        --Groucho Marx, _Duck Soup_

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 21 Dec 2005 11:14:28 +0000

Randall Gellens wrote:

>>>  In other words, the client has no way of knowing whether the server 
>>> supports partial fetches.
>>
Seems like it is needed to satisfy OMA requirements.

>> will replace both RFC 2192 and URLAUTH by incorporating URLAUTH; but 
>> to do 2192bis properly will require time.
>

I think that is the plan, but we still need a new capability for partial 
support in IMAP URLs. Can the same capability cover use of partial in 
both CATENATE and URLAUTH?