Subject: [lemonade] draft-ietf-lemonade-vfolder

From: "Weingarten Jerry" <[email-masked]>
Date: Thu, 16 Mar 2006 16:45:34 +0200

Hi,

I am confused by the Formal syntax (section 5) and the examples in
section 6 -
The syntax seems to refer to a literal string "LVFOLDER" whereas the
examples use a string "LPSEARCH" is there a connection between the two?
Also the first example in section 6 uses as the psearch string - (INBOX
HEADER "Sender" "lemonade-bounces") what header field is this searching
or is it searching the entire message header  for either of the two
strings?  What is the meaning of multiple search strings - is it "OR" or
"AND"?

Thanx,

Yaacov (Jerry) Weingarten
Comverse - Standards 
phone: +972-3-645 2392
mobile: +972-52-854 2392
email: [email-masked]

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Mon, 20 Mar 2006 14:42:49 -0800

At 4:45 PM +0200 3/16/06, Weingarten Jerry wrote:

>  Also the first example in section 6 uses as the psearch string - 
> (INBOX HEADER "Sender" "lemonade-bounces") what header field is 
> this searching or is it searching the entire message header  for 
> either of the two strings?  What is the meaning of multiple search 
> strings - is it "OR" or "AND"?

Hi Jerry,

This is in RFC 3501, the IMAP specification.  HEADER is a search key 
that looks for the second string in the header whose name is the 
first string.  Note that it does a case-insensitive substring match.

Per RFC 3501, if multiple keys are entered the match is on all of them (AND).
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Premature optimization is the root of all evil
                              --C. A. R. Hoare