Subject: [lemonade] confusion on syntax of the access portion of the URLAUTH

From: Peter Coates <[email-masked]>
Date: Thu, 30 Mar 2006 12:29:54 -0800

the description of the access portion of URLAUTH tells me about the meaning
of authuser, anonymous, user+userid, and submit+userid.
 
the ABNF tells me that 
 
access          = ("submit+" iuserauth) / ("user+" iuserauth) /
                    "authuser" / "anonymous"

iuserauth is defined in RFC 2192 as
 
iuserauth        = enc_user [iauth] / [enc_user] iauth

What would the meaning be of a URLAUTH with an access portion of the form
 
;URLAUTH=user+;auth=*
or
;URLAUTH=submit+;auth=xxx
 
Would such forms be legal?  the syntax seems a bit tortured.  But I assume
this is deliberate as it would have been easy to define access as
 
access          = ("submit+" enc_user) / ("user+" enc_user) /
                    "authuser" / "anonymous"

if that had been the intent.

I also note that iuserauth is replaced with iuserinfo in
draft-ietf-lemonade-rfc2192bis-01.txt

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Fri, 31 Mar 2006 18:26:05 -0800 (Pacific Standard Time)

I think that we decided that iauth wasn't meaningful in IMAP URLs that use 
URLAUTH, because we don't allow relative IMAP URLs with URLAUTH.

But I forget why we used the iuserauth instead of the enc_user rule.

Should we fix this?  Can I get away with doing so during AUTH48?

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.