Subject: RE: [lemonade] Future Release a WG item or ind. submission

From: "Vaudreuil, Greg M (Greg)" <[email-masked]>
Date: Fri, 24 Mar 2006 08:08:51 -0600

Ned asserted that the document was not part of the charter.  I incorrectly agreed, forgetting that we had debated this point and accepted the document as a WG item when we last met in greater Dallas almost two years ago.  So, there was discussion in the meeting about whether this was or was not a WG item.  It is fair to say the discussion was confused.

The current document is the result of incorporating comments received during WG last call. This is document is a WG work item and is now ready for IETF last-call (once the ID clears the publishing queue).

Greg V.

-----Original Message-----
From: Tony Hansen [mailto:[email-masked]]
Sent: Friday, March 24, 2006 1:51 AM
To: Chris Newman
Cc: [email-masked]
Subject: Re: [lemonade] Future Release a WG item or ind. submission

Sometimes we'll move on to the next slide, but then additional comments
will continue to be made on the previous topic. The log doesn't always
capture those flip flop situations.

	Tony Hansen
	[email-masked]

Chris Newman wrote:
> The jabber log was slightly out of order.  The discussion was about the
> object-based encryption proposal.
> 
>                - Chris
> 
> Greg White wrote on 3/22/06 20:52 -0600:
> 
>> Hi,
>>
>> I just read the jabber logs from today's Lemonade meeting.  Clip re: the
>> status of Future Release as a WG item:
>>
>> [11:51:24] <tonyhansen> slide #32: futuer delivery
>> [11:51:41] --- jr111 has joined
>> [11:51:55] <randy> Chris said he user case was interesting but
>> shouldn't be
>> a wg item
>> [11:52:01] <randy> s/he/his/
>> [11:52:51] <tonyhansen> ned: this doc is really not in charter; should
>> have
>> been in vpim; individual contrib so ok
>>
>>
>> I'm not sure I understand what Tony's version of what Ned said means,
>> but I
>> will point the group to
>> http://www1.ietf.org/mail-archive/web/lemonade/current/msg00568.html ,
>> which
>> contains the minutes for the Interim Meeting in Richardson, TX in June
>> 2004.
>> At this meeting, it was voted that the document would be a WG item. 
>> Because
>> of this, I changed the name of the draft from
>> draft-vaudreuil-futuredelivery-02.txt to
>> draft-ietf-lemonade-futuredelivery-00.txt at the end of June 2004.  This
>> change has been noted in the change log at the end of the draft since
>> June
>> 2004.
>>
>> So, folks, what is the state of the draft?
> 
> 
> _______________________________________________
> lemonade mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Ned Freed <[email-masked]>
Date: Fri, 24 Mar 2006 09:26:24 -0800 (PST)

> Ned asserted that the document was not part of the charter.

It isn't. If you believe otherwise please cite the charter work item it fits
under. I just reread the charter (for about the tenth time) and I sure don't
see it.

> I incorrectly agreed, forgetting that we had debated this point and accepted
> the document as a WG item when we last met in greater Dallas almost two years
> ago.  So, there was discussion in the meeting about whether this was or was not
> a WG item.  It is fair to say the discussion was confused.

Excuse me, but it was nothing of the sort. Future release is not part of the
work the group was chartered to do. And it doesn't matter what the working
group agreed to two years ago unless that agreement caused a charter update.
Working groups don't get to add things to their charters without IESG approval.
It doesn't matter if there is universal agreement which is repeatedly
reaffirmed on the list and at every meeting over the course of a decade. It
also doesn't matter that the problem went unnoticed for a while. This just
isn't how the process works.

Now, I have no problem with the charter being amended to add this. I also have
no problem with this document proceeding as an individual submission and being
reviewed in this group. But it canont proceed as a working group document
without a charter revision. Period! Full stop!

The issue here isn't that future release is a bad proposal. It isn't - it's  a
good proposal. The issue here is one of precedent. If we let working groups
work on anything they feel like charters won't be worth the electrons they're
composed of. Sooner or later there will be a group that after being chartered
wants to embrace something that's a really bad idea. We cannot afford a
situation such a group can point over here and say "it didn't matter that this
was out of scope for LEMONADE - you let them do it anything". We really don't
have all that many rules and restrictions, and that makes the ones we do have
even more important.

> The current document is the result of incorporating comments received during
> WG last call. This is document is a WG work item and is now ready for IETF
> last-call (once the ID clears the publishing queue).

And I again repeat that it either needs to be renamed as a non-WG document or
we need a charter amendment. Please don't make me have to appeal this, because
I will if I have to.

				Ned

---

From: Mark Crispin <[email-masked]>
Date: Fri, 24 Mar 2006 10:10:41 -0800 (PST)

On Fri, 24 Mar 2006, Ned Freed wrote:
> we need a charter amendment.

Either of these two courses of action will be considerably less painful 
than an appeal.

I personally vote for a non-WG document that was reviewed in the WG. 
This is the easiest course of action, and I doubt very much that it will 
be at all controversial.  A charter amendment can open up avenues for 
mischief (not to mention delaying the eventual termination of the WG).

Let's just do it.

Given that my Lemonade work is more or less on idle with the approval of 
the trio, I'm willing to take on responsibility for this document and 
shepherding it through approval.  However, if I do so, be warned that I'll 
substantially revise it; no technical change, but much less text.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.

---

From: "Greg White" <[email-masked]>
Date: Fri, 24 Mar 2006 12:45:01 -0600

I'll take care of it, but why do you think it needs substantially less text?

Greg W.

-----Original Message-----
From: Mark Crispin [mailto:[email-masked]] 
Sent: Friday, March 24, 2006 12:11 PM
To: Ned Freed
Cc: [email-masked]; Tony Hansen; Vaudreuil Greg M Greg
Subject: RE: [lemonade] Future Release a WG item or ind. submission

On Fri, 24 Mar 2006, Ned Freed wrote:
> And I again repeat that it either needs to be renamed as a non-WG 
> document or we need a charter amendment.

Let's just do it.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch. Liberty
is a well-armed sheep contesting the vote.

_______________________________________________
lemonade mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Mark Crispin <[email-masked]>
Date: Fri, 24 Mar 2006 13:13:09 -0800 (PST)

> I'll take care of it, but why do you think it needs substantially less text?

25K of text for such a minor extension is ridiculous.  This is the sort of 
bloat that encourages people not to read specifications.

There's obvious fluff in the document: statements of opinion ("It is 
unfortunate to define two seemingly identical ways to indicate a future 
delivery time."), redundancy, or statement of the obvious.  If something 
isn't necessary to define the protocol, it should be removed.

I don't particularly care for the use of the passive voice or other 
wordiness in the necessary text.  For example, the Framework can be 
expressed much more succinctly; and the result would be quite a bit 
clearer.

-- Mark --

http://panda.com/mrc