Subject: [lemonade] Locating media servers for streaming

From: Neil Cook <[email-masked]>
Date: Wed, 14 Jun 2006 18:44:04 +0100

All,

Been thinking about the potential problem of lemonade clients  
locating a media server to use in reference to streaming a multimedia  
attachment.

There are several scenarios where media server location is *required*:

1) Discovery of media servers if client doesn't know *any* already.
(How likely is this scenario? You would need a SIP-capable client
that is not configured with any media servers, which doesn't seem  
incredibly likely)

2) Discovery of media servers that are authorised to access an IMAP
server, because it is configured to accept URLFETCH requests only
from certain media servers.

There are also several scenarios where media server location is a
nice-to-have for other reasons such as security. I'm thinking of the
security implications of pawn-ticket URLs. The IMAP server could return
a media server address together with the username that the media server
uses to access the IMAP server, and thus the client could generate a URL
which was secure in that it could *only* be accessed by the media server
in question.

Any thoughts?

Neil.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: <[email-masked]>
Date: Tue, 20 Jun 2006 13:52:09 +0300

Could there be a separate command for this? (so that the client can get the latest info if needed at any time)
E.g.
To get full mapping:
C: GETMEDIASERVER
S: Server1 (1.1.1.1: avi, divx, wmv, wma); Server2 (1.1.1.2: mov, rm, mp3, ac3)

To get a server that handles a particular type:
C: GETMEDIASERVER avi
S: Server1(1.1.1.1)

Also, I have a question - perhaps it was described/discussed before, apologies if it was:
Can I stream a content that is being converted?
E.g. I get an AC3 audio stream as attachment, can I stream it as MP3 instead?

Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

-----Original Message-----
From: ext Neil Cook [mailto:[email-masked]] 
Sent: 14 June, 2006 20:44
To: [email-masked]
Subject: [lemonade] Locating media servers for streaming

All,

Been thinking about the potential problem of lemonade clients locating a media server to use in reference to streaming a multimedia attachment.

1) Discovery of media servers if client doesn't know *any* already.
(How likely is this scenario? You would need a SIP-capable client that is not configured with any media servers, which doesn't seem incredibly likely)

2) Discovery of media servers that are authorised to access an IMAP server, because it is configured to accept URLFETCH requests only from certain media servers.

There are also several scenarios where media server location is a nice-to-have for other reasons such as security. I'm thinking of the security implications of pawn-ticket URLs. The IMAP server could return a media server address together with the username that the media server uses to access the IMAP server, and thus the client could generate a URL which was secure in that it could *only* be accessed by the media server in question.

Any thoughts?

Neil.

---

From: Neil Cook <[email-masked]>
Date: Tue, 20 Jun 2006 15:48:11 +0100

Zoltan,

yes I was thinking of a separate command - the latest draft just  
posted contains a description of the problem and a high-level  
proposal for a solution similar to your suggestion below. I wanted to  
get a feeling for whether we should do this before going into command  
specifics.

As for your second question, that is really a function of the media  
server. If the client presents a set of acceptable media in the SDP  
to the media server that is different from the media in the  
attachment, then the media server could transcode it, depending on  
its capabilities. So theoretically, yes. Of course there may not be a  
suitable transcoder from/to the supported media types, but that is an  
implementation issue.

Neil.

On 20 Jun 2006, at 11:52, <[email-masked]>  
<[email-masked]> wrote:

> Could there be a separate command for this? (so that the client can  
> get the latest info if needed at any time)
> E.g.
> To get full mapping:
> C: GETMEDIASERVER
> locating a media server to use in reference to streaming a  
> multimedia attachment.
>
> nice-to-have for other reasons such as security. I'm thinking of  
> the security implications of pawn-ticket URLs. The IMAP server  
> could return a media server address together with the username that  
> the media server uses to access the IMAP server, and thus the  
> client could generate a URL which was secure in that it could  
> *only* be accessed by the media server in question.
>
> Any thoughts?
>
> Neil.
>
>

---

From: <[email-masked]>
Date: Wed, 21 Jun 2006 13:23:55 +0300

Thank You Neil,
I would definiately prefer the new command - the client could always get up-to-date information according to its needs.

Back to the second issue: I understand what You are saying, and I agree, however my question was more like: "Does the syntax support this and how to do this?" I mean, You get a BURL so You an stream the media from the media server. How can transcoding parameters be added to the BURL (so that You can tell the server that You could give me that content like this as well, just let me know which type it will be)? 

Thank You.

-----Original Message-----
From: ext Neil Cook [mailto:[email-masked]] 
Sent: 20 June, 2006 17:48
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere)
Cc: [email-masked]
Subject: Re: [lemonade] Locating media servers for streaming

Zoltan,

yes I was thinking of a separate command - the latest draft just posted contains a description of the problem and a high-level proposal for a solution similar to your suggestion below. I wanted to get a feeling for whether we should do this before going into command specifics.

As for your second question, that is really a function of the media server. If the client presents a set of acceptable media in the SDP to the media server that is different from the media in the attachment, then the media server could transcode it, depending on its capabilities. So theoretically, yes. Of course there may not be a suitable transcoder from/to the supported media types, but that is an implementation issue.

Neil.

On 20 Jun 2006, at 11:52, <[email-masked]> <[email-masked]> wrote:

> get the latest info if needed at any time) E.g.
> To get full mapping:
> C: GETMEDIASERVER
> Been thinking about the potential problem of lemonade clients locating 
> a media server to use in reference to streaming a multimedia 
> attachment.
>
> (How likely is this scenario? You would need a SIP-capable client that 
> is not configured with any media servers, which doesn't seem 
> incredibly likely)
>
> server, because it is configured to accept URLFETCH requests only from 
> certain media servers.
>
> security implications of pawn-ticket URLs. The IMAP server could 
> return a media server address together with the username that the 
> media server uses to access the IMAP server, and thus the client could 
> generate a URL which was secure in that it could

---

From: Neil Cook <[email-masked]>
Date: Wed, 21 Jun 2006 11:46:10 +0100

Zoltan,

when the client contacts the media server, it provides the URL as a  
parameter to the SIP INVITE as in my draft. What the draft doesn't go  
into the details of is the SIP payload, which is SDP. SDP contains  
all the media negotiation facilities required for this, and the  
client would simply setup the correct SDP parameters to indicate  
which media is it prepared to accept for this session. The reply to  
the invite contains SDP parameters from the media server.

I didn't go into the details of SIP/SDP in the draft, kind of  
assuming that it was well understood, but I can flesh it out the fact  
that SDP will be used for the media negotiation a little more. I  
gueess it is a little presumptuous to assume that all messaging folks  
also know about SDP.

Neil.

On 21 Jun 2006, at 11:23, <[email-masked]>  
<[email-masked]> wrote:

> Thank You Neil,
> I would definiately prefer the new command - the client could  
> always get up-to-date information according to its needs.
>
> Back to the second issue: I understand what You are saying, and I  
> agree, however my question was more like: "Does the syntax support  
> this and how to do this?" I mean, You get a BURL so You an stream  
> the media from the media server. How can transcoding parameters be  
> added to the BURL (so that You can tell the server that You could  
> give me that content like this as well, just let me know which type  
> it will be)?
>
> Thank You.
>
> proposal for a solution similar to your suggestion below. I wanted  
> to get a feeling for whether we should do this before going into  
> command specifics.
>
> its capabilities. So theoretically, yes. Of course there may not be  
> a suitable transcoder from/to the supported media types, but that  
> is an implementation issue.
>
> Neil.
>
>> locating
>> that

---

From: <[email-masked]>
Date: Wed, 21 Jun 2006 13:59:55 +0300

Well, I do know some things about the SDP - but I guess it is not as much as I should.
An example would be very helpful. I do not think I am the only guy who is doing mostly email only and reading about SIP INVITE and SDP regarding emails - and start wondering. :-)

-----Original Message-----
From: ext Neil Cook [mailto:[email-masked]] 
Sent: 21 June, 2006 13:46
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere)
Cc: [email-masked]
Subject: Re: [lemonade] Locating media servers for streaming

Zoltan,

when the client contacts the media server, it provides the URL as a parameter to the SIP INVITE as in my draft. What the draft doesn't go into the details of is the SIP payload, which is SDP. SDP contains all the media negotiation facilities required for this, and the client would simply setup the correct SDP parameters to indicate which media is it prepared to accept for this session. The reply to the invite contains SDP parameters from the media server.

I didn't go into the details of SIP/SDP in the draft, kind of assuming that it was well understood, but I can flesh it out the fact that SDP will be used for the media negotiation a little more. I gueess it is a little presumptuous to assume that all messaging folks also know about SDP.

Neil.

On 21 Jun 2006, at 11:23, <[email-masked]> <[email-masked]> wrote:

> Thank You Neil,
> I would definiately prefer the new command - the client could always 
> get up-to-date information according to its needs.
>
> this and how to do this?" I mean, You get a BURL so You an stream the 
> media from the media server. How can transcoding parameters be added 
> to the BURL (so that You can tell the server that You could give me 
> that content like this as well, just let me know which type it will 
> be)?
>
> Thank You.
>
> posted contains a description of the problem and a high-level proposal 
> for a solution similar to your suggestion below. I wanted to get a 
> feeling for whether we should do this before going into command 
> specifics.
>
> server. If the client presents a set of acceptable media in the SDP to 
> the media server that is different from the media in the attachment, 
> then the media server could transcode it, depending on its 
> capabilities. So theoretically, yes. Of course there may not be a 
>> media server uses to access the IMAP server, and thus the client 
>> could generate a URL which was secure in that it could