Subject: [lemonade] Use of \Draft flag to indicate message ready for submission

From: Alexey Melnikov <[email-masked]>
Date: Mon, 05 Jun 2006 22:34:33 +0100

Hi folks,
After reviewing some of the recent editorial changed done to Profile 
bis, it occurred to me that the draft is now recommending to use the 
\Draft system flag to mark messages that are about to be submitted. I 
think this is wrong, the \Draft flag has a special meaning of "the 
marked message is being edited, it might not be a proper RFC 2822 
message", which is quite different from "the message is complete and 
waiting to be submitted". So I would suggest to define a new flag for 
the latter meaning. One of the advantage of having a new flag is ability 
to have both types of messages in the same mailbox. If a client 
submitting multiple messages crashes (which does happen), upon restart 
it can pick up from the message it failed to submit and continue 
submitting other messages in the mailbox.

Any objections to the proposal?

Alexey

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Cyrus Daboo <[email-masked]>
Date: Tue, 06 Jun 2006 12:51:50 -0400

Hi Alexey,

--On June 5, 2006 10:34:33 PM +0100 Alexey Melnikov 
<[email-masked]> wrote:

> After reviewing some of the recent editorial changed done to Profile bis,
> it occurred to me that the draft is now recommending to use the \Draft
> system flag to mark messages that are about to be submitted. I think this
> is wrong, the \Draft flag has a special meaning of "the marked message is
> being edited, it might not be a proper RFC 2822 message", which is quite
> different from "the message is complete and waiting to be submitted". So
> I would suggest to define a new flag for the latter meaning. One of the
> advantage of having a new flag is ability to have both types of messages
> in the same mailbox. If a client submitting multiple messages crashes
> (which does happen), upon restart it can pick up from the message it
> failed to submit and continue submitting other messages in the mailbox.
>

I agree - let's not overload the meaning of \Draft.

-- 
Cyrus Daboo

---

From: Anil SRIVASTAVA <[email-masked]>
Date: Tue, 06 Jun 2006 09:59:26 -0700 (Pacific Daylight Time)

I agree with the proposal.  Let us not mix \draft with message ready to 
be submitted.

Anil

On 2006-06-05/22:34 [+0100], [email-masked] [Alexey Melnikov] wrote:

> Hi folks,
> After reviewing some of the recent editorial changed done to Profile bis, it
> occurred to me that the draft is now recommending to use the \Draft system
> flag to mark messages that are about to be submitted. I think this is wrong,
> the \Draft flag has a special meaning of "the marked message is being edited,
> it might not be a proper RFC 2822 message", which is quite different from "the
> message is complete and waiting to be submitted". So I would suggest to define
> a new flag for the latter meaning. One of the advantage of having a new flag
> is ability to have both types of messages in the same mailbox. If a client
> submitting multiple messages crashes (which does happen), upon restart it can
> pick up from the message it failed to submit and continue submitting other
> messages in the mailbox.
> 

_______________
Anil SRIVASTAVA
[email-masked]

---

From: Dave Cridland <[email-masked]>
Date: Tue, 06 Jun 2006 19:37:32 +0100

On Mon Jun  5 22:34:33 2006, Alexey Melnikov wrote:
> Hi folks,
> After reviewing some of the recent editorial changed done to 
> Profile bis, it occurred to me that the draft is now recommending 
> to use the \Draft system flag to mark messages that are about to be 
> submitted. I think this is wrong, the \Draft flag has a special 
> meaning of "the marked message is being edited, it might not be a 
> proper RFC 2822 message", which is quite different from "the 
> message is complete and waiting to be submitted". So I would 
> suggest to define a new flag for the latter meaning.

Incidentally, that was my edit, based on a mis-reading of a thread 
here, so I'm quite happy to define a new flag instead.

Another related proposal:

Alexey has had a long-standing draft defining a formal registry for 
what I'll call $keywords, and it's this that originally defined 
$Forwarded, for instance. It's draft-melnokov-imap-keywords - and 
currently expired.

I would personally feel happier if $Forwarded were restored to this 
draft, and I would feel much happier if $NewKeywordMeaningReadyToSend 
  were defined in such a document.

So I'd like to table a motion that:

a) Alexey is encouraged into bringing his draft back into production,
b) we reference it from Profile Bis,
c) it defines a new flag indicating "ready for submission",
d) optionally, it defines $Forwarded as well, updating Profile.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Tony Hansen <[email-masked]>
Date: Tue, 06 Jun 2006 14:51:03 -0400

+1

---

From: <[email-masked]>
Date: Wed, 7 Jun 2006 13:16:08 +0300

Yes, I agree with this.
Once a draft message is complete (e.g. saved as a draft), it won't be necessarily sent. I for instance use it to store notes/comments (which I never send) related to emails that I have received.
Do You have a proposal for a good name for this flag?
Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

-----Original Message-----
From: ext Alexey Melnikov [mailto:[email-masked]] 
Sent: 06 June, 2006 00:35
To: Lemonade WG
Subject: [lemonade] Use of \Draft flag to indicate message ready forsubmission

Hi folks,
After reviewing some of the recent editorial changed done to Profile bis, it occurred to me that the draft is now recommending to use the \Draft system flag to mark messages that are about to be submitted. I think this is wrong, the \Draft flag has a special meaning of "the marked message is being edited, it might not be a proper RFC 2822 message", which is quite different from "the message is complete and waiting to be submitted". So I would suggest to define a new flag for the latter meaning. One of the advantage of having a new flag is ability to have both types of messages in the same mailbox. If a client submitting multiple messages crashes (which does happen), upon restart it can pick up from the message it failed to submit and continue submitting other messages in the mailbox.

Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 07 Jun 2006 12:10:05 +0100

>Once a draft message is complete (e.g. saved as a draft), it won't be necessarily sent. I for instance use it to store notes/comments (which I never send) related to emails that I have received.
Yes, I do the same.

>Do You have a proposal for a good name for this flag?
That is the difficult part :-)!
Suggestions?

Alexey

---

From: <[email-masked]>
Date: Wed, 7 Jun 2006 15:10:16 +0300

\Unsent? 

-----Original Message-----
From: ext Alexey Melnikov [mailto:[email-masked]] 
Sent: 07 June, 2006 14:10
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere)
Cc: [email-masked]
Subject: Re: [lemonade] Use of \Draft flag to indicate message ready forsubmission

Yes, I do the same.

Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 07 Jun 2006 13:24:30 +0100

>\Unsent? 
Can't use the leading "\", as it means that the flag is a system flag. 
For most servers addition of a system flag requires some code modifications.

$Unsent?

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 07 Jun 2006 08:57:31 -0400

Hi Alexey,

> For most servers addition of a system flag requires some code

Actually, profilebis is using the \Draft flag (or rather the absence of the 
draft flag) as an indicator that the message was sent, as opposed to an 
indicator that the message is waiting to be sent. So I think what we 
actually want is a $Sent flag that the client can set once its fully 
completed the submission of the message.

The alternative of $Unsent would mean that the client has to set that when 
doing the initial APPEND/CATENATE and then remove it on submission.

Maybe we need both a $ToSend and a $Sent flag to cover all possible states?

-- 
Cyrus Daboo

---

From: Dave Cridland <[email-masked]>
Date: Wed, 07 Jun 2006 14:43:58 +0100

On Wed Jun  7 12:10:05 2006, Alexey Melnikov wrote:
>> Once a draft message is complete (e.g. saved as a draft), it won't 
>> be necessarily sent. I for instance use it to store notes/comments 
>> (which I never send) related to emails that I have received.
>>  
> Yes, I do the same.
> 
> 
I should mention that one of my users specifically wanted a $Note for 
that purpose, but that's distinct from a message where editing is 
complete, and the message is awaiting being sent.

$Note - "The message has not been submitted, and is explicitly not 
intended to be sent.".

> That is the difficult part :-)!

$Pending - "The message is intended to be sent, but has not yet been 
submitted. Clients MUST NOT automatically send the message without 
user interaction."

That latter proscription to both allow uses other than purely staging 
a message for immediate send, and prevent it from turning into an 
ill-advised IMAP-based submission mechanism. I'd assume that a client 
starting up might note the presence of $Pending messages and offer to 
send them, however.

Dave.

---

From: Dave Cridland <[email-masked]>
Date: Wed, 07 Jun 2006 14:45:45 +0100

On Wed Jun  7 13:57:31 2006, Cyrus Daboo wrote:
> Actually, profilebis is using the \Draft flag (or rather the 
> absence of the draft flag) as an indicator that the message was 
> sent, as opposed to an indicator that the message is waiting to be 
> sent. So I think what we actually want is a $Sent flag that the 
> client can set once its fully completed the submission of the 
> message.
> 
> 
I'd have to say that a $Sent flag is unsuitable, because:

a) that then would imply that any messages which did not have that 
flag were awaiting send, which is not the case now, and

b) local copies of sent messages can arrive from outside IMAP, such 
as a BCC to oneself, or use of POSTADDRESS.

> The alternative of $Unsent would mean that the client has to set 
> that when doing the initial APPEND/CATENATE and then remove it on 
> submission.
> 
> 
It's possible that this is a dead-end - no flag, present or absent - 
may be the best option in most cases.

Dave.

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 07 Jun 2006 09:51:50 -0400

Hi Dave,

--On June 7, 2006 2:45:45 PM +0100 Dave Cridland <[email-masked]> wrote:

> a) that then would imply that any messages which did not have that flag
> were awaiting send, which is not the case now, and

I disagree, to me it means only that messages with that flag have been 
submitted via the BURL mechanism.

> b) local copies of sent messages can arrive from outside IMAP, such as a
> BCC to oneself, or use of POSTADDRESS.

 We could change the name to $Submitted to make the intent clearer.

> It's possible that this is a dead-end - no flag, present or absent - may
> be the best option in most cases.

That's reasonable too...

-- 
Cyrus Daboo

---

From: Randall Gellens <[email-masked]>
Date: Fri, 9 Jun 2006 17:45:23 -0700

At 2:43 PM +0100 6/7/06, Dave Cridland wrote:

>  $Pending - "The message is intended to be sent, but has not yet 
> been submitted. Clients MUST NOT automatically send the message 
> without user interaction."
>
>  That latter proscription to both allow uses other than purely 
> staging a message for immediate send, and prevent it from turning 
> into an ill-advised IMAP-based submission mechanism. I'd assume 
> that a client starting up might note the presence of $Pending 
> messages and offer to send them, however.

I was going to suggest $pending, so I like your proposal of it.

At 2:45 PM +0100 6/7/06, Dave Cridland wrote:

>> sent ...

So with both \Draft and $Pending, we'd have a state transition of 
something like:

New message is created on server with \Draft flag.  User has started 
composition.
User presses 'send' button.  Client removes \Draft and sets $Pending.
Client receives OK from submit server that message has been sent. 
Client removes $Pending.

>>  ...snip...
>>  ... I think what we actually want is a $Sent flag that the client 
>> can set once its fully completed the submission of the message.

A $Sent flag would then be an optional state indicator that the 
message was successfully sent.

The absence of any flag could not be used to know for sure that a 
message had been sent, but it would indicate that the message was not 
an active draft nor a pending message in use by a lemonade client.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
There's nothing wrong with me.  Maybe there's something wrong with
the universe.       --'Dr. Beverly Crusher' in ST:TNG _Remember Me_.