Subject: FW: [lemonade] LEMONADE Profile 2 issues

From: <[email-masked]>
Date: Mon, 5 Jun 2006 10:07:07 +0300

Hi all,
this is something I sent to the Chairmen, they suggested it to be sent to the mailing list.
So, here we go:
 
Page 1
-> Typo: "It provides also extensions to provide support for realizationz of"-> realizations

Section 12.2.2
"   I2 designates proprietary adapters to the backends.  They may invoved
   functions performed in the message stores or submit server as well as
   in the MEM enabler server."
-> invoved? Involved, right?
-> What is a proprietary adapter? This is supposed to provide an IMAP <-> POP3 mapping, right? So the message here is that proprietary emails will never work because LEMONADE supports IMAP/SUBMIT only, so whatever You do, You will need a LEMONADE anabled IMAP/SUBMIT anyway, right? If so, should this whole section be removed then? (LEMONADE does not provide any support/specification for it, so it's not in the scope).

Section 13
-> Title contains "LEMONADE" - is is supposed to be there or it is simply incomplete?
-> under DF: reference [25] is for the sieve charter and not the specification. It needs to be described how sieve filters can be used. Also, it says "can be" - is that a MAY? If so, what other alternatives are there? I mean the client and the LEMONADE-compliant server both need to know otherwise we have IOP issues, right?

-> under VF: reference sentence seems to be messed up (reference [26] is used twice in the same sentence) and the sentence itself does not look good either.

-> under VF: referenced document [37] is listed as "Replaced, Dead or Unknown" on the web site, while the document designated as replacement does not exist (in the LEMONADE repository at least).

Section 14.
->Third last bullet lists reference [49]. This reference is listed as "Replaced, Dead or Unknown" and it cannot be accessed  on the LEMONADE repository.

->Second last bullet lists reference [46] for best practices, while [45] is listed here as well. Now, [46] discourages piggybacking, while [45] encourages it - which is contradicting. Contradictions are no good in standards, can we get rid of either one of them?

-> The bullets are full of "as discussed in" statement. Would it be possible to have requirements on those instead? Like "MUST/SHOULD/MAY follow this or MUST/SHOULD/MAY follow that"?

And finally:
There are an awfully long list of references listed - however not all of these are used. Reference [48] is a very good example. Stephane for example takes every opportunity to promote proprietary technology P-IMAP  - if You check, it's almost in every draft, but never actually used. I am not saying P-IMAP is bad, I am saying that this kind of behaviour confuses OMA MEM, analists (even my own managers) because they do not know what LEMONADE is and what the relation of profile/bis to P-IMAP is (which was believed to be dropped quite a while ago). To avoid confusion, all of the unused references should be either removed or described why and how they are used.

I hope these worries can be addressed as soon as possible.
Thank You.

Best regards: Zoltán Ördögh
E-mail: [email-masked]
Phone: +358 50 386 0566

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Dave Cridland <[email-masked]>
Date: Fri, 23 Jun 2006 00:31:31 +0100

> realizationz of"-> realizations
Alexey corrected this. (I think).

> -> invoved? Involved, right?

Corrected.

> -> What is a proprietary adapter? This is supposed to provide an 
> IMAP <-> POP3 mapping, right? So the message here is that 
> proprietary emails will never work because LEMONADE supports 
> IMAP/SUBMIT only, so whatever You do, You will need a LEMONADE 
> anabled IMAP/SUBMIT anyway, right? If so, should this whole section 
> be removed then? (LEMONADE does not provide any 
> support/specification for it, so it's not in the scope).
> 
> 
I'd appreciate some discussion on this.

> And finally:
> There are an awfully long list of references listed - however not 
> all of these are used. Reference [48] is a very good example. 
> Stephane for example takes every opportunity to promote proprietary 
> technology P-IMAP  - if You check, it's almost in every draft, but 
> never actually used. I am not saying P-IMAP is bad, I am saying 
> that this kind of behaviour confuses OMA MEM, analists (even my own 
> managers) because they do not know what LEMONADE is and what the 
> relation of profile/bis to P-IMAP is (which was believed to be 
> dropped quite a while ago). To avoid confusion, all of the unused 
> references should be either removed or described why and how they 
> are used.
> 
> 
Both Alexey and myself have gone through the references carefully.

A considerable number of these have built up over time, and until I'd 
done some stricter processing, it was difficult to see which ones 
were no longer used.

Hopefully the references are now a little more usable.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade