Subject: RE: [lemonade] I-D ACTION:draft-ietf-lemonade-vfolder-01.txt

From: <[email-masked]>
Date: Thu, 1 Jun 2006 14:59:48 +0300

>>   - "a vfolder should appear to function as a regular mailbox" 
>> Question: Can one create a VFOLDER based on a VFOLDER?

> The draft says this is supported.
 
Could You point out where? I must have missed it. Thank You.
If I create a view chain like this:
//Inbox/Mails from Joseph/Today only/New mails only/
And I delete the "Today only" view, what will happen? I understand the draft describes the case when the mailbox is deleted/moved, but not the case when a VFOLDER is deleted from a chain. Weird case I know, but I would like to know what happens in this case.
Thank You.

Best regards: Zoltán Ördögh
E-mail: zoltan.ordogh at nokia.com
Phone: +358 50 386 0566

-----Original Message-----
From: ext Randall Gellens [mailto:[email-masked]] 
Sent: 31 May, 2006 22:21
To: Ordogh Zoltan (Nokia-TP-MSW/Tampere); [email-masked]
Subject: RE: [lemonade] I-D ACTION:draft-ietf-lemonade-vfolder-01.txt

At 1:02 PM +0300 5/31/06, <[email-masked]> wrote:

>   - what is a "potentially large or high velocity mailbox"

I thought this was amusing wording.  I suppose "high velocity" 
mailbox is one that resides on a mobile device that has been hurtled at high speed towards someone or something?  (I assume the intent is one whose contents change frequently.)

>   - "a vfolder should appear to function as a regular mailbox" 
> Question: Can one create a VFOLDER based on a VFOLDER?

The draft says this is supported.

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: --------------- Nine out of 10 doctors agree that 1 out of 10 doctors is an idiot.

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Thu, 1 Jun 2006 11:01:29 -0700

>  Could You point out where? I must have missed it. Thank You.

In Section 2, the draft says:

    From the client's perspective, a vfolder should appear to function as
    a regular mailbox. This includes the ability for a new virtual folder
    to be created by using another virtual folder as a backing mailbox.

>  And I delete the "Today only" view, what will happen? I understand 
> the draft describes the case when the mailbox is deleted/moved, but 
> not the case when a VFOLDER is deleted from a chain. Weird case I 
> know, but I would like to know what happens in this case.
>  Thank You.

  I think we agreed that if the backing mailbox is deleted, the 
vfolder is also deleted.  So:

If
	- mailbox TOP is a vfolder using mailbox MIDDLE as a backing store, and
	- mailbox MIDDLE is a vfolder using mailbox BOTTOM as a backing store, and
	- mailbox BOTTOM is a normal mailbox,

then as I understand it,

	- if mailbox MIDDLE is deleted, then mailbox TOP also gets deleted
	- if mailbox BOTTOM is deleted, then both mailboxes TOP and 
MIDDLE get deleted

-------------- Randomly-selected tag: ---------------
My definition of a free society is a society where it is
safe to be unpopular.                  --Adlai Stevenson