Subject: [lemonade] BINARY*

From: Eric Burger <[email-masked]>
Date: Tue, 12 Dec 2006 16:59:27 -0500

Open question from IETF 67:

In Profile-bis, do we want:
 BINARY and BINARYMIME
 BINARY only
 BINARYMIME only
 neither

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: Dave Cridland <[email-masked]>
Date: Wed, 13 Dec 2006 09:37:20 +0000

> In Profile-bis, do we want:

I have to admit I don't see why this is an open issue.

I'd say we have to have both or neither. Having just BINARYMIME was a 
poor choice in retrospect for Profile 1.

My strong preference is for both. Base64 overhead is not fully 
recoverable by compression, and a BINARY-only client is simpler to 
write.

Since many IMAP servers have BINARY anyway, and SMTP servers will 
have to have done BINARYMIME to gain Profile 1, I think it's 
reasonable to expect both BINARY and BINARYMIME to be in Profile Bis.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 13 Dec 2006 14:26:11 +0000

> poor choice in retrospect for Profile 1.

+1.

> recoverable by compression, and a BINARY-only client is simpler to write.
>
> Since many IMAP servers have BINARY anyway, and SMTP servers will have 
> to have done BINARYMIME to gain Profile 1, I think it's reasonable to 
> expect both BINARY and BINARYMIME to be in Profile Bis.

Indeed. I would prefer that the Profile bis is a superset of the Profile 1.