Subject: RE: [lemonade] I-D ACTION:draft-ietf-lemonade-deployments-04.txt - comments

From: <[email-masked]>
Date: Mon, 11 Dec 2006 10:46:12 +0200

Hi all,
started reading my long long backlog of emails.
I process them in a timely manner, therefore some of these might be late responses by now.
Here is a small comment and a question regarding deployments-04.
C: In the first paragraph of section 4 TCP has been placed into brackets (so now it is a reference). Many other occurences of 'TCP' in the draft are not refereces. I guess either the first occurrence should be the reference and the rest is not, or: all occurences consistently should be references. I do not have a strong feeling about this since TCP is a well-known term - it more like observation in case You have plenty of time.
Q: Section 4, par. 2. A question out of curiosity: do You know of any environment currently that uses HTTP without TCP?

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>-----Original Message-----
>From: ext [email-masked] [mailto:[email-masked]] 
>Sent: 16 November, 2006 22:50
>To: [email-masked]
>Cc: [email-masked]
>Subject: [lemonade] I-D ACTION:draft-ietf-lemonade-deployments-04.txt 
>
>A New Internet-Draft is available from the on-line 
>Internet-Drafts directories.
>This draft is a work item of the Enhancements to Internet 
>email to Support Diverse Service Environments Working Group of 
>the IETF.
>
>	Title		: Deployment Considerations for 
>lemonade-compliant Mobile Email
>	Author(s)	: R. Gellens
>	Filename	: draft-ietf-lemonade-deployments-04.txt
>	Pages		: 11
>	Date		: 2006-11-16
>	
>This document discusses deployment issues and describes requirements
>    for successful deployment of mobile email which are implicit in the
>    IETF lemonade documents.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-lemonade-deploym
>ents-04.txt
>
>To remove yourself from the I-D Announcement list, send a 
>message to [email-masked] with the word 
>unsubscribe in the body of the message. 
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>to change your subscription settings.
>
>Internet-Drafts are also available by anonymous FTP. Login 
>with the username "anonymous" and a password of your e-mail 
>address. After logging in, type "cd internet-drafts" and then 
>"get draft-ietf-lemonade-deployments-04.txt".
>
>A list of Internet-Drafts directories can be found in 
>http://www.ietf.org/shadow.html or 
>ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>	[email-masked].
>In the body type:
>	"FILE /internet-drafts/draft-ietf-lemonade-deployments-04.txt".
>	
>NOTE:	The mail server at ietf.org can return the document in
>	MIME-encoded form by using the "mpack" utility.  To use this
>	feature, insert the command "ENCODING mime" before the "FILE"
>	command.  To decode the response(s), you will need "munpack" or
>	a MIME-compliant mail reader.  Different MIME-compliant 
>mail readers
>	exhibit different behavior, especially when dealing with
>	"multipart" MIME messages (i.e. documents which have been split
>	up into multiple messages), so check your local documentation on
>	how to manipulate these messages.
>
>Below is the data which will enable a MIME compliant mail 
>reader implementation to automatically retrieve the ASCII 
>version of the Internet-Draft.
>

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade

---

From: "Ben Last" <[email-masked]>
Date: Mon, 11 Dec 2006 09:46:46 -0000

>From: [email-masked] [mailto:[email-masked]] 
>Q: Section 4, par. 2. A question out of curiosity: do You know of any
environment currently that uses HTTP without TCP?
One of our software engineers pointed out that WAP access from phones is
roughly equivalent to HTTP over a non-TCP bearer, if one allows that WSP
is a form of compressed HTTP.  And there are also HTTP-over-WAP
environments.

Regards
Ben

R&D Manager
EMCC Software Ltd

---

From: Martin Konold <[email-masked]>
Date: Tue, 12 Dec 2006 07:08:23 +0100

Am Montag, 11. Dezember 2006 09:46 schrieb [email-masked]:

> par. 2. A question out of curiosity: do You know of any environment
> currently that uses HTTP without TCP?

I am aware of experimenta HTTP over SCTP. Many years ago I wrote a http server 
and client over proprietary Myrinet in user space. In theory http only 
requires a reliable transport layer and is not bound to TCP.

In casees of extreme concurrency, packet loss, high asymmetry and extremly 
high latency, TCP has issues which make other transport protocols an 
attractive research topic.

TCP is also a waste in case of a reliable physical network layer like the 
above mentioned Myrinet.

Regards,
-- martin

-- 
http://www.erfrakon.com/
Erlewein, Frank, Konold & Partner - Beratende Ingenieure und Physiker

---

From: Randall Gellens <[email-masked]>
Date: Tue, 12 Dec 2006 09:37:17 -0800

At 10:46 AM +0200 12/11/06, <[email-masked]> wrote:

>  C: In the first paragraph of section 4 TCP has been placed into 
> brackets (so now it is a reference). Many other occurences of 'TCP' 
> in the draft are not refereces. I guess either the first occurrence 
> should be the reference and the rest is not, or: all occurences 
> consistently should be references. I do not have a strong feeling 
> about this since TCP is a well-known term - it more like 
> observation in case You have plenty of time.

My feeling was that the brackets were best used in normative 
statements such as "Support for [TCP] is REQUIRED" as opposed to 
descriptive text.

>  Q: Section 4, par. 2. A question out of curiosity: do You know of 
> any environment currently that uses HTTP without TCP?

There have been many discussions in WG sessions on this topic, 
including statements that some Java environments support HTTP but not 
TCP.  Note that in cases such as this, the underlying environment 
necessaries implements TCP, but only HTTP is exposed to the 
application execution environment.  Of course, if you can't use TCP 
in your application, then you can't use most Internet protocols. 
That's the point of the document.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Virtue has never been as respectable as money.      --Mark Twain