Subject: RE: [lemonade] Profile-bis and IMAP Notifications

From: <[email-masked]>
Date: Mon, 21 Jan 2008 14:49:07 +0200

Hi Eric,
if I was not present in Vancouver, I would have said a clear yes. I am not sure now, however because I think that in Vancouver I heard some negative comments about NOTIFY in the room.
I cannot recall who it was, what the comment was, all I have is a faint memory (maybe it was Alexey pointing out that nobody implemented it because people think that it is not necessary? - sorry if it is not the case!).
But I guess if there was a problem, people would start screaming, so I say yes for now anyway...

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

>-----Original Message-----
>From: ext Eric Burger [mailto:[email-masked]] 
>Sent: 15 December, 2007 17:15
>To: [email-masked]
>Cc: Alexey Melnikov; Stéphane Maes
>Subject: [lemonade] Profile-bis and IMAP Notifications
>
>WITH CHAIR HAT OFF, just a member of the work group...
>
>Right now we say Lemonade Message Stores MUST support IDLE and 
>is silent on NOTIFY.
>
>I would offer Lemonade Message Stores MUST support NOTIFY and 
>MAY support IDLE.
>
>Mandating support for IDLE means IDLE lives forever, even if 
>no one uses it in the future.
>
>If there are other reasons for servers to support IDLE, like 
>no extant client today supports NOTIFY, then market forces 
>will ensure Lemonade Message Stores will support IDLE for the 
>time being.
>
>
>Notice:  This email message, together with any attachments, 
>may contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  affiliated entities,  that may be 
>confidential,  proprietary,  copyrighted  and/or legally 
>privileged, and is intended solely for the use of the 
>individual or entity named in this message. If you are not the 
>intended recipient, and have received this message in error, 
>please immediately return this by email and then delete it.
>
>
>_______________________________________________
>lemonade mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/lemonade
>Supplemental Web Site:
>http://www.standardstrack.com/ietf/lemonade
>

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: "Eric Burger" <[email-masked]>
Date: Mon, 21 Jan 2008 05:25:13 -0800

My recollection is yours: the primary reason is everyone does IDLE in the server today and no one does NOTIFY in the client. Since we expect lemonade to be successful, we expect implementations of NOTIFY to happen. I also expect that market forces will keep IDLE alive: if your customers have NOTIFY-ignorant clients, you will supply them with an IDLE-capable server. 

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Eric Burger; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Sent: Mon Jan 21 04:49:07 2008
Subject: RE: [lemonade] Profile-bis and IMAP Notifications

Hi Eric,

>please immediately return this by email and then delete it.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.