Subject: [lemonade] Taking the knife to METADATA

From: Cyrus Daboo <[email-masked]>
Date: Thu, 13 Mar 2008 17:54:56 -0400

Hi folks,
There have been several discussions at the IETF meeting about METADATA. Its 
clear that implementers want a "lighter" version. Here are some proposals 
based on those discussions and other comments during last call:

1) Remove the dependency on LISTEXT. This basically means turning the clock 
back to the original ANNOTATEMORE extension. So the GETMETADATA command 
would be used to retrieve mailbox annotations as well as server annotations.

2) Remove attributes. i.e. 'value' and 'size' attributes will be removed. 
There will only be a value. The .priv and .shared suffixes will then be 
applied to the entry names.

3) Entries are case insensitive.

4) Wildcards not allowed in SETMETADATA.

5) Only register /comment for both server and mailbox annotations, and 
/admin for server annotations in this document.

Please comment on these so we can move forward with this extension, thanks.

-- 
Cyrus Daboo

_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 13 Mar 2008 22:03:44 +0000

>would be used to retrieve mailbox annotations as well as server annotations.
That is fine with me.

You forgot handling on comparators in GETMETADATA.

>applied to the entry names.
I am not convinced this is needed. I am really concerned about people 
putting big annotations on the server and then clients being flooded 
with traffic.

>3) Entries are case insensitive.
I am neutral on this one. I can be convinced both ways.

>4) Wildcards not allowed in SETMETADATA.
That would be fine with me.

>/admin for server annotations in this document.
+1.

>Please comment on these so we can move forward with this extension, thanks.

Some other things that need to be addressed:

Clarify access controls for various metadata items.

---

From: Randall Gellens <[email-masked]>
Date: Fri, 14 Mar 2008 05:06:36 -0700

>  would be used to retrieve mailbox annotations as well as server annotations.

As I recall, the original concern was that using GETMETADATA for 
mailbox annotations would be confusing?  I have no problem with the 
change, but I wanted to be sure we understood why it was changed in 
the first place.

>  applied to the entry names.

Does this really make a difference?
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
We like because, we love although.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Dan Karp <[email-masked]>
Date: Fri, 14 Mar 2008 06:48:36 -0700 (PDT)

> Does this really make a difference?

If there's no real difference, then simpler is better, no?
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Fri, 14 Mar 2008 07:17:47 -0700

>  If there's no real difference, then simpler is better, no?

We were trying to maintain some level of similarity with ANNOTATE, 
and also provide the client with a way to see the size before 
fetching something.

I'm not saying these are must-have elements, but I'm not sure taking 
them out will make much difference in ease of implementation.  Are 
you saying it will?  Is this because of parsing responses, or 
something else?

-------------- Randomly-selected tag: ---------------
Auntie Em, Hate you; Hate Kansas; Taking the dog.  --Dorothy.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 14 Mar 2008 15:37:05 +0100

Randall Gellens writes:
> you saying it will?

Matching size was difficult, the rest was easy. And AFAICT 
searching/matching doesn't apply to metadata, only to annotate.

Arnt

---

From: Cyrus Daboo <[email-masked]>
Date: Fri, 14 Mar 2008 10:57:32 -0400

Hi Alexey,

--On March 13, 2008 10:03:44 PM +0000 Alexey Melnikov 
<[email-masked]> wrote:

>> 1) Remove the dependency on LISTEXT. This basically means turning the
>> clock  back to the original ANNOTATEMORE extension. So the GETMETADATA
>> command  would be used to retrieve mailbox annotations as well as server
>> annotations.
>>
>>
> That is fine with me.
>

Actually I am not proposing that GETMETADATA provide a way to search 
annotations (which is what LISTEXT does). If you want searching, then write 
an extension to this extension that does use LISTEXT.

-- 
Cyrus Daboo

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 14 Mar 2008 21:50:30 +0000

Cyrus Daboo wrote:

> annotations (which is what LISTEXT does).

But LISTEXT is not relevant to per-server annotations (i.e. 
METADATA-SERVER).

> If you want searching, then write an extension to this extension that 
> does use LISTEXT.

But it is possible to search for everything else in IMAP (headers, text 
in body parts, flags, etc.), so lack of search would be awkward.