Subject: [lemonade] MA 3: BINARY

From: "Eric Burger" <[email-masked]>
Date: Thu, 13 Mar 2008 13:36:57 -0700

Alexey will propose new ABNF to fix issues with returning
BODYPARTSTRUCTURE.  Alexey will do this soon.  If anyone has any
comment, comment now.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 16 Mar 2008 02:23:40 +0000

>BODYPARTSTRUCTURE.  Alexey will do this soon.  If anyone has any
I suggest to do the following change:

OLD:
 urldata-ext      =  SP url-full [url-metadata] SP (nstring / literal8)
    ; Note that content is always returned.
    ; If the content contains a NUL octet, the server MUST use literal8.
    ; Otherwise, the server SHOULD use nstring syntax.

 url-metadata-el  =  "BODYPARTSTRUCTURE" SP body / "BINARY"

NEW:
 urldata-ext      =  SP url-full url-metadata

 url-metadata-el  =  "BODYPARTSTRUCTURE" SP body /
                     "BINARY" SP (nstring / literal8)
    ; If the content contains a NUL octet, the server MUST use literal8
    ; with BINARY. Otherwise, the server SHOULD use nstring syntax.

========
For your convenience, the following 3 productions are unchanged:

 urlfetch-data    =  "*" SP "URLFETCH"
                     1*(SP (urldata-simple / urldata-ext))

 urldata-simple   =  SP url-full SP nstring
    ; If client issues url-fetch-simple, server MUST respond with
    ; urldata-simple

 url-metadata     =  1*(SP "(" url-metadata-el ")")