Subject: [lemonade] [Editorial Errata Reported] RFC5524 (6214)

From: RFC Errata System <[email-masked]>
Date: Wed, 24 Jun 2020 01:31:24 -0700 (PDT)

The following errata report has been submitted for RFC5524,
"Extended URLFETCH for Binary and Converted Parts".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6214

--------------------------------------
Type: Editorial
Reported by: Дилян Палаузов <[email-masked]>

Section: 6

Original Text
-------------
This document defines the URLFETCH=BINARY IMAP capability.  IANA has added it to the registry accordingly.

Corrected Text
--------------
This document defines the URLAUTH=BINARY IMAP capability.  IANA is asked to replace URLFETCH=BINARY with URLAUTH=BINARY in the IMAP registry.

Notes
-----
This document talks about URLAUTH=BINARY.  Mentioning URLFETCH=BINARY in the IANA section was not intended.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5524 (draft-cridland-urlfetch-binary-03)
--------------------------------------
Title               : Extended URLFETCH for Binary and Converted Parts
Publication Date    : May 2009
Author(s)           : D. Cridland
Category            : PROPOSED STANDARD
Source              : Enhancements to Internet email to support diverse service environments
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Eric Burger <[email-masked]>
Date: Wed, 24 Jun 2020 08:32:06 -0400

Hmmmm. It has been over a decade. What did people implement?

From the RFC:
The capability is URLAUTH=BINARY.
The command is URLFETCH (… BINARY …)

> On Jun 24, 2020, at 4:31 AM, RFC Errata System <[email-masked]> wrote:
>

---

From: Eric Burger <[email-masked]>
Date: Wed, 24 Jun 2020 08:36:54 -0400

Resending with a better address for Dave, as he’s key to the question.

> On Jun 24, 2020, at 8:32 AM, Eric Burger <[email-masked]> wrote:
> 
>> On Jun 24, 2020, at 4:31 AM, RFC Errata System <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> https://www.rfc-editor.org/errata/eid6214 <https://www.rfc-editor.org/errata/eid6214>
>>

---

From: Dave Cridland <[email-masked]>
Date: Wed, 24 Jun 2020 14:18:49 +0100

On Wed, 24 Jun 2020 at 13:37, Eric Burger <[email-masked]>
wrote:

> Hmmmm. It has been over a *decade. *What did people implement?
>
> From the RFC:
Yes, it's been a while.

And I'm not actually sure if anyone ever did implement this. I'm certainly
unsure how I'd find out now - Alexey would know about Isode M-Box, and if
that doesn't implement I'm not sure what else would. I've looked at both my
client (Polymer - been a while since I looked at that, too), and Panda
IMAP, and neither support it.

If Alexey doesn't support this, then my suspicion is that nobody does.

> This document defines the URLAUTH=BINARY IMAP capability.  IANA is asked
> to replace URLFETCH=BINARY with URLAUTH=BINARY in the IMAP registry.
>
> Notes
> -----

---

From: Eric Burger <[email-masked]>
Date: Wed, 24 Jun 2020 09:34:12 -0400

Bringing Alexey in, as I think we killed the LEMONADE list long ago…

Alexey - did you build a URLAUTH=BINARY implementation? Do you know if anyone did?

> On Jun 24, 2020, at 9:18 AM, Dave Cridland <[email-masked]> wrote:
> 
> 
> 
> On Wed, 24 Jun 2020 at 13:37, Eric Burger <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jun 24, 2020, at 8:32 AM, Eric Burger <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> And I'm not actually sure if anyone ever did implement this. I'm certainly unsure how I'd find out now - Alexey would know about Isode M-Box, and if that doesn't implement I'm not sure what else would. I've looked at both my client (Polymer - been a while since I looked at that, too), and Panda IMAP, and neither support it.
> 
>>> Reported by: Дилян Палаузов <[email-masked] <mailto:[email-masked]>>
>>> 
>>> Section: 6
>>> 
>>> Original Text
>>> -------------

---

From: Дилян Палаузов <[email-masked]>
Date: Wed, 24 Jun 2020 14:46:14 +0000

Hello,

according to https://imapwiki.org/Specs RFC 5524 is supported by Cyrus IMAP and Dovecot only.

https://github.com/dovecot/core/blob/master/src/imap/imap-client.c#L199
and https://github.com/cyrusimap/cyrus-imapd/blob/master/imap/imapd.c#L383 announce capability URLAUTH=BINARY.

This was discussed at https://mailarchive.ietf.org/arch/browse/imapext/ .

Greetings
  Дилян

On Wed, 2020-06-24 at 09:34 -0400, Eric Burger wrote:
> > On Wed, 24 Jun 2020 at 13:37, Eric Burger <[email-masked]> wrote:
> > And I'm not actually sure if anyone ever did implement this. I'm certainly unsure how I'd find out now - Alexey
> > would know about Isode M-Box, and if that doesn't implement I'm not sure what else would. I've looked at both my
> > client (Polymer - been a while since I looked at that, too), and Panda IMAP, and neither support it.
> >

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 24 Jun 2020 16:15:44 +0100

> This was discussed at https://mailarchive.ietf.org/arch/browse/imapext/ .

Isode didn't implement it.

Eric, we did discuss it on IMAPEXT mailing list and I agreed with 
Дилян's text for the erratum.

> _______________________________________________
> imapext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/imapext

---

From: Eric Burger <[email-masked]>
Date: Wed, 24 Jun 2020 12:10:05 -0400

Good enough for me!Thanks. --Sent from a small device with autocorrect. Partial blame at https://standardstrack.com/ietf/lemonade/index.html
-------- Original message --------From: Alexey Melnikov <[email-masked]> Date: 6/24/20  11:15 AM  (GMT-05:00) To: Дилян Палаузов <[email-masked]>, Eric Burger <[email-masked]>, imapext <[email-masked]> Cc: [email-masked], Cridland Dave <[email-masked]>, "Murray S. Kucherawy" <[email-masked]>, Parsons Glenn <[email-masked]>, Leiba Barry <[email-masked]>, RFC Errata System <[email-masked]> Subject: Re: [imapext] [Editorial Errata Reported] RFC5524 (6214) On 24/06/2020 15:46, Дилян Палаузов wrote:> Hello,>> according to https://imapwiki.org/Specs RFC 5524 is supported by Cyrus IMAP and Dovecot only.>> https://github.com/dovecot/core/blob/master/src/imap/imap-client.c#L199> and https://github.com/cyrusimap/cyrus-imapd/blob/master/imap/imapd.c#L383 announce capability URLAUTH=BINARY.>> This was discussed at https://mailarchive.ietf.org/arch/browse/imapext/ .Isode didn't implement it.Eric, we did discuss it on IMAPEXT mailing list and I agreed with Дилян's text for the erratum.> Greetings>    Дилян>> On Wed, 2020-06-24 at 09:34 -0400, Eric Burger wrote:>> Bringing Alexey in, as I think we killed the LEMONADE list long ago…>>>> Alexey - did you build a URLAUTH=BINARY implementation? Do you know if anyone did?>>>>> On Jun 24, 2020, at 9:18 AM, Dave Cridland <[email-masked]> wrote:>>>>>>>>>>>> On Wed, 24 Jun 2020 at 13:37, Eric Burger <[email-masked]> wrote:>>>> Resending with a better address for Dave, as he’s key to the question.>>>>>>>>> On Jun 24, 2020, at 8:32 AM, Eric Burger <[email-masked]> wrote:>>>>>>>>>> Hmmmm. It has been over a decade. What did people implement?>>>>>  From the RFC:>>>>> The capability is URLAUTH=BINARY.>>>>> The command is URLFETCH (… BINARY …)>>>>>>>> Yes, it's been a while.>>>>>> And I'm not actually sure if anyone ever did implement this. I'm certainly unsure how I'd find out now - Alexey>>> would know about Isode M-Box, and if that doesn't implement I'm not sure what else would. I've looked at both my>>> client (Polymer - been a while since I looked at that, too), and Panda IMAP, and neither support it.>>>>>> If Alexey doesn't support this, then my suspicion is that nobody does.>>>>>> On Jun 24, 2020, at 4:31 AM, RFC Errata System <[email-masked]> wrote:>>>>>>>>>>>> The following errata report has been submitted for RFC5524,>>>>>> "Extended URLFETCH for Binary and Converted Parts".>>>>>>>>>>>> -------------------------------------->>>>>> You may review the report below and at:>>>>>> https://www.rfc-editor.org/errata/eid6214>>>>>>>>>>>> -------------------------------------->>>>>> Type: Editorial>>>>>> Reported by: Дилян Палаузов <[email-masked]>>>>>>>>>>>>> Section: 6>>>>>>>>>>>> Original Text>>>>>> ------------->>>>>> This document defines the URLFETCH=BINARY IMAP capability.  IANA has added it to the registry accordingly.>>>>>>>>>>>> Corrected Text>>>>>> -------------->>>>>> This document defines the URLAUTH=BINARY IMAP capability.  IANA is asked to replace URLFETCH=BINARY with>>>>>> URLAUTH=BINARY in the IMAP registry.>>>>>>>>>>>> Notes>>>>>> ----->>>>>> This document talks about URLAUTH=BINARY.  Mentioning URLFETCH=BINARY in the IANA section was not intended.>>>>>>>>>>>> Instructions:>>>>>> ------------->>>>>> This erratum is currently posted as "Reported". If necessary, please>>>>>> use "Reply All" to discuss whether it should be verified or>>>>>> rejected. When a decision is reached, the verifying party>>>>>> can log in to change the status and edit the report, if necessary.>>>>>>>>>>>> -------------------------------------->>>>>> RFC5524 (draft-cridland-urlfetch-binary-03)>>>>>> -------------------------------------->>>>>> Title               : Extended URLFETCH for Binary and Converted Parts>>>>>> Publication Date    : May 2009>>>>>> Author(s)           : D. Cridland>>>>>> Category            : PROPOSED STANDARD>>>>>> Source              : Enhancements to Internet email to support diverse service environments>>>>>> Area                : Applications>>>>>> Stream              : IETF>>>>>> Verifying Party     : IESG>> _______________________________________________> imapext mailing list> [email-masked]> https://www.ietf.org/mailman/listinfo/imapext