Subject: Re: [Lime] LIME Charter Propsosal v1

From: wangzitao <[email-masked]>
Date: Thu, 18 Sep 2014 03:05:47 +0000

Examples of "administration" tools are network discovery and planning
    tools.

SB> Regardless of RFC6291, network discovery is normally part of routing, or of an application layer broker.

SB> Surely the normal definition of admin is configuration?
[Qin]: Yes, I agree routing protocol or application protocol provide a good functionality for network discovery.
Also I agree configuration is a good example of administration. Before configuration, management function needs to know who needs to be configured and where it is.
Doesn't this come from a network management database, or in these modern times the orchestrator.

Perhaps we need to go up a level and understand where on the spectrum of full manual configuration to autonomic networking we are targeting the discovery, and what is in and out of scope in a "traditional" network.

- Stewart
Interesting discussion on network discovery. I am wondering if routing protocol or application protocol can provide a capability to allow management entity discover a set of managed elements in the same path for a specific flow?
It would be interesting to see management entity to support such capability? It looks routing protocol doesn't support such capability. Can autonomic networking provide such capability?

-    Michael

---

From: Qin Wu <[email-masked]>
Date: Thu, 18 Sep 2014 04:52:50 +0000

发件人: Lime [mailto:[email-masked]] 代表 wangzitao
发送时间: 2014年9月18日 11:06
收件人: [email-masked]
主题: Re: [Lime] LIME Charter Propsosal v1

- Stewart
Interesting discussion on network discovery. I am wondering if routing protocol or application protocol can provide a capability to allow management entity discover a set of managed elements in the same path for a specific flow?
It would be interesting to see management entity to support such capability? It looks routing protocol doesn’t support such capability. Can autonomic networking provide such capability?

-    Michael

[Qin]: You are talking about discovery along a given path, I think network management database doesn’t support such capability since you need to correlate different managed elements together for a given path.

Are you proposing to put this capability as part of discovery component we are proposing in the charter?

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 18 Sep 2014 11:41:05 +0100

On 18/09/2014 04:05, wangzitao wrote:
>     SB> Regardless of RFC6291, network discovery is normally part of
>     routing, or of an application layer broker.
>
>
>     [Qin]: Yes, I agree routing protocol or application protocol
>     provide a good functionality for network discovery.
>
>     Also I agree configuration is a good example of administration.
>     Before configuration, management function needs to know who needs
>     to be configured and where it is.
>
> Perhaps we need to go up a level and understand where on the spectrum 
> of full manual configuration to autonomic networking we are targeting 
> the discovery, and what is in and out of scope in a "traditional" network.
>
> - Stewart
>
> Interesting discussion on network discovery. I am wondering if routing 
> protocol or application protocol can provide a capability to allow 
> management entity discover a set of managed elements in the same path 
> for a specific flow?
>
Yes and no.

BGP-LS (for example) is taking on the task of providing connectivity and 
path information to the orchestrator, I am assuming that is part of the 
management plane, although that is something that bares thought in 
understanding the bounds of network management vs path imposition. Then 
there is the degree to which the path is explicit (SR and RSVP) vs 
implicitly known (classic routing single path, where algorithms + shared 
data give the same answer) vs fully delegated (local choice of an ECMP 
path or IPFRR).

> It would be interesting to see management entity to support such 
> capability? It looks routing protocol doesn't support such capability. 
> Can autonomic networking provide such capability?
>
I don't quite understand this question.

- Stewart
>
>
> -     Michael
>
>
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Tom Taylor <[email-masked]>
Date: Thu, 18 Sep 2014 07:08:57 -0400

Below, marked [PTT].

Tom Taylor

> On 18/09/2014 04:05, wangzitao wrote:
...
> data give the same answer) vs fully delegated (local choice of an ECMP
[PTT] I thought routing and path discovery was a function of the control 
plane rather than the management plane. Changing the location and path 
taken for the information doesn't really change its nature. On the other 
hand, backing away from this perhaps academic distinction, the 
topological information being collected is definitely the foundation for 
the more abstracted view centralized management needs to present.

[PTT] Of course, we need equivalent functionality for the data link 
layer(s). I know that BGP extends to some of them, but certainly not 
all. And we also need to map the physical layer at the bottom. The nodes 
we have to identify in all these cases are the managed entities.

[PTT] Like you said, a big database, and maybe parts are not 
discoverable but have to be entered manually.

[PTT] In any event, the chartert currently puts discovery out of scope.

...

---

From: Qin Wu <[email-masked]>
Date: Thu, 18 Sep 2014 12:02:30 +0000

发件人: Lime [mailto:[email-masked]] 代表 Stewart Bryant
发送时间: 2014年9月18日 18:41
收件人: wangzitao; [email-masked]
主题: Re: [Lime] LIME Charter Propsosal v1

- Stewart

BGP-LS (for example) is taking on the task of providing connectivity and path information to the orchestrator, I am assuming that is part of the management plane, although that is something that bares thought in understanding the bounds of network management vs path imposition. Then there is the degree to which the path is explicit (SR and RSVP) vs implicitly known (classic routing single path, where algorithms + shared data give the same answer) vs fully delegated (local choice of an ECMP path or IPFRR).

[Qin]: I think BGP-LS focus on L3 Topology discovery.
Can BGP-LS is used to discovery L2 to L3 connectivity if L2 managed entity is connecting to L3 management entity.  I think management plane based solution can handle various type of network devices at different layer, including L2/L3/L4/L7 switch, router, host and discover connectivity between these devices. SNMP based solution can be one example to do multi-layer network topology discovery.

[Qin]: My interpretation to what he said is management entity can not use routing protocol(e.g.,BGP-LS) to discover connectivity between L2 managed element and L3 managed element.

- Stewart

-    Michael

Lime mailing list

[email-masked]<mailto:[email-masked]>

--

---

From: wangzitao <[email-masked]>
Date: Thu, 18 Sep 2014 12:18:02 +0000

My point is discovering a set of forwarding element in the path is not same as discovering a set of managed elements in the path.
Because not all the forwarding element needs to be managed. We may configure some of forwarding elements as managed elements.
So who will be managed elements and where they are, you still don’t know based on network topology gathered using BGP-LS
unless BGP-LS is extended to indicate that.

Regards!
-Michael
发件人: Stewart Bryant [mailto:[email-masked]]
发送时间: 2014年9月18日 18:41
收件人: wangzitao; [email-masked]
主题: Re: [Lime] LIME Charter Propsosal v1

- Stewart

- Stewart

-    Michael

Lime mailing list

--