Subject: [Lime] LIME Charter Proposal update discussion in Design Team

From: Qin Wu <[email-masked]>
Date: Tue, 23 Sep 2014 02:53:42 +0000

Hi, all:
Centering around the Consolidated Charter proposal we posted below:
https://github.com/danielkinguk/lime/tree/master/charter-proposal 

We Charter Design team have a very good offline discussion yesterday on it. 
Summarizing what we discussed so far, three main issues are sufficiently discussed:
1. Shall we document use case for converged management of OAM in multi-layer and multi-technology  
Networks? Shall we publish it?
The rough agreement is we should document use cases and LIME will decide later whether to publish use case document.
2. Do we need to deliver both IM and DM and shall we go directly define DM?
We reach agreement that we should develop both. The step is to develop IM first and DM should be based on this IM.
3. Do we allow other Data modeling Language(DML) besides YANG to be considered?
It looks most of people think Yes. But IETF should focus on using YANG as DML.

We will update our charter proposal based on the discussion and post it to the list soon.

Regards!
-Qin

---

From: Benoit Claise <[email-masked]>
Date: Tue, 23 Sep 2014 23:12:31 +0200

Dear all,

[I removed the people in cc, otherwise the mailer complaints "Too many 
recipients to the message". Hopefully, everybody is subscribed]

Thanks to all of you who worked on the charter. It is a good starting point.
See in line for some answers/questions.

> The rough agreement is we should document use cases and LIME will decide later whether to publish use case document.
That makes sense to me.
> We reach agreement that we should develop both. The step is to develop IM first and DM should be based on this IM.
For the sake of completeness, let me cut/paste here my feedback from 
http://www.ietf.org/mail-archive/web/lime/current/msg00047.html

    In my charter reviews since I became OPS AD, I've been stressing the
    need to have an information model before specifying the data
    model(s), especially for WGs that still need to determine their
    management requirements:
         fault, configuration, accounting, performance?
         push/pull?
         OAM or not?
         ...
    Now, the LIME work is special: it's specific to configuration, and
    for configuration there is a primary language: YANG.
    The growing interest in YANG throughout the industry proves YANG is
    the right way to go.
    So I'm wondering if, in _this __SPECIFIC _(potential) WG, it's
    necessary to go with an information model first? I would say no, but
    could be convinced otherwise.

> It looks most of people think Yes. But IETF should focus on using YANG as DML.
See point 2.
What about DML do you have in mind? SMI? Well, it could potentially make 
sense to augment a MIB module that configures and monitors OAM. However, 
I don't know of any at the IETF. So I don't see the point to go in that 
direction.

Some more feedback:
- "It will also produce architectural guidelines for the
development of new OAM tools and protocols so that they may be
coherent with these mechanisms and more easily integrated across
layers."
I would say "... more easily integrated from an operational points of view".
This work is about "OAM Management" after all.

- "YANG data models, based on above mentioned IM, for generic
layer-independent and technology-independent configuration,
reporting and presentation for OAM mechanisms. Data models
expressed in other languages than YANG may be considered."
So, you guys want to create the generic data model(s), or you also want 
to have the specific extensions for the IETF OAM mechanisms? If the 
extensions are not done here, where? In the respective WGs?
Ideally, we should have one data model, generic enough to be augmented 
for all the OAM specific configuration/operational objects.

- I believe that the following deliverable needs some clarification:

    An architecture for new IETF OAM that can be used as guidance by
    other working groups developing new OAM protocols or modifying
    existing OAM protocols at any layer and for any technology that is
    within scope for the IETF.

There are two distinct points: architecture and guidance
1. an architecture.
Which "architecture" do you want to build this generic data model on?
I heard some of you want to use the IEEE CFM? Is there agreement (I 
don't think this was discussed on the list)? There are most probably 
other architectures.
Do we want to mention in the charter: "review existing architecture"? 
However, please, let's not go into a beauty contest that will take years 
(yes, I've been there before)
2. the guidance.
Whether this guidance speak about management plane only or also about 
data plane should be mentioned.

-  "The initial scope is restricted to a single administrative domain
and may be extended for inter-domain scenarios in future as and
when a need rises"
That's a good limitation IMO.

- Speaking of SDOs, shouldn't the sentence "(including, but not limited 
to the ITU-T, IEEE, BBF and 3GPP)" include the MEF?
I'm sure MEF deals with OAM.

- At this point in time, I believe you should request a BoF at the next 
IETF. Note: deadline is Sept 26th 
(http://www.ietf.org/meeting/important-dates-2014.html#IETF91)
And if we converge quickly, we could potentially shoot for a WG creation 
before/at Honolulu, depending on the feedback received from the broader 
community.
Let's keep in mind that a BoF is not a hard requirement for a WG creation.

Regards, Benoit
> .

---

From: Qin Wu <[email-masked]>
Date: Wed, 24 Sep 2014 03:30:07 +0000

Hi,
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2014年9月24日 5:13
收件人: Qin Wu; [email-masked]
主题: Re: [Lime] LIME Charter Proposal update discussion in Design Team

Dear all,

[I removed the people in cc, otherwise the mailer complaints "Too many recipients to the message". Hopefully, everybody is subscribed]

Hi, all:

We reach agreement that we should develop both. The step is to develop IM first and DM should be based on this IM.
For the sake of completeness, let me cut/paste here my feedback from http://www.ietf.org/mail-archive/web/lime/current/msg00047.html
In my charter reviews since I became OPS AD, I've been stressing the need to have an information model before specifying the data model(s), especially for WGs that still need to determine their management requirements:
    fault, configuration, accounting, performance?
    push/pull?
    OAM or not?
    ...
Now, the LIME work is special: it's specific to configuration, and for configuration there is a primary language: YANG.
The growing interest in YANG throughout the industry proves YANG is the right way to go.
So I'm wondering if, in this SPECIFIC (potential) WG, it's necessary to go with an information model first? I would say no, but could be convinced otherwise.

[Qin]: Our initial proposal is to develop YANG data model directly, but when we get to Charter Design team discussion, it seems a lot of people favor defining IM first, given the following
our proposed text in the charter:
“harmonising with generic models in other SDOs” .
Some of Design team concerned that without IM first, how to harmonize with other SDOs for generic models? How to claim it is technology independent?
I think generic models in other SDOs are referred to ITU-T defined protocol independent information model, however they are technology specific in the forwarding plane, e.g., IM can be applied to MPLS-TP, OTN, Etherent technology, they are protocol neutral with respect to management protocols(e.g., SNMP, NETCONF, etc.).
Other example is MEF related work, but IM,DM they defined are also Ethernet specific.
Here technology independent is not management protocol independent but forwarding technology independent, I think.
I agree that LIME is specific to configuration  and we are chartered to do IETF work and we should focus on YANG data model.

It looks most of people think Yes. But IETF should focus on using YANG as DML.
See point 2.
What about DML do you have in mind? SMI? Well, it could potentially make sense to augment a MIB module that configures and monitors OAM. However, I don't know of any at the IETF. So I don't see the point to go in that direction.

[Qin]: There are additional comments from Carlos and Ron in the Design team discussion, they both support using YANG as only data modeling language of the LIME.
Talking with Dan, we also agree SNMP/MIB and NETCONF/YANG are competing for configuration operation.
MAYbe we need to tweak the charter text proposal a little bit.

Some more feedback:

[Qin]Agree.

- "YANG data models, based on above mentioned IM, for generic
layer-independent and technology-independent configuration,
reporting and presentation for OAM mechanisms. Data models
expressed in other languages than YANG may be considered."
So, you guys want to create the generic data model(s), or you also want to have the specific extensions for the IETF OAM mechanisms? If the extensions are not done here, where? In the respective WGs?
[Qin]: Yes, extension should be done in the respective WGs who play specific technology.

Ideally, we should have one data model, generic enough to be augmented for all the OAM specific configuration/operational objects.

[Qin]:I think it is the former, I think LIME should focus on technology independent or Generic YANG data model

I heard some of you want to use the IEEE CFM? Is there agreement (I don't think this was discussed on the list)? There are most probably other architectures.

[Qin]:Yes, IEEE CFM mode or Y.1731 related model is a good example.

Do we want to mention in the charter: "review existing architecture"? However, please, let's not go into a beauty contest that will take years (yes, I've been there before)

[Qin]: Good suggestion, I think.

2. the guidance.
Whether this guidance speak about management plane only or also about data plane should be mentioned.

[Qin]: We can cover both as you suggested.

- Speaking of SDOs, shouldn't the sentence "(including, but not limited to the ITU-T, IEEE, BBF and 3GPP)" include the MEF?
I'm sure MEF deals with OAM.

[Qin]: Miss that, will fix it. Thanks.

- At this point in time, I believe you should request a BoF at the next IETF. Note: deadline is Sept 26th (http://www.ietf.org/meeting/important-dates-2014.html#IETF91)

[Qin]: Done, Carlos and I have produced the initial version of BOF proposal and uploaded it to the wiki page.

And if we converge quickly, we could potentially shoot for a WG creation before/at Honolulu, depending on the feedback received from the broader community.
Let's keep in mind that a BoF is not a hard requirement for a WG creation.

[Qin]: Great, that’s our expectation. We will prepare for that.

Regards, Benoit

Regards!

-Qin

.

---

From: <[email-masked]>
Date: Wed, 24 Sep 2014 11:36:57 +0000

Hi Benoit,

I'm one of those who voiced during the DT discussion for calling out explicitly IMs in the charter.

I see a value in documenting IMs first as doing so, not only has the merit to hide protocol specificities, but it would ease inter-SDOs discussion (which I would expect and encourage for this topic).

Of course, there is an IETF recommended DM but other SDOs may have their "favorite" DM too.

Cheers,
Med

De : Lime [mailto:[email-masked]] De la part de Benoit Claise
Envoyé : mardi 23 septembre 2014 23:13
À : Qin Wu; [email-masked]
Objet : Re: [Lime] LIME Charter Proposal update discussion in Design Team

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Sep 2014 02:10:23 +0000

Hi, All:
Thanks Med to bring up this point.
Here is the background to the comment raised by Med below.
Based on AD’s recent comments and questions on the second version of Charter proposal posted at:
(https://github.com/danielkinguk/lime/tree/master/charter-proposal),
we get back to design team discussion.
Three Questions discussed in the Design team:

Q 1. Should we do DM without information model?

Q 2. Shall we allow other DMLs than YANG?

Q 3. Can guidance be applied to both management plane and data plane?
Most of Design team members now became to reach agreement and have answers Yes to Q1 and Q3 and NO to Q2.
Now we like to re-raise the above 3 Questions to the list. Hopefully we can get converged discussion and move forward.

Regards!
-Qin
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2014年9月24日 19:37
收件人: Benoit Claise; Qin Wu; [email-masked]
主题: RE: [Lime] LIME Charter Proposal update discussion in Design Team

Hi Benoit,

I’m one of those who voiced during the DT discussion for calling out explicitly IMs in the charter.

Of course, there is an IETF recommended DM but other SDOs may have their “favorite” DM too.

Cheers,
Med

De : Lime [mailto:[email-masked]] De la part de Benoit Claise
Envoyé : mardi 23 septembre 2014 23:13
À : Qin Wu; [email-masked]<mailto:[email-masked]>
Objet : Re: [Lime] LIME Charter Proposal update discussion in Design Team

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Sep 2014 02:41:32 +0000

Hi, Med:
I like to summarize several reasons discussed by other Design team members
For why we are not willing to start from IM:

1.       We lack control on the other DMLs than YANG

2.       There is tradeoff between cost of maintaining multiple DMLs and allow other DML than YANG.

3.       Direct data modelling into MIB modules have already been done.

4.       YANG as DML owned by IETF has gained most popularity in the industry.
So I feel that if we start from IM, we can imagine that harmonizing with other SDOs for IM will take quite a long time.

Regards!
-Qin

Hi Benoit,

Cheers,
Med

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

---

From: <[email-masked]>
Date: Thu, 25 Sep 2014 06:15:00 +0000

Hi Win,

Please see inline.

Cheers,
Med

De : Qin Wu [mailto:[email-masked]]
Envoyé : jeudi 25 septembre 2014 04:42
À : BOUCADAIR Mohamed IMT/OLN; Benoit Claise; [email-masked]
Objet : RE: [Lime] LIME Charter Proposal update discussion in Design Team

Hi, Med:

1.       We lack control on the other DMLs than YANG
[Med] Yes. That’s why an IM is much more suitable than DMs.

2.       There is tradeoff between cost of maintaining multiple DMLs and allow other DML than YANG.
[Med] I didn’t asked for having multiple DMs! I just warranted the IETF cannot dictate a DM to other SDOs and suggested to use IM as an entry point.

3.       Direct data modelling into MIB modules have already been done.
[Med] Sure! But this is because people had a similar reasoning as for YANG today ;-) I do really think there is a value in de-correlating the abstract modelling from the protocol-centric approaches.

4.       YANG as DML owned by IETF has gained most popularity in the industry.
So I feel that if we start from IM, we can imagine that harmonizing with other SDOs for IM will take quite a long time.
[Med] I frankly don’t know how it will last. Note, the arguments you raised above can be over-exaggerated and as such be interpreted as the IETF should not do any work on IMs anymore.

Regards!
-Qin
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2014年9月24日 19:37
收件人: Benoit Claise; Qin Wu; [email-masked]<mailto:[email-masked]>
主题: RE: [Lime] LIME Charter Proposal update discussion in Design Team

Hi Benoit,

Cheers,
Med

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Sep 2014 08:47:20 +0000

[Qin]: What I am saying is ITU-T and MEF have already done some IMs (e.g., MEF 7.1, ITU-T G.8052). IM defined in ITU-T G.8051 is protocol neutral and use IEEE CFM model and Y.1731 as basis.
See figure 2 of MEF-38 for Relationship between MEF and ITU-T specifications, the YANG modules developed by MEF
http://www.metroethernetforum.org/Assets/Technical_Specifications/PDF/MEF_38.pdf

Do we need to redo IMs again and look for harmonization with ITU-T and MEF for these IMs
Or should we simply reference these IMs and do a DM directly in IETF?

Regards!
-Qin

Hi Benoit,

Cheers,
Med

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

---

From: Yuji Tochio <[email-masked]>
Date: Thu, 25 Sep 2014 18:26:56 +0900

Hi Qin,

Regarding to three questions on another thread as:
Q 1. Should we do DM without information model?
Q 2. Shall we allow other DMLs than YANG?
Q 3. Can guidance be applied to both management plane and data plane?

I am wondering how to answer to #1, but if LIME says Yes as below,
> Or should we simply reference these IMs and do a DM directly in IETF?
then I can reply to Yes to #1.

As to #2, we focus on YANG in IETF first at this moment. To #3, Yes.

Regards, Yuji

(2014/09/25 17:47), Qin Wu wrote:
> */[Med] I frankly don’t know how it will last. Note, the arguments you raised above can be over-exaggerated and as such be interpreted as the IETF should not
> do any work on IMs anymore. /*
>
> *? 件人:[email-masked] <mailto:[email-masked]> [mailto:[email-masked]]
> *? 送??:*2014年9月24日19:37
> *收件人:*Benoit Claise; Qin Wu; [email-masked] <mailto:[email-masked]>
> *主?:*RE: [Lime] LIME Charter Proposal update discussion in Design Team
>
> Hi Benoit,
>
> I see a value in documenting IMs first as doing so, not only has the merit to hide protocol specificities, but it would ease inter-SDOs discussion (which I
> would expect and encourage for this topic).
>
> *De :*Lime [mailto:[email-masked]] *De la part de* Benoit Claise
> *Envoye' :* mardi 23 septembre 2014 23:13
> *A` :* Qin Wu; [email-masked] <mailto:[email-masked]>
> *Objet :* Re: [Lime] LIME Charter Proposal update discussion in Design Team
>
> Dear all,
>
> In my charter reviews since I became OPS AD, I've been stressing the need to have an information model before specifying the data model(s), especially for WGs
> that still need to determine their management requirements:
> So I'm wondering if, in _this SPECIFIC _(potential) WG, it's necessary to go with an information model first? I would say no, but could be convinced otherwise.
>
>      
>
> What about DML do you have in mind? SMI? Well, it could potentially make sense to augment a MIB module that configures and monitors OAM. However, I don't know
> of any at the IETF. So I don't see the point to go in that direction.
>
>
> Some more feedback:
> - At this point in time, I believe you should request a BoF at the next IETF. Note: deadline is Sept 26th
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

---

From: Benoit Claise <[email-masked]>
Date: Thu, 25 Sep 2014 11:59:45 +0200

Dear all,

Trying to bring closure on this IM topic.

Taking the feedback from the charter design team , and the answers to 
the following questions:

    Q 1. Can we do DM without information model?
    Q 2. Shall we allow other DMLs than YANG?
    Q 3. Can guidance be applied to both management plane and data plane?

Note that the right question Q1 is: Should we do DM without information 
model?
All 9 replies went in the same direction:

    Q 1. Yes
    Q 2. No
    Q 3. Yes

Btw, many thanks to the charter design team for their work and initial 
proposal. I consider that their work is now done, that any communication 
should now happen on this mailing list.

As I mentioned before, I don't think IM is required in this specific WG. 
I explained the reasons in the previous email.
My point is that if the WG finds it necessary to work on the Information 
Model before the Data Model, it's free to do so.

What does it imply in terms of charter text?
- The Information Model deliverable has been removed
- "Data models expressed in other languages than YANG may be 
considered." has been removed
- The following sentence has been added:  "If the working group finds it 
necessary to work on an information model before the data model, it 
might do so."

Regards, Benoit

>> So I feel that if we start from IM, we can imagine that harmonizing 
>> with other SDOs for IM will take quite a long time.
>>
>> */[Med] I frankly don't know how it will last. Note, the arguments 
>> you raised above can be over-exaggerated and as such be interpreted 
>> as the IETF should not do any work on IMs anymore. /*
>>
>> [Qin]: What I am saying is ITU-T and MEF have already done some IMs 
>> (e.g., MEF 7.1, ITU-T G.8052). IM defined in ITU-T G.8051 is protocol 
>> neutral and use IEEE CFM model and Y.1731 as basis.
>>
>> See figure 2 of MEF-38 for Relationship between MEF and ITU-T 
>> specifications, the YANG modules developed by MEF
>>
>> *? ??:[email-masked] 
>> <mailto:[email-masked]> 
>> [mailto:[email-masked]]
>> *? ???:*2014?9?24?19:37
>> *???:*Benoit Claise; Qin Wu; [email-masked] <mailto:[email-masked]>
>> *??:*RE: [Lime] LIME Charter Proposal update discussion in Design Team
>>
>> Hi Benoit,
>>
>> I see a value in documenting IMs first as doing so, not only has the 
>> merit to hide protocol specificities, but it would ease inter-SDOs 
>> discussion (which I would expect and encourage for this topic).
>>
>> *Envoyé :* mardi 23 septembre 2014 23:13
>> *À :* Qin Wu; [email-masked] <mailto:[email-masked]>
>> [I removed the people in cc, otherwise the mailer complaints "Too 
>> many recipients to the message". Hopefully, everybody is subscribed]
>>
>> So I'm wondering if, in _this SPECIFIC _(potential) WG, it's 
>> What about DML do you have in mind? SMI? Well, it could potentially 
>> make sense to augment a MIB module that configures and monitors OAM. 
>> However, I don't know of any at the IETF. So I don't see the point to 
>> go in that direction.
>>
>>
>> Some more feedback:
>> So, you guys want to create the generic data model(s), or you also 
>> want to have the specific extensions for the IETF OAM mechanisms? If 
>> the extensions are not done here, where? In the respective WGs?
>> Ideally, we should have one data model, generic enough to be 
>> augmented for all the OAM specific configuration/operational objects.
>>
>> However, please, let's not go into a beauty contest that will take 
>> years (yes, I've been there before)
>> 2. the guidance.
>> - Speaking of SDOs, shouldn't the sentence "(including, but not 
>> limited to the ITU-T, IEEE, BBF and 3GPP)" include the MEF?
>> And if we converge quickly, we could potentially shoot for a WG 
>> creation before/at Honolulu, depending on the feedback received from 
>> the broader community.

---

From: Tom Taylor <[email-masked]>
Date: Thu, 25 Sep 2014 06:30:24 -0400

I think I like Yuji's response to 1). Med, will this lead us into 
conflict if we pick CFM in particular?

Tom T

...

---

From: <[email-masked]>
Date: Thu, 25 Sep 2014 11:25:30 +0000

Hi Benoît,

Since it seems I’m the only that (still) asks for IMs to be explicitly included in the charter, the proposed changes you listed below are fair.

Thank you.

Cheers,
Med

De : Lime [mailto:[email-masked]] De la part de Benoit Claise
Envoyé : jeudi 25 septembre 2014 12:00
À : Yuji Tochio; Qin Wu
Cc : [email-masked]
Objet : Re: [Lime] LIME Charter Proposal update discussion in Design Team

Dear all,

Taking the feedback from the charter design team , and the answers to the following questions:
Q 1. Can we do DM without information model?
Q 2. Shall we allow other DMLs than YANG?
Q 3. Can guidance be applied to both management plane and data plane?
Note that the right question Q1 is: Should we do DM without information model?
All 9 replies went in the same direction:
Q 1. Yes
Q 2. No
Q 3. Yes
Btw, many thanks to the charter design team for their work and initial proposal. I consider that their work is now done, that any communication should now happen on this mailing list.

As I mentioned before, I don't think IM is required in this specific WG. I explained the reasons in the previous email.
My point is that if the WG finds it necessary to work on the Information Model before the Data Model, it's free to do so.

What does it imply in terms of charter text?
- The Information Model deliverable has been removed
- "Data models expressed in other languages than YANG may be considered." has been removed
- The following sentence has been added:  "If the working group finds it necessary to work on an information model before the data model, it might do so."

Regards, Benoit
Hi Qin,

Regards, Yuji

Regards!
-Qin
发 件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发 送时间: 2014年9月24日 19:37
收件人: Benoit Claise; Qin Wu; [email-masked]<mailto:[email-masked]>
主题: RE: [Lime] LIME Charter Proposal update discussion in Design Team

Hi Benoit,

Cheers,
Med

Dear all,

Hi, all:

Some more feedback:

Regards, Benoit

Regards!

-Qin

.

Lime mailing list

[email-masked]<mailto:[email-masked]>

Lime mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 25 Sep 2014 12:32:35 +0100

Thanks for guiding this, Benoit.

> Trying to bring closure on this IM topic.
[snip]
> - The following sentence has been added:  "If the working group
>   finds it necessary to work on an information model before the
>   data model, it might do so."

I like that outcome.
The IETF does not need another data model language for this type of config and
reporting, and I think SMI is now phasing out.
I like that you have left info models open if the WG finds a need, and (of
course) the WG can look at existing info models at any time. This is thoroughly
covered by the final sentence of the charter text.
   Therefore, it is anticipated that the working group will closely coordinate
   its activities with other SDOs (including, but not limited to the ITU-T, MEF,
   IEEE, BBF and 3GPP) to ensure that the generic models are harmonized
   with work done in those SDOs and are applicable to many technologies.

Good job.
Adrian

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Sep 2014 17:49:43 -0400

Med:

Benoit had convinced me IM models so we could agree on DM language was
useful.  However, if you are at already defined configuration – is it
necessary?  I do agree it has been useful to IM for I2RS first round
definitions.

Sue 

From: Lime [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, September 24, 2014 7:37 AM
To: Benoit Claise; Qin Wu; [email-masked]
Subject: Re: [Lime] LIME Charter Proposal update discussion in Design Team

Hi Benoit,

I’m one of those who voiced during the DT discussion for calling out
explicitly IMs in the charter. 

I see a value in documenting IMs first as doing so, not only has the merit
to hide protocol specificities, but it would ease inter-SDOs discussion
(which I would expect and encourage for this topic). 

Of course, there is an IETF recommended DM but other SDOs may have their
“favorite” DM too.

Cheers,

Med

De : Lime [mailto:[email-masked]] De la part de Benoit Claise
Envoyé : mardi 23 septembre 2014 23:13
À : Qin Wu; lime@iet <mailto:[email-masked]> f.org
Objet : Re: [Lime] LIME Charter Proposal update discussion in Design Team

Dear all, 

Hi, all:
 
We Charter Design team have a very good offline discussion yesterday on it. 
Summarizing what we discussed so far, three main issues are sufficiently
discussed:
1. Shall we document use case for converged management of OAM in multi-layer
and multi-technology  
Networks? Shall we publish it?
The rough agreement is we should document use cases and LIME will decide
later whether to publish use case document.

That makes sense to me.

2. Do we need to deliver both IM and DM and shall we go directly define DM?
We reach agreement that we should develop both. The step is to develop IM
first and DM should be based on this IM.

In my charter reviews since I became OPS AD, I've been stressing the need to
have an information model before specifying the data model(s), especially
for WGs that still need to determine their management requirements:
    fault, configuration, accounting, performance?
    push/pull?
    OAM or not?
    ...
Now, the LIME work is special: it's specific to configuration, and for
configuration there is a primary language: YANG.
The growing interest in YANG throughout the industry proves YANG is the
right way to go.
So I'm wondering if, in this SPECIFIC (potential) WG, it's necessary to go
with an information model first? I would say no, but could be convinced
otherwise.

3. Do we allow other Data modeling Language(DML) besides YANG to be
considered?
It looks most of people think Yes. But IETF should focus on using YANG as
DML.

See point 2.
What about DML do you have in mind? SMI? Well, it could potentially make
sense to augment a MIB module that configures and monitors OAM. However, I
don't know of any at the IETF. So I don't see the point to go in that
direction.

Some more feedback:

- "YANG data models, based on above mentioned IM, for generic
layer-independent and technology-independent configuration,
reporting and presentation for OAM mechanisms. Data models
expressed in other languages than YANG may be considered."
So, you guys want to create the generic data model(s), or you also want to
have the specific extensions for the IETF OAM mechanisms? If the extensions
are not done here, where? In the respective WGs?
Ideally, we should have one data model, generic enough to be augmented for
all the OAM specific configuration/operational objects.

There are two distinct points: architecture and guidance
1. an architecture. 
Which "architecture" do you want to build this generic data model on?
I heard some of you want to use the IEEE CFM? Is there agreement (I don't
think this was discussed on the list)? There are most probably other
architectures.
Do we want to mention in the charter: "review existing architecture"?
However, please, let's not go into a beauty contest that will take years
(yes, I've been there before)
2. the guidance. 
Whether this guidance speak about management plane only or also about data
plane should be mentioned.

- Speaking of SDOs, shouldn't the sentence "(including, but not limited to
the ITU-T, IEEE, BBF and 3GPP)" include the MEF?
I'm sure MEF deals with OAM.

Regards, Benoit

We will update our charter proposal based on the discussion and post it to
the list soon.
 
Regards!
-Qin
.