Subject: [Lime] LIME charter: next step

From: Benoit Claise <[email-masked]>
Date: Fri, 26 Sep 2014 11:31:35 +0200

Dear all,

Thanks to all who contributed to this proposed charter so far.
I believe that this charter is now stable enough, and has enough 
community support.
At this point in time, we want to get feedback from the IESG.
Therefore this charter is on the IESG telechat next Thursday.

Regards, Benoit

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 26 Sep 2014 14:57:13 +0000

Dear Benoit,
thank you for dedicating your time and expertise to this effort. I believe that the problem we've formulated and direction chartered are both practical and useful. We're for a great ride! Looking forward.

And my congratulations to Qin who had started it all!

	Regards,
		Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Friday, September 26, 2014 2:32 AM
To: [email-masked]
Subject: [Lime] LIME charter: next step

Dear all,

Thanks to all who contributed to this proposed charter so far.
I believe that this charter is now stable enough, and has enough community support.
At this point in time, we want to get feedback from the IESG.
Therefore this charter is on the IESG telechat next Thursday.

Regards, Benoit

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sat, 27 Sep 2014 20:35:07 +0000

Thanks for uploading the new versions of the charter, including all the actual charter updates as well as the draft milestones we sent out and updated.

I think that the milestones need some more work. In addition to correcting typo's and grammo's, soem details seem missing.

Here's a proposal:

Milestones:
Feb 2015 - Adopt the WG draft on generic OAM YANG data model(s)
May 2015 - Adopt the WG draft on the LIME Architecture
Jun 2015 - WG Adoption of the Use-Cases document. Note this document might not be published as an RFC
Aug 2015 - Adopt the WG draft on the Applicability of the generic model(s)
Sep 2015 - Submit the YANG model(s) document to the IESG as a Proposed Standards RFC
Nov 2015 - Submit the Architecture document to the IESG as an Informational RFC
Apr 2016 -  Submit the Applicability document to the IESG as an Informational RFC
Apr 2016 - Recharter or conclude

Thanks,

Carlos.

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 27 Sep 2014 20:48:03 +0000

Hi Carlos,
thank you for your valuable suggestion to the milestones.
I think that before the WG can adopt any contribution on generic OAM we need to discuss the model, the paradigm of Generic OAM - scope, models, toolset. After there's agreement on what Generic OAM actually is, then, I agree, the WG may consider adopting YANG model. I think that work and discussion of the LIME Architecture may include discussion of Generic OAM. If Generic OAM is within the scope of LIME, then YANG DM of the G-OAM becomes part of LIME YANG DM work.

What do you think?

	Regards,
		Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Saturday, September 27, 2014 1:35 PM
To: Benoit Claise (bclaise)
Cc: [email-masked]
Subject: Re: [Lime] LIME charter: next step

Here's a proposal:

Milestones:
Feb 2015 - Adopt the WG draft on generic OAM YANG data model(s) May 2015 - Adopt the WG draft on the LIME Architecture Jun 2015 - WG Adoption of the Use-Cases document. Note this document might not be published as an RFC Aug 2015 - Adopt the WG draft on the Applicability of the generic model(s) Sep 2015 - Submit the YANG model(s) document to the IESG as a Proposed Standards RFC Nov 2015 - Submit the Architecture document to the IESG as an Informational RFC Apr 2016 -  Submit the Applicability document to the IESG as an Informational RFC Apr 2016 - Recharter or conclude

Thanks,

Carlos.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Sat, 27 Sep 2014 21:07:23 +0000

Hi Greg,

Yes, I agree that some of the specifics of the definition of what Generic OAM (as you say, "G-OAM") is will come and build from the understanding of the paradigm, models, and architecture. But, to me, that does not mean that we cannot make progress on the G-OAM YANG model(s). I believe that the charter text (https://datatracker.ietf.org/doc/charter-ietf-lime/) already gives enough definition to get us started, and includes the fact that G-OAM is within scope.

Thanks,

Carlos.

---

From: Qin Wu <[email-masked]>
Date: Sun, 28 Sep 2014 00:48:58 +0000

:-), Greg, you should know how hard it is to engage the right people at the beginning.
Thanks Greg and all the community continuing support in the process, without these support, we would not have make so rapid progress.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Gregory Mirsky
发送时间: 2014年9月26日 22:57
收件人: Benoit Claise; [email-masked]
主题: Re: [Lime] LIME charter: next step

Dear Benoit,

	Regards,
		Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Friday, September 26, 2014 2:32 AM
To: [email-masked]
Subject: [Lime] LIME charter: next step

Dear all,

Regards, Benoit

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 27 Sep 2014 21:03:53 -0400

Qin and Greg:

You have done a great job!

Sue 

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Saturday, September 27, 2014 8:49 PM
To: Gregory Mirsky; Benoit Claise; [email-masked]
Subject: Re: [Lime] LIME charter: next step

:-), Greg, you should know how hard it is to engage the right people at the
beginning.
Thanks Greg and all the community continuing support in the process, without
these support, we would not have make so rapid progress.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Gregory Mirsky
发送时间: 2014年9月26日 22:57
收件人: Benoit Claise; [email-masked]
主题: Re: [Lime] LIME charter: next step

Dear Benoit,
thank you for dedicating your time and expertise to this effort. I believe
that the problem we've formulated and direction chartered are both practical
and useful. We're for a great ride! Looking forward.

	Regards,
		Greg

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Friday, September 26, 2014 2:32 AM
To: [email-masked]
Subject: [Lime] LIME charter: next step

Dear all,

Thanks to all who contributed to this proposed charter so far.
I believe that this charter is now stable enough, and has enough community
support.
At this point in time, we want to get feedback from the IESG.
Therefore this charter is on the IESG telechat next Thursday.

Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Sun, 28 Sep 2014 01:22:24 +0000

Greg seems to talk about adoption requirements for any new work item in LIME, I agree with Carlos Charter text has already provided such guidance, e.g., reviewing existing OAM architecture.
But it is confusing to use Generic OAM since we are not targeted to define new technology or new OAM protocol (e.g., forwarding plane OAM protocol), generic data model work
Is our goal.

I think AD has already reiterated this point several times,
Quoted what Benoit said below:
"
Here is what we concluded:
1. Building an OAM generic protocol is impractical for multiple reasons. 
"
So "G-OAM" should not be used in the Charter text. I think the current Charter text(https://datatracker.ietf.org/doc/charter-ietf-lime/) updated by our AD address this very well.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Carlos Pignataro (cpignata)
发送时间: 2014年9月28日 5:07
收件人: Gregory Mirsky
抄送: Benoit Claise (bclaise); [email-masked]
主题: Re: [Lime] LIME charter: next step

Hi Greg,

Thanks,

Carlos.

---

From: Benoit Claise <[email-masked]>
Date: Sun, 28 Sep 2014 17:28:54 -0400

Carlos, Greg,

The WG is not about a generic OAM, but it's about a generic data model 
for OAM technologies.

Note: the deliverables are now slightly modified according to your advice.

Regards, Benoit
> .