Subject: [Lime] Generic Model and protocol-specific extension

From: Benoit Claise <[email-masked]>
Date: Thu, 25 Sep 2014 12:25:48 +0200

Dear all,

I've been having a concern related to: how do we check that the generic 
LIME data model(s) does/do the right job.
That lead to the another question: where should the protocol-specific 
extensions be standardized?

Based on a discussion with our routing AD Adrian Farrel, we propose this 
extra deliverable:

• Those YANG model(s) specified in this working group must be usable and
extensible by the existing OAM technologies. This usability and 
extensibility
must be demonstrated, for example with IP Ping, traceroute, BFD, and LSP 
Ping.
Note the technology-specific data model extensions should ideally be worked
on in the respective working groups.

Regards, Benoit

---

From: <[email-masked]>
Date: Thu, 25 Sep 2014 13:03:54 +0200

Dear all,

how is this ensured?
Is it that way that LIME might work on protocol-specific extensions (if interested)
or won't work on these extensions (excluded)?

Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Lime [mailto:[email-masked]] Im Auftrag von Benoit Claise
Gesendet: Donnerstag, 25. September 2014 12:26
An: [email-masked]
Cc: Adrian Farrel; Alia Atlas
Betreff: [Lime] Generic Model and protocol-specific extension

Dear all,

I've been having a concern related to: how do we check that the generic LIME data model(s) does/do the right job.
That lead to the another question: where should the protocol-specific extensions be standardized?

Based on a discussion with our routing AD Adrian Farrel, we propose this extra deliverable:

. Those YANG model(s) specified in this working group must be usable and extensible by the existing OAM technologies. This usability and extensibility must be demonstrated, for example with IP Ping, traceroute, BFD, and LSP Ping.
Note the technology-specific data model extensions should ideally be worked on in the respective working groups.

Regards, Benoit

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime

---

From: Benoit Claise <[email-masked]>
Date: Thu, 25 Sep 2014 14:26:44 +0200

Hi Roland,
> how is this ensured?
This is the dilemma.
On one side, we have to ensure usability and extensibility.
One the other side, It's not right to include the OAM protocol-specific 
extensions into the LIME charter. Let's pick BFD, there is a BFD WG 
where the experts are.

So the only solution is to stress the requirement in the charter and to 
trust the ADs, the WG chairs, and the community.
> or won't work on these extensions (excluded)?
I don't want to have strict rules for now. Hence the phrasing: "should 
_ideally _be worked on in the respective working group".
What is important (and I guess that Adrian & Alia share this view) is 
that the key experts are involved in producing a auality document.
 From there, where the document ends up in the end is less important IMO.

Regards, Benoit
> .

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Sep 2014 15:42:10 -0400

Benoit:

The protocol specific extensions should go to the protocol WGs.

Sue 

-----Original Message-----
From: Lime [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, September 25, 2014 6:26 AM
To: [email-masked]
Cc: Adrian Farrel; Alia Atlas
Subject: [Lime] Generic Model and protocol-specific extension

Dear all,

I've been having a concern related to: how do we check that the generic LIME
data model(s) does/do the right job.
That lead to the another question: where should the protocol-specific
extensions be standardized?

. Those YANG model(s) specified in this working group must be usable and
extensible by the existing OAM technologies. This usability and
extensibility must be demonstrated, for example with IP Ping, traceroute,
BFD, and LSP Ping.
Note the technology-specific data model extensions should ideally be worked
on in the respective working groups.

Regards, Benoit

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 26 Sep 2014 20:14:24 +0000

On Sep 25, 2014, at 1:26 PM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Hi Roland,

Dear all,

how is this ensured?

This is the dilemma.
On one side, we have to ensure usability and extensibility.
One the other side, It's not right to include the OAM protocol-specific extensions into the LIME charter. Let's pick BFD, there is a BFD WG where the experts are.

So the only solution is to stress the requirement in the charter and to trust the ADs, the WG chairs, and the community.

I don't want to have strict rules for now. Hence the phrasing: "should ideally be worked on in the respective working group".
What is important (and I guess that Adrian & Alia share this view) is that the key experts are involved in producing a auality document.
>From there, where the document ends up in the end is less important IMO.

I agree -- and the most efficient way of getting the experts involved is in the protocol WGs. LIME would have to ensure a strong link and coordination with those WGs, as well as review and contribution make sure those protocol-specific extensions fit the generic model.

Thanks,

Carlos.

Regards, Benoit

Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Lime [mailto:[email-masked]] Im Auftrag von Benoit Claise
Gesendet: Donnerstag, 25. September 2014 12:26
An: [email-masked]<mailto:[email-masked]>
Cc: Adrian Farrel; Alia Atlas
Betreff: [Lime] Generic Model and protocol-specific extension

Dear all,

Regards, Benoit

_______________________________________________
Lime mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lime
.

_______________________________________________
Lime mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lime