Subject: [link-relations] Registering the 'search' link relation type

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Nov 2010 15:08:16 +1100

Hello OpenSearchers,

I'm acting as a Designated Expert for the IANA Link Relation Type registry, defined by RFC5988 <http://tools.ietf.org/html/rfc5988>.

We've had a request <http://paramsr.us/tracker/issue18> from the W3C HTML WG to register the 'search' link relation type. 
  
Since OpenSearch has defined the 'search' relation type, and HTML5 refers to your specification to define its semantics, we wanted to make sure this registration was OK with the OpenSearch community before proceeding. Do you have any objections to them doing so?

Additionally, we (the Designated Experts) wanted to double-check with you that the reference they give is a) appropriate, and b) stable. I.e., it's not going to change gratuitously. 

We'd appreciate a response as soon as possible, so that we can proceed with the registration.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: DeWitt Clinton <[email-masked]>
Date: Tue, 2 Nov 2010 21:21:08 -0700

No objection at all, (speaking as unofficial spec editor).  Very glad to see
this happen, and thank you to Michael Smith and the W3C HTML WG for making
the proposal.

That URL is stable, and has not changed in several years, and we would of
course be sure to preserve it with a redirect in the event anything ever
moved.

That said, the full URL appears truncated in the registration application.
 It currently reads:

http://www.opensearch.org/Specifications/OpenSearch/1.1#Autodiscovery_in_HTML.2FXH

Should be:

http://www.opensearch.org/Specifications/OpenSearch/1.1#Autodiscovery_in_HTML.2FXHTML

Thanks, Mark!

-DeWitt

On Tue, Nov 2, 2010 at 9:08 PM, Mark Nottingham <[email-masked]> wrote:

> Hello OpenSearchers,
>
> I'm acting as a Designated Expert for the IANA Link Relation Type registry,
> defined by RFC5988 <http://tools.ietf.org/html/rfc5988>.
>
> We've had a request <http://paramsr.us/tracker/issue18> from the W3C HTML
> WG to register the 'search' link relation type.
>
> Since OpenSearch has defined the 'search' relation type, and HTML5 refers
> to your specification to define its semantics, we wanted to make sure this
> registration was OK with the OpenSearch community before proceeding. Do you
> have any objections to them doing so?
>
> Additionally, we (the Designated Experts) wanted to double-check with you
> that the reference they give is a) appropriate, and b) stable. I.e., it's
> not going to change gratuitously.
>
> You received this message because you are subscribed to the Google Groups
> "OpenSearch" group.
> To post to this group, send email to [email-masked].
> To unsubscribe from this group, send email to
> [email-masked]<[email-masked]>
> .
> For more options, visit this group at
> http://groups.google.com/group/opensearch?hl=en.
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Nov 2010 15:47:24 +1100

Thanks, DeWitt.

One thing; I'm wondering if it makes more sense to list the OpenSearch link directly as the reference, rather than going through the HTML5 one. 

E.g., the registration could be:

Relation Name:
 search

Description:
 Gives a link to a resource that can be used to search through
 the current document and its related pages.

Reference:

Notes:
 See also: http://www.w3.org/TR/html5/links.html#link-type-search

Thoughts? Mike?

On 03/11/2010, at 3:21 PM, DeWitt Clinton wrote:

> No objection at all, (speaking as unofficial spec editor).  Very glad to see this happen, and thank you to Michael Smith and the W3C HTML WG for making the proposal.
> 
> That URL is stable, and has not changed in several years, and we would of course be sure to preserve it with a redirect in the event anything ever moved.
> 
> That said, the full URL appears truncated in the registration application.  It currently reads:
> 
> You received this message because you are subscribed to the Google Groups "OpenSearch" group.
> To unsubscribe from this group, send email to [email-masked].
> For more options, visit this group at http://groups.google.com/group/opensearch?hl=en.
> 
> 
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: DeWitt Clinton <[email-masked]>
Date: Tue, 2 Nov 2010 21:58:53 -0700

If the designated experts are comfortable with that approach — and it sounds
like you might be, otherwise you wouldn't have asked — I'd personally prefer
that, considering the 'search' relation name is used in multiple contexts
for the same purpose, not exclusively HTML(5).

Thanks for asking,

-DeWitt

On Tue, Nov 2, 2010 at 9:47 PM, Mark Nottingham <[email-masked]> wrote:

> Thanks, DeWitt.
>
> One thing; I'm wondering if it makes more sense to list the OpenSearch link
> directly as the reference, rather than going through the HTML5 one.
>
> > No objection at all, (speaking as unofficial spec editor).  Very glad to
> see this happen, and thank you to Michael Smith and the W3C HTML WG for
> making the proposal.
> >
> > I'm acting as a Designated Expert for the IANA Link Relation Type
> registry, defined by RFC5988 <http://tools.ietf.org/html/rfc5988>.
> >
> > We've had a request <http://paramsr.us/tracker/issue18> from the W3C
> HTML WG to register the 'search' link relation type.
> >

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Nov 2010 16:00:29 +1100

OK. If that's the case, should the registration just have:

> Reference:
>  http://www.opensearch.org/Specifications/OpenSearch/1.1

?

Cheers,

On 03/11/2010, at 3:58 PM, DeWitt Clinton wrote:

> If the designated experts are comfortable with that approach — and it sounds like you might be, otherwise you wouldn't have asked — I'd personally prefer that, considering the 'search' relation name is used in multiple contexts for the same purpose, not exclusively HTML(5).
> 
> Thanks for asking,
> 
> -DeWitt
>

---

From: DeWitt Clinton <[email-masked]>
Date: Tue, 2 Nov 2010 22:01:55 -0700

Yes, please.

-DeWitt

On Tue, Nov 2, 2010 at 10:00 PM, Mark Nottingham <[email-masked]> wrote:

> > If the designated experts are comfortable with that approach — and it
> sounds like you might be, otherwise you wouldn't have asked — I'd personally
> prefer that, considering the 'search' relation name is used in multiple
> contexts for the same purpose, not exclusively HTML(5).
> >
> > Thanks for asking,
> >
> > -DeWitt
> >
> > One thing; I'm wondering if it makes more sense to list the OpenSearch
> link directly as the reference, rather than going through the HTML5 one.
> >
> > > No objection at all, (speaking as unofficial spec editor).  Very glad
> to see this happen, and thank you to Michael Smith and the W3C HTML WG for
> making the proposal.
> > >
> > > That URL is stable, and has not changed in several years, and we would
> of course be sure to preserve it with a redirect in the event anything ever
> moved.
> > >
> > > Since OpenSearch has defined the 'search' relation type, and HTML5
> refers to your specification to define its semantics, we wanted to make sure
> this registration was OK with the OpenSearch community before proceeding. Do
> you have any objections to them doing so?
> > >
> > > Additionally, we (the Designated Experts) wanted to double-check with
> you that the reference they give is a) appropriate, and b) stable. I.e.,
> it's not going to change gratuitously.
> > >

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 4 Nov 2010 01:45:16 +0900

Updated request (in full):

  Relation Name:
    search

  Description:

  Reference:

-- 
Michael(tm) Smith
http://people.w3.org/mike

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 4 Nov 2010 11:46:55 +1100

Mike, are you requesting the link with the fragid on purpose? Clinton and I seem to agree that going without makes more sense.

Cheers,

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 4 Nov 2010 16:47:24 +0900

Hi Mark,

> Mike, are you requesting the link with the fragid on purpose?

No, just inadvertently copied and pasted the URL with the fragid instead of
the one without (sorry, was in a kind of a hurry yesterday to get mail sent
before the battery ran out on my laptop).

> Clinton and I seem to agree that going without makes more sense.

Yeah, I agree as well -- sorry for the confusion.

  --Mike

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Nov 2010 12:01:18 +1100

Iana folks: 

Please add the following to the link relations registry.

----------------

 Relation Name:
   search

 Description:
   Refers to a resource that can be used to search through
   the link's context and related resources.

 Reference:

Notes:

-------------------