Subject: [link-relations] Link relation registrations from HTML5

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Nov 2010 21:10:31 +1100

Mike,

Now that the RFC has been published, I'm going to start processing of these requests. 

1) The first batch have already been approved, and I'll send a request to IANA shortly.

prefetch
noreferrer
nofollow
icon
archives
author
help
stylesheet

Note that the description of 'icon' has been slightly re-worded to make it more generic:

 Links to an icon representing the current document.

Likewise, stylesheet is re-worded to:

 Links to a stylesheet.

Tell us if either is an issue for you.

2) I think we can also register

next
prev

... but before we do, we should clarify the status of 'previous', which is currently a synonym to 'prev'. The simplest thing to do would be to copy
its text from 'prev', but the HTML document doesn't currently define it AIUI, so the reference wouldn't be correct.

Alternatively, we could deprecate it and point to prev. 

Thoughts?

3) The following are still in-process, but waiting for the discussion on-list to finish:

bookmark
alternate

4) I've temporarily deferred the following, as they appear to be still under discussion in the HTML WG:

sidebar
tag
external
index
first 
last (because it's so closely tied to 'first')

5) Likewise, I've deferred the following until I hear back from you regarding whether it's acceptable to keep the current description and reference, updating the notes to point to HTML5 for HTML-specific concerns:

up
license

6) We're still processing search. As you've hopefully seen, we've gotten in touch with OpenSearch and see if they're happy to have HTML5 register the relation that points to their spec. They say that's OK, but see my question in that thread re: appropriate references.

7) We've deferred pingback as well. The biggest issue is that it is on a personal Web site, with no continuity. We really need to see something a bit more stable, e.g., on the W3C Web site as a Note, or on a stable community site like microformats.org. Can you look into this? 

Finally, you can also see the current state of your requests in our tracker:
  http://paramsr.us/tracker/

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Wed, 03 Nov 2010 11:46:12 +0100

On 03.11.2010 11:10, Mark Nottingham wrote:
> ...
> ...

Depends a bit on how popular the synonym is.

I'd recommend to update the existing registrations, and treat "previous" 
separately.

 > ...

Best regards, Julian

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 4 Nov 2010 02:07:36 +0900

>  Links to an icon representing the current document.

I just sent an updated request with that changed to:

  The specified resource is an icon representing the page or site, and
  should be used by the user agent when representing the page in the user
  interface.

But I think "Links to an icon representing the current document." is also
fine. I leave it up to the DEs to discuss and make a final decision on.

> Likewise, stylesheet is re-worded to:

I sent an updated request with the wording "Specifies a stylesheet." but I
think "Links to a stylesheet." is also fine. I leave it up to the DEs to
discuss and make a final decision on.

> Tell us if either is an issue for you.

No issues for me, but as noted above, I leave it up to you all to decide
the final wording.

> Alternatively, we could deprecate it and point to prev. 

I agree with Julian -- I think we should go ahead an register "prev" and
deal with follow-up about "previous" in parallel.

> 3) The following are still in-process, but waiting for the discussion on-list to finish:

See my updated requests for those -

http://www.ietf.org/mail-archive/web/link-relations/current/msg00110.html
http://www.ietf.org/mail-archive/web/link-relations/current/msg00111.html

> last (because it's so closely tied to 'first')

Yep

> 5) Likewise, I've deferred the following until I hear back from you
> regarding whether it's acceptable to keep the current description and
> reference, updating the notes to point to HTML5 for HTML-specific
> concerns:
> 
> up

I agree with Julian that is makes sense to defer that one.

> license

Here's an updated request (in full):

  Relation Name:                                                                                                                                              
   license                                                                                                                                                    
                                                                                                                                                              
  Description:                                                                                                                                                
   Refers to a license associated with the link's context.                                                                                                    
                                                                                                                                                              
  Reference:                                                                                                                                                  
   [RFC4946]                                                                                                                                                  
                                                                                                                                                              
  Notes:                                                                                                                                                      
    For implications of use in HTML, see:
    http://www.w3.org/TR/html5/links.html#link-type-license                                                             

> 6) We're still processing search. As you've hopefully seen, we've gotten
> in touch with OpenSearch and see if they're happy to have HTML5 register
> the relation that points to their spec. They say that's OK, but see my
> question in that thread re: appropriate references.

See my updated request:

  http://www.ietf.org/mail-archive/web/link-relations/current/msg00119.html

> 7) We've deferred pingback as well. The biggest issue is that it is on a
> personal Web site, with no continuity. We really need to see something a
> bit more stable, e.g., on the W3C Web site as a Note, or on a stable
> community site like microformats.org. Can you look into this? 

Yes, I will.

>   http://paramsr.us/tracker/

Thanks

  --Mike

-- 
Michael(tm) Smith
http://people.w3.org/mike

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 4 Nov 2010 09:44:35 +1100

Thanks for the reply, Mike. Followups inline.

> No issues for me, but as noted above, I leave it up to you all to decide

Right. I'm inclined to do a light edit of the request descriptions to bring them into a bit more alignment, if it's OK with you.

I.e., right now they use phrases like:
  "provides a link"
  "gives a link to the current document's..."
  "links to an..."
  "indicates that the current resource's..."
  "specifies that the target resource..."
  "specifies a..."
  "designates a..."
  "refers to a..."

whereas the registry entries tend to use "refers to a...", "context" and "resource."

I'd suggest we:
  - use "refers to..." instead of "provides..." "gives..." and similar
  - use "indicates..." instead of "designates"
  - use "current resource" or "link's context" instead of "current document"
  - use "link target" instead of "referenced resource"

To be clear -- this is all completely optional, and I'm not going to hold up registration by splitting hairs over terminology. 

I'll send a summary of the edits for review separately if you agree.

> deal with follow-up about "previous" in parallel.

Will do.

> http://www.ietf.org/mail-archive/web/link-relations/current/msg00111.html

Approved, keeping in mind the terminology question above.

>    http://www.w3.org/TR/html5/links.html#link-type-license

Approved.

>  http://www.ietf.org/mail-archive/web/link-relations/current/msg00119.html

Will follow up there.

Cheers,

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 4 Nov 2010 16:48:38 +0900

Mark Nottingham <[email-masked]>, 2010-11-04 09:44 +1100:

> Right. I'm inclined to do a light edit of the request descriptions to
> bring them into a bit more alignment, if it's OK with you.

OK by me, in principle.

> whereas the registry entries tend to use "refers to a...", "context" and "resource."

I see.

>   - use "refers to..." instead of "provides..." "gives..." and similar

I assume that's the way you want to do it for purposes of stylistic
consistency in the registry, so I'm objecting. But I can't say that I think
it's an actual improvement. For example, I think "Provides a link to
context-sensitive help" is fine as-is, and I don't think "Refers to a link
to context-sensitive help" is an improvement at all.

If anything, if you wanted to choose something for stylistic consistency
or, really, even for reasons of precision in wording, I think "represents"
would be much better. For example, "Represents a link to context-sensitive
help".

Anyway, I don't object to "refers to".

>   - use "indicates..." instead of "designates"

Yeah, that is a clear improvement. (FWIW, I did not have "designates"
originally -- I requested it that way because "Designates a substitute for
the link's context is what HTML4 had, and it was suggested to me that it
should be changed back to that.)

>   - use "current resource" or "link's context" instead of "current document"

I'm fine with replacing "document" with "resource." (I might have written
it that way to begin with except that I now completely avoid using the word
"resource" at all because of the problem that has been created by whatever
historical chain of events led to the standards community ever having
agreed to begin with to take a really useful real word for which we don't
have any suitable synonyms, and permanently turn it into a specialized term
of art.)

While I understand the motivation for changing to "context", I don't think
the result is big improvement for clarity. But I don't have anything better
to suggest, so I won't object.

>   - use "link target" instead of "referenced resource"

Yeah, that is definitely better.

> To be clear -- this is all completely optional, and I'm not going to hold
> up registration by splitting hairs over terminology. 
> 

That would be great if you can make time to do it, but I don't think it's
absolutely necessary.

Thanks,

  --Mike

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 4 Nov 2010 19:09:13 +1100

On 04/11/2010, at 6:48 PM, Michael(tm) Smith wrote:
> consistency in the registry, so I'm objecting.

Did you mean 'not objecting'?  

> But I can't say that I think

Fair enough. I don't disagree with your observations; I think the best thing to do is just send an followup email with suggested edits -- taking your feedback into account -- and see if we can agree on something.

Cheers,

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 4 Nov 2010 17:34:43 +0900

> Did you mean 'not objecting'?  

Yes, I did mean "not objecting" (sorry for the carelessness)

> Fair enough. I don't disagree with your observations; I think the best
> thing to do is just send an followup email with suggested edits -- taking
> your feedback into account -- and see if we can agree on something.

OK

  --Mike