Subject: [link-relations] Fwd: A go at a rough edit

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Nov 2010 11:57:33 +1100

I didn't get a response from Mike to these, and he had previously said that he didn't object to such editing (in general), so in the interest of getting these into the registry I'm going to go ahead and forward to IANA. 

Mike, if you have objections (even small ones), please yell and we'll get them fixed.

Regards,

Begin forwarded message:

> From: Mark Nottingham <[email-masked]>
> Date: 4 November 2010 11:52:10 PM AEDT
> To: "Michael(tm) Smith" <[email-masked]>
> Subject: A go at a rough edit
> 
> Hey Mike,
> 
> Just thought I'd run these by you to get a reaction... e.g., using "refers to" here but NOT "refers to a link..." which I agree doesn't work.
> 
> I use 'context' here because in some (e.g., icon) it seems to work better than "resource or site" which seems a bit arbitrary. However, if you don't like it (even a bit) I'm happy to go for "resource" as you indicated.
> 
> Cheers,
> 
> 
> ------------
> 
> Relation Name:
> archives
> 
> Description:
> Refers to a collection of records, documents, or other
> materials of historical interest.
> 
> Reference: 
> http://www.w3.org/TR/html5/links.html#link-type-archives
> 
> Notes:
> 
> --------------
> 
> Relation Name:
> author
> 
> Description:
> Refers to the context’s author.
> 
> Reference: 
> http://www.w3.org/TR/html5/links.html#link-type-author
> 
> Notes:
> 
> --------------------
> 
> Relation Name:
>    icon
> 
> Description:
>    Refers to an icon representing the link's context.
> 
> Reference:
>    http://www.w3.org/TR/html5/links.html#link-type-icon
> 
> Notes:
> 
> 
> --------------------
> 
> Relation Name:
>    nofollow
> 
> Description:
>    Indicates that the context’s original author or
>    publisher does not endorse the link target.
> 
> Reference:
>    http://www.w3.org/TR/html5/links.html#link-type-nofollow
> 
> Notes:
> 
> 
> -----------------
> 
> Relation Name:
> noreferrer
> 
> Description:
> Indicates that no referrer information is to be leaked when following the link.
> 
> Reference:
> http://www.w3.org/TR/html5/links.html#link-type-noreferrer
> 
> Notes:
> 
> 
> --------------------
> 
> Relation Name:
> prefetch
> 
> Description:
> Indicates that the link target should be preemptively cached.
> 
> Reference: 
> http://www.w3.org/TR/html5/links.html#link-type-prefetch
> 
> Notes:
> 
> ------------------------
> 
> Relation Name:
> help
> 
> Description:
> Refers to context-sensitive help.
> 
> Reference:
> http://www.w3.org/TR/html5/links.html#link-type-help
> 
> Notes:
> 
> --------------------------
> 
> Relation Name:
> stylesheet
> 
> Description:
> Refers to a stylesheet.
> 
> Reference: 
> http://www.w3.org/TR/html5/links.html#link-type-stylesheet
> 
> Notes:
> 
> ---------------------------
> 
> Relation Name:
>  alternate
> 
> Description:
> Refers to a substitute for this context.
> 
> Reference:
>  http://www.w3.org/TR/html5/links.html#link-type-alternate
> 
> Notes:
> 
> ---------------------------
> 
> Relation Name:                                                                                                                                              
>  license                                                                                                                                                    
> 
> Description:                                                                                                                                                
>  Refers to a license associated with this context.
> 
> Reference:                                                                                                                                                  
>  [RFC4946]                                                                                                                                                  
> 
> Notes:                                                                                                                                                      
>   For implications of use in HTML, see:
>   http://www.w3.org/TR/html5/links.html#link-type-license   
> 
> -------------------------

--
Mark Nottingham   http://www.mnot.net/

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Tue, 9 Nov 2010 11:05:28 +0900

Mark Nottingham <[email-masked]>, 2010-11-09 11:57 +1100:

> I didn't get a response from Mike to these, and he had previously said
> that he didn't object to such editing (in general), so in the interest of
> getting these into the registry I'm going to go ahead and forward to
> IANA. 
> 

No objections. And I see that you've got it on out to IANA, so thanks.

  --Mike

-- 
Michael(tm) Smith
http://people.w3.org/mike