Subject: [Lln-futures] Notes from hallway meeting in Vancouver

From: Geoff Mulligan <[email-masked]>
Date: Wed, 12 Sep 2012 11:58:35 -0600

LLN people,

Here are the notes (thank you Justin) from the hallway meeting in Vancouver.

There seems to be some "sort-of" parallel efforts (coman and solace), 
but potentially focused on different areas.

We had about 7 or 8 people attend the hallway discussion.  There seem to 
folks interested in a variety of topics related to LLNs that were not 
addressed by 6lowpan.  If we would like to have a formal BOF in Atlanta 
I need to request it soon so we should have some good discussion about 
work items and topics for the the BOF.

Please read these notes below and lets start talking...

     geoff

---------------- Notes ---------------------

6lowpan has shut down but there is still stuff to be done.

What are the gaps in getting M2M communication to work within the scope 
of LLNs?

Management of constrained devices might be taking place in COMAN.

Where do we do architectures for LLNs?  In general the IETF doesn't 
do architectures but its hard to tackle these problems without an over 
arching framework.

There are lots of different drafts and protocols and who is the 
person/group looking over them and seeing if they are going to work and 
how they fit together.

What about a common security solution for LLNs?  There are different 
levels of security for different type of systems. It might be possible 
to leverage the shared medium characteristics to help secure these devices.

With the layering approach we have so far....our feeling is that we have 
many different solutions at the different layers. We end up with 
different solutions  doing the same work and potentially not interoperable.

There is an interest in security and key management.  End to end 
security in a multihop network.

The original drafts we put out we said you can't do IPSEC. Technology 
has increased so perhaps we can do ipsec in these smaller devices, or 
some subset of ipsec.

The 802.15 group has been expanding at a rapid rate- some new PHYs and 
MACs.  Is there interest in IP over these?

Working groups cluster multi dimensional issues together and the 
solutions to the different issues might not be the same.  LLN (as low 
power lossy networks) are they low power or are they lossy or are they 
both?  Perhaps we should focus on one or the other

What about device identity issues.  Is this in SOLACE or COMAN

---

From: "Keoh, Sye Loong" <[email-masked]>
Date: Mon, 17 Sep 2012 11:16:29 +0000

Dear all,

I agree that having a formal BOF in Atlanta would be great to kick off some discussion. Geoff, what do we need to prepare for a formal BOF in IETF?

Security for LLN is definitely one of the areas that we should address. A common solution for key management, communication security, security bootstrapping is beneficial as we can remove redundancies due to the constraints of the devices.

Cheers
Sye Loong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Geoff Mulligan
Sent: woensdag 12 september 2012 19:59
To: [email-masked]
Subject: [Lln-futures] Notes from hallway meeting in Vancouver

LLN people,

There seems to be some "sort-of" parallel efforts (coman and solace), but potentially focused on different areas.

We had about 7 or 8 people attend the hallway discussion.  There seem to folks interested in a variety of topics related to LLNs that were not addressed by 6lowpan.  If we would like to have a formal BOF in Atlanta I need to request it soon so we should have some good discussion about work items and topics for the the BOF.

     geoff

---------------- Notes ---------------------

What are the gaps in getting M2M communication to work within the scope of LLNs?

Where do we do architectures for LLNs?  In general the IETF doesn't do architectures but its hard to tackle these problems without an over arching framework.

There are lots of different drafts and protocols and who is the person/group looking over them and seeing if they are going to work and how they fit together.

What about a common security solution for LLNs?  There are different levels of security for different type of systems. It might be possible to leverage the shared medium characteristics to help secure these devices.

With the layering approach we have so far....our feeling is that we have many different solutions at the different layers. We end up with different solutions  doing the same work and potentially not interoperable.

There is an interest in security and key management.  End to end security in a multihop network.

The original drafts we put out we said you can't do IPSEC. Technology has increased so perhaps we can do ipsec in these smaller devices, or some subset of ipsec.

The 802.15 group has been expanding at a rapid rate- some new PHYs and MACs.  Is there interest in IP over these?

Working groups cluster multi dimensional issues together and the solutions to the different issues might not be the same.  LLN (as low power lossy networks) are they low power or are they lossy or are they both?  Perhaps we should focus on one or the other

What about device identity issues.  Is this in SOLACE or COMAN _______________________________________________
Lln-futures mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lln-futures

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Mon, 17 Sep 2012 11:19:20 +0000

Requesting a BOF requires an accurate view on the scope, potential  charter, ...

JP Vasseur
Cisco Fellow

Sent from my iPhone

On 17 sept. 2012, at 13:16, "Keoh, Sye Loong" <[email-masked]> wrote:

> _______________________________________________
> Lln-futures mailing list
> [email-masked]

---

From: Ralph Droms <[email-masked]>
Date: Mon, 17 Sep 2012 09:08:32 -0400

The deadline for requesting a BoF is next Monday, Sep 25.

More information is available here: http://www.ietf.org/wg/bof-procedures.html

I'll be happy to work with you to develop a BoF request.  There is a review process for BoF scheduling, and not every BoF request is approved, so you'll need to work quickly to organize the purpose and scope of the BoF, and prepare the BoF request.

- Ralph

---

From: Thomas Heide Clausen <[email-masked]>
Date: Mon, 17 Sep 2012 15:12:59 +0200

The IETF found it helpful to record experiences on how to have a successful BOF:

   http://tools.ietf.org/html/rfc5434

Lars Eggert even is working on documenting experiences with having successful bar-BOFs:

   http://tools.ietf.org/html/draft-eggert-successful-bar-bof

Best,

Thomas

-- 
Thomas Heide Clausen
http://www.thomasclausen.org/

"Any simple problem can be made insoluble if enough meetings are held to
 discuss it."
   -- Mitchell's Law of Committees

---

From: "Mani, Mehdi" <[email-masked]>
Date: Mon, 17 Sep 2012 06:16:14 -0700

One interesting topic to be included in lln-futures discussions could be "network management protocol for LLN devices".

-Mehdi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Keoh, Sye Loong
Sent: lundi 17 septembre 2012 13:16
To: [email-masked]
Subject: Re: [Lln-futures] Notes from hallway meeting in Vancouver

Dear all,

Cheers
Sye Loong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Geoff Mulligan
Sent: woensdag 12 september 2012 19:59
To: [email-masked]
Subject: [Lln-futures] Notes from hallway meeting in Vancouver

LLN people,

     geoff

---

From: Ralph Droms <[email-masked]>
Date: Mon, 17 Sep 2012 09:36:39 -0400

> The deadline for requesting a BoF is next Monday, Sep 25.

Correction: Monday 9/24.

- Ralph

---

From: Geoff Mulligan <[email-masked]>
Date: Mon, 17 Sep 2012 10:50:01 -0600

so if folks have items of interest and suggestions on work items and 
charter, please speak up

time is running out

     geoff

---

From: Geoff Mulligan <[email-masked]>
Date: Mon, 17 Sep 2012 11:08:49 -0600

Ralph,
   Thanks for the offer of help.

As Ralph pointed out, we need to define the purpose and scope.  As I've 
mentioned in my past messages, we have lots of disparate topics.  We 
need to define something somewhat cohesive in order to schedule a formal 
BOF.

Suggestions...

         geoff

---

From: Geoff Mulligan <[email-masked]>
Date: Mon, 17 Sep 2012 11:09:54 -0600

Is this what coman is doing?

---

From: "Mani, Mehdi" <[email-masked]>
Date: Tue, 18 Sep 2012 00:58:27 -0700

It is. And it would be much more better to have one WG covering different aspect of LLNs instead of having different teams like this. I believe that management and security are two aspects that are bound and it is hard to imagine that these two aspects be handled in two different WGs.