Subject: [LOOPS] Results of the LOOPS side meeting May 2020

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Jun 2020 02:16:23 +0200

Thank you all for participating in the May 26 side meeting.
I have updated the charter proposal with the results of the discussion:

https://github.com/loops-wg/charter

This reflects embracing ECN both for the end-to-end flows and for the path segment, as well as cleaning up the milestones to a single deliverable (which might or might not be multiple documents; I don’t think the charter needs to nail this down).  Goals for FEC support are scaled down, but FEC stays in as part of the first deliverable.

I have also moved the “discussion” section to a separate file.

Please have a timely look as the charter will be one of the inputs to the BOF process — we need to have a solid BOF proposal by June 12.

Grüße, Carsten

---

From: Liyizhou <[email-masked]>
Date: Thu, 4 Jun 2020 08:50:24 +0000

Hi,

From last discussion, I think LOOPS would provide the flexibility to allow the negotiation of what FEC to be used.

So in the charter proposal, 
"at least one FEC scheme will be included in order to exercise the protocol mechanisms. "

We can add text like,
Channel to allow FEC scheme negotiation is also to be defined?

Thanks,
Yizhou  
"

-----Original Message-----
From: LOOPS [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Thursday, June 4, 2020 8:16 AM
To: [email-masked]
Subject: [LOOPS] Results of the LOOPS side meeting May 2020

Grüße, Carsten

-- 
LOOPS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/loops

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 4 Jun 2020 11:34:23 +0200

Hi Carsten,

I saw that the charter is now focusing on Geneve as the first and premier mapping. There is an active working group for this protocol which usually is interested in taking on new extension within their group. Was this work presented there already? Would probably be good to start a draft for that extensions as well!

Mirja

> On 4. Jun 2020, at 02:16, Carsten Bormann <[email-masked]> wrote:
>

---

From: <[email-masked]>
Date: Thu, 4 Jun 2020 10:01:00 +0000

Hi Carsten, 

Thank you for reflecting the outcome of the discussion in the proposed charter text.

FWIW, you may find some change proposals at: https://github.com/loops-wg/charter/pull/3/files 

Cheers,
Med

> -----Message d'origine-----
> De : LOOPS [mailto:[email-masked]] De la part de Carsten
> Bormann
> Envoyé : jeudi 4 juin 2020 02:16
> À : [email-masked]
> Objet : [LOOPS] Results of the LOOPS side meeting May 2020
> 
> This reflects embracing ECN both for the end-to-end flows and for the
> path segment, as well as cleaning up the milestones to a single
> deliverable (which might or might not be multiple documents; I don’t
> think the charter needs to nail this down).  Goals for FEC support are
> scaled down, but FEC stays in as part of the first deliverable.
> 
> Please have a timely look as the charter will be one of the inputs to
> the BOF process — we need to have a solid BOF proposal by June 12.
> 
> Grüße, Carsten
> 
> --
> LOOPS mailing list
> [email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 4 Jun 2020 06:44:05 -0400

FEC negotiation is a good idea.

Marie-José Montpetit, Ph.D.
[email-masked]

On June 4, 2020 at 4:50:37 AM, Liyizhou ([email-masked]) wrote:

Hi,

So in the charter proposal,
"at least one FEC scheme will be included in order to exercise the protocol
mechanisms. "

We can add text like,

Thanks,
Yizhou
"

-----Original Message-----
From: LOOPS [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Thursday, June 4, 2020 8:16 AM
To: [email-masked]
Subject: [LOOPS] Results of the LOOPS side meeting May 2020

This reflects embracing ECN both for the end-to-end flows and for the path
segment, as well as cleaning up the milestones to a single deliverable
(which might or might not be multiple documents; I don’t think the charter
needs to nail this down). Goals for FEC support are scaled down, but FEC
stays in as part of the first deliverable.

Please have a timely look as the charter will be one of the inputs to the
BOF process — we need to have a solid BOF proposal by June 12.

Grüße, Carsten

---

From: wangjl50 <[email-masked]>
Date: Thu, 4 Jun 2020 19:47:35 +0800

Hi Carsten,     Thank you for updating the charter proposal. It looks good for me. I'd also suggest to set up a milestone for adopting problems and opportunities, which is also mentioned by Med. It need not be published as an RFC eventually, but an adopted problem and opportunity draft can help the community to better design the specification during its development process. Thank  you.
Best regards
Jianglong Wang

From: [email-masked]
Date: 2020-06-04 18:01
To: Carsten Bormann; [email-masked]
Subject: Re: [LOOPS] Results of the LOOPS side meeting May 2020
Hi Carsten, 

 
Cheers,
Med

---

From: "Morten V. Pedersen" <[email-masked]>
Date: Thu, 4 Jun 2020 23:31:05 +0200

Agreed.

On 6/4/20 12:44 PM, Marie-Jose Montpetit wrote:
> [email-masked] <mailto:[email-masked]>
>
>
>
> On June 4, 2020 at 4:50:37 AM, Liyizhou ([email-masked] 
> <mailto:[email-masked]>) wrote:
>
>> Hi,
>>
>> From last discussion, I think LOOPS would provide the flexibility to 
>> allow the negotiation of what FEC to be used.
>>
>> From: LOOPS [mailto:[email-masked] 
>> <mailto:[email-masked]>] On Behalf Of Carsten Bormann
>> To: [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: Liyizhou <[email-masked]>
Date: Fri, 5 Jun 2020 01:09:02 +0000

That sounds like a good idea to me.

Yizhou

From: LOOPS [mailto:[email-masked]] On Behalf Of wangjl50
Sent: Thursday, June 4, 2020 7:48 PM
To: loops <[email-masked]>; cabo <[email-masked]>
Cc: [email-masked]
Subject: Re: [LOOPS] Results of the LOOPS side meeting May 2020

Hi Carsten,

     Thank you for updating the charter proposal. It looks good for me. I'd also suggest to set up a milestone for adopting problems and opportunities, which is also mentioned by Med. It need not be published as an RFC eventually, but an adopted problem and opportunity draft can help the community to better design the specification during its development process. Thank  you.
Best regards
Jianglong Wang

From: [email-masked]<mailto:[email-masked]>
Date: 2020-06-04 18:01
To: Carsten Bormann<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [LOOPS] Results of the LOOPS side meeting May 2020
Hi Carsten,

Cheers,
Med

> À : [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> https://www.ietf..org/mailman/listinfo/loops
--
LOOPS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/loops

---

From: Liyizhou <[email-masked]>
Date: Fri, 5 Jun 2020 01:34:13 +0000

Hi Mirja and Carsten,

I presented LOOPS in NVO3 WG in IETF 106. At that time, the main focus was to give a briefing on the problems to solve and what transport feature design (choice of ACK/NACK, timeout, re-sequencing or not, cc interaction, etc) to be expected. The encapsulation format was not the top priority back then.

LOOPS's key feature is more transport mechanism oriented, and I think it should be independent from different encap formats, especially for the common fields. 
Probably it would be good to talk to NVO3 regarding Geneve encapsulation again after this charter proposal discussion.

Thanks,
Yizhou

-----Original Message-----
From: LOOPS [mailto:[email-masked]] On Behalf Of Mirja Kuehlewind
Sent: Thursday, June 4, 2020 5:34 PM
To: Carsten Bormann <[email-masked]>
Cc: [email-masked]
Subject: Re: [LOOPS] Results of the LOOPS side meeting May 2020

Hi Carsten,

Mirja

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Jun 2020 18:24:02 +0200

> On 2020-06-04, at 13:47, wangjl50 <[email-masked]> wrote:
> 
> Hi Carsten,
>      Thank you for updating the charter proposal. It looks good for me. I'd also suggest to set up a milestone for adopting problems and opportunities, which is also mentioned by Med. It need not be published as an RFC eventually, but an adopted problem and opportunity draft can help the community to better design the specification during its development process. 

Hi Jianglong,

That is indeed a good idea.  I changed the proposed wording as follows below.

Grüße, Carsten

 ## Milestones
 
+The main deliverable will be a LOOPS specification.
+Also, the working group will adopt a "problems and opportunities"
+document as the basis of this work; this document then does not
+necessarily need to be published by itself as an output of the WG.
+
+* LOOPS problems and opportunities, WG document adopted, September 2020
 * LOOPS specification, WG document adopted, October 2020
 * LOOPS specification, PS to IESG, October 2021

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Jun 2020 18:40:53 +0200

Hi Med,

thank you for these proposals.  I had a bit of a hard time integrating some of them, because they don’t come with a rationale — sometimes the change seems to be a bit out of character with the charter.

Please have a look at https://github.com/loops-wg/charter/commit/6336fc92ea28733e61ca920d9822cb74add17ec2 and tell me if you think any of the other changes are essential.

Grüße, Carsten

> On 2020-06-04, at 12:01, [email-masked] wrote:
> 
> Hi Carsten, 
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Jun 2020 18:41:55 +0200

(And it probably is worth pointing out that there is a draft already:

https://tools.ietf.org/html/draft-bormann-loops-geneve-binding

I apologize for having let that draft expire; I need to update it with the decision to focus on Geneve first.)

Grüße, Carsten

> On 2020-06-04, at 10:50, Liyizhou <[email-masked]> wrote:
> 
> Hi,
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 8 Jun 2020 18:41:59 +0200

> Channel to allow FEC scheme negotiation is also to be defined?

I changed the wording as follows:

   retransmission, but at least one FEC scheme will be included in
-  order to exercise the protocol mechanisms.
+  order to exercise the protocol mechanisms for selecting FEC and a
+  specific FEC scheme.

Grüße, Carsten

---

From: <[email-masked]>
Date: Tue, 9 Jun 2020 07:17:03 +0000

Hi Carsten, 

The updated version looks better. I see that you integrated the proposal for adding a milestone for the opportunities spec. Thanks 

I still have the following (minor) comments: 

(1) I suggest we simply go for: s/network structures/networks

Not sure how "structures" should be interpreted.

(2) I'd like to be explicit that "multipath" may be a future work. It would be cool if we can add the following to that part: "and is left for future consideration."

(3) The opportunities doc will be an output of the WG. What we need to discuss as per (https://www.ietf.org/about/groups/iesg/statements/support-documents/) is whether we plan to publish it as an RFC. I suggest to make at least this change:

s/as an output of the WG/as an RFC.

We can even have an explicit text saying that the WG will decide that in due time.

(4) I suggested to make this change "s/LOOPS specification/LOOPS specification(s)" because I'm not sure yet if we can go for one single spec or have a core spec + Encap option spec. 

Similar to (3), we can decide now or leave this decision to be made during the lifetime of the WG. 

Cheers,
Med

> De : Carsten Bormann [mailto:[email-masked]]
> Envoyé : lundi 8 juin 2020 18:41
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : [email-masked]
> Objet : Re: [LOOPS] Results of the LOOPS side meeting May 2020
> 
> Hi Med,
> 
> thank you for these proposals.  I had a bit of a hard time integrating
> some of them, because they don’t come with a rationale — sometimes the
> change seems to be a bit out of character with the charter.
> 
> Please have a look at https://github.com/loops-
> wg/charter/commit/6336fc92ea28733e61ca920d9822cb74add17ec2 and tell me
> if you think any of the other changes are essential.
> 
> Grüße, Carsten
> 
> 
> > FWIW, you may find some change proposals at:
> https://github.com/loops-wg/charter/pull/3/files
> >
> > Cheers,
> > Med
> >

---

From: Liyizhou <[email-masked]>
Date: Tue, 9 Jun 2020 09:49:15 +0000

That looks good to me.
Thanks.

Rgds,
Yizhou

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Tuesday, June 9, 2020 12:42 AM
To: Liyizhou <[email-masked]>
Cc: [email-masked]
Subject: Re: [LOOPS] Results of the LOOPS side meeting May 2020

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Jun 2020 14:29:49 +0200

Hi Med,

> (1) I suggest we simply go for: s/network structures/networks

Done.

> (2) I'd like to be explicit that "multipath" may be a future work. It would be cool if we can add the following to that part: "and is left for future consideration."

Done.  I expect IESG to revert this forward-looking statement, but it sure helps to state our intention for now.

> s/as an output of the WG/as an RFC.

Done.

> We can even have an explicit text saying that the WG will decide that in due time.

(Yes, but probably not charter-worthy.)

> (4) I suggested to make this change "s/LOOPS specification/LOOPS specification(s)" because I'm not sure yet if we can go for one single spec or have a core spec + Encap option spec. 

So I made this a bit more explicit:

The main deliverable will be a LOOPS specification (one or split
between two documents, to be decided by the WG).

And I changed the milestone to

* LOOPS specification, WG document(s) adopted, October 2020

Thank you!

Grüße, Carsten