Subject: [LOOPS] GitHub?

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Jun 2020 10:25:13 +0300

Hi,

some folks (incl. me) have been opening issues on GitHub under the expectation a discussion would happen there - but nothing much so far.

If you would prefer issues to be discussed on the list, could I suggest that you disable the issue functionality for the repos?

Thanks,
Lars

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Jun 2020 09:52:50 +0200

Hi Lars,

> On 2020-06-23, at 09:25, Lars Eggert <[email-masked]> wrote:
> 
> Signed PGP part
> Hi,
> 

Indeed, we don’t have a github policy yet.

> If you would prefer issues to be discussed on the list, could I suggest that you disable the issue functionality for the repos?

Most WGs I contribute to do discuss issues on the list, but retain the issues functionality on github for its (administrative) process management function.  You certainly do things in a different way for QUIC, and when a WG is set up, that will need to be one of the discussions we need to have.

Incidentally, it was on my to do list for today to pull these issues out for discussion on the mailing list.  You beat me to it...

Grüße, Carsten

---

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Jun 2020 10:57:53 +0300

On 2020-6-23, at 10:52, Carsten Bormann <[email-masked]> wrote:
> 
> Most WGs I contribute to do discuss issues on the list, but retain the issues functionality on github for its (administrative) process management function.

ACK. Maybe add an issue template that clarifies that GitHub issues are for management, and other issues should be raised by email?

Lars

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Jun 2020 18:50:58 +0200

> ACK. Maybe add an issue template that clarifies that GitHub issues are for management, and other issues should be raised by email?

I’m not sure that this is the best advice.  What I have seen is that an issue that was raised on Github may stay there for a couple of days before it takes a shape that can be discussed well on the mailing list.  So I wouldn't want to discourage people bringing issues to Github first.

I do need to get better in bringing the issues forward though.  Sorry about your (very good) issues sitting there for a week.

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 23 Jun 2020 19:50:48 -0500

Hi, Carsten,

On Tue, Jun 23, 2020 at 11:51 AM Carsten Bormann <[email-masked]> wrote:

> >> Most WGs I contribute to do discuss issues on the list, but retain the
> issues functionality on github for its (administrative) process management
> function.
> >
> > ACK. Maybe add an issue template that clarifies that GitHub issues are
> for management, and other issues should be raised by email?
>
> I’m not sure that this is the best advice.  What I have seen is that an
> issue that was raised on Github may stay there for a couple of days before
> it takes a shape that can be discussed well on the mailing list.  So I
> wouldn't want to discourage people bringing issues to Github first.
>

(as an individual)

What we worked out with the MOPS co-chairs was

This document is in the Github repository at:

https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons

Readers are welcome to open issues and send pull requests for this document.

Substantial discussion of this document should take place on the MOPS
working group mailing list ([email-masked]).

Join: https://www.ietf.org/mailman/listinfo/mops
Search: https://mailarchive.ietf.org/arch/browse/mops/

Does that sound about right for LOOPS?

Best,

Spencer

I do need to get better in bringing the issues forward though.  Sorry about
> your (very good) issues sitting there for a week.
>
> Grüße, Carsten
>
> --
> LOOPS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/loops
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Jun 2020 07:01:15 +0200

On 2020-06-24, at 02:50, Spencer Dawkins at IETF <[email-masked]> wrote:
> Substantial discussion of this document should take place on the MOPS working group mailing list ([email-masked]).
> 
> Join: https://www.ietf..org/mailman/listinfo/mops

Sounds very much so for me.  This would go into a <note> at the start of any I-D relevant to LOOPS.  (The charter is not an I-D, so this information needs to be stashed somewhere TBD, maybe just as a preamble to the charter itself.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Jun 2020 07:25:47 +0200

On 2020-06-24, at 07:01, Carsten Bormann <[email-masked]> wrote:
> 
> This would go into a <note> at the start of any I-D relevant to LOOPS.

(And here is an example for such a note at the start of an I-D I helped edit:

Contributing

   Recent versions of this document are available at its GitHub
   repository https://github.com/one-data-model/sdf (https://github.com/
   one-data-model/sdf) -- this also provides an issue tracker as well as
   a way to supply "pull requests".

   General discussion of this SDF Internet-Draft for now will be on the
   mailing list of the Thing-to-Thing Research group, [email-masked]
   (subscribe at https://www.irtf.org/mailman/listinfo/t2trg
   (https://www.irtf.org/mailman/listinfo/t2trg)).

   The IRTF Note Well applies (https://www.ietf.org/about/note-well/
   (https://www.ietf.org/about/note-well/)).

The weird duplication of URIs in the plaintext form is an XML2RFC thing; it looks fine in the HTML.)

Grüße, Carsten

---

From: Lars Eggert <[email-masked]>
Date: Thu, 25 Jun 2020 08:58:48 +0300

> Incidentally, it was on my to do list for today to pull these issues out for discussion on the mailing list.  You beat me to it...

Are you going to forward the other issues to the list?

Lars

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Jun 2020 08:07:27 +0200

> Are you going to forward the other issues to the list?

Yes.  I was hoping to get closure on #6 first.  But I think we are there now wrt discussion, we just need to generate the changes to the charter text.

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 25 Jun 2020 11:25:50 -0500

Hi, Carsten,

On Thu, Jun 25, 2020 at 1:07 AM Carsten Bormann <[email-masked]> wrote:

> >> Incidentally, it was on my to do list for today to pull these issues
> out for discussion on the mailing list.  You beat me to it...
> >
> Yes.  I was hoping to get closure on #6 first.  But I think we are there
> now wrt discussion, we just need to generate the changes to the charter
> text.
>

Speaking as only one of three co-chairs, so don't take this as gospel, but
it seems useful to talk through more than one issue on the mailing list at
once, because if I read my calendar correctly, we're only about five weeks
from IETF 108, and only about three weeks from the cutoff for agendas being
posted, which (for a BOF) I believe should include materials like the
proposed charter.

So, I'm not asking for line-rate posting of issues for discussion, but
maybe we could slow start and ramp this up a bit? :-)

Do the right thing, of course.

Best,

Spencer

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Jun 2020 09:10:26 +0300

On 2020-6-25, at 19:25, Spencer Dawkins at IETF <[email-masked]> wrote:
> So, I'm not asking for line-rate posting of issues for discussion, but maybe we could slow start and ramp this up a bit? :-)

+1

It's not a great indicator of activity and interest if comments remain unaddressed for weeks.

Lars