Subject: [lp-wan] meeting in B-A IETF 95

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Mar 2016 17:10:20 +0000

Dear all:

The IETF is only a month away. Maybe we could start focusing on what we are going to discuss?
The current BoF schedule (https://trac.tools.ietf.org/bof/trac/wiki/WikiStart) has the below

  *   Discussion: Better characterization of a LPWAN. Identify target technologies
  *   Discussion: Applicability and gap analysis of Internet protocols
     *   IP challenges and non-IP wireless I/O models
     *   Latency and transport: applicability and problems with existing models
     *   exchange model: Is REST the right approach?
     *   AAA model

Do we have candidates to present on the above subjects?

Pascal

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 8 Mar 2016 20:19:35 +0100

Dear Pascal,

Thanks for setting up the discussion ! All items you listed are important and I think there are many potential candidates to present on the given subjects.

Among the different topics, I could present the possible implications for CoAP in LP-WANs (application-level ACKs, tokens, timers, etc.), as well as things related to specific functions, such as AAA, or technology-independent device/application management.

Best,
Alexander

> Le 4 mars 2016 à 18:10, Pascal Thubert (pthubert) <[email-masked]> a écrit :
> 
> Dear all:
>  
> The current BoF schedule (https://trac.tools.ietf.org/bof/trac/wiki/WikiStart <https://trac.tools.ietf.org/bof/trac/wiki/WikiStart>) has the below
>  
> Discussion: Better characterization of a LPWAN. Identify target technologies
> Discussion: Applicability and gap analysis of Internet protocols
> IP challenges and non-IP wireless I/O models
> Latency and transport: applicability and problems with existing models
> exchange model: Is REST the right approach?
> AAA model 
>  
> _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 8 Mar 2016 19:58:33 +0000

That would be great, Alex.

Beyond AAA we need to talk about identity models, who owns it ( net vs. app ) and how the trust is delegated.

I'm cc'ind Zach and Carsten in the hope that they contribute to the gap analysis discussions on transport and above.

Take care,

Pascal

Le 8 mars 2016 ? 20:20, Alexander Pelov <[email-masked]<mailto:[email-masked]>> a ?crit :

Dear Pascal,

Best,
Alexander

Le 4 mars 2016 ? 18:10, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> a ?crit :

Dear all:

Pascal
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 8 Mar 2016 23:04:00 +0100

Hi Pascal,

> Le 8 mars 2016 à 20:58, Pascal Thubert (pthubert) <[email-masked]> a écrit :
> 

Yes, sure, I was thinking on talking on the identity models, the ways this impacts the apps (RESTful or other) and the AAA. Delegating the trust, deviating keys for third-party applications, and the rest are all issues I can touch upon.

> I'm cc'ind Zach and Carsten in the hope that they contribute to the gap analysis discussions on transport and above.

Sure, great idea! I’ve been discussing with Carsten on some of these topics and it would be great to have him and Zach pitch in.

Best,
Alexander

> 
> Take care,
> 
> Pascal
> 
> Le 8 mars 2016 à 20:20, Alexander Pelov <[email-masked] <mailto:[email-masked]>> a écrit :
> 
>> Dear Pascal,
>> 
>>> Le 4 mars 2016 à 18:10, Pascal Thubert (pthubert) <[email-masked] <mailto:[email-masked]>> a écrit :
>>> 
>>> Dear all:
>>>  
> [email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 8 Mar 2016 23:39:04 -0500

Hi,

Yes, LPWAN has tentatively been scheduled for Monday Afternoon 17:40 to 19:40.

I have started a skeletal agenda. People interested in presenting
should contact me. This list is a reasonable place to discuss what
presentations we want and their relative importance.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Fri, Mar 4, 2016 at 12:10 PM, Pascal Thubert (pthubert)
<[email-masked]> wrote:
> The current BoF schedule
> (https://trac.tools.ietf.org/bof/trac/wiki/WikiStart) has the below
>
>
>

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 9 Mar 2016 09:07:35 +0100

Hello,

In the list that Pascal has mentioned in his previous mail, it is possible
for me to present the target technologies, its common characteristics and
the targets within the IETF.

thanks

Ana

On Wed, Mar 9, 2016 at 5:39 AM, Donald Eastlake <[email-masked]> wrote:

> > The IETF is only a month away. Maybe we could start focusing on what we
> are
> > going to discuss?
> >
> > The current BoF schedule

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 9 Mar 2016 09:20:10 +0000

Hello Don:

The initial thought son the WiKi were as follows:

"
*	Discussion: Better characterization of a LPWAN. Identify target technologies 
*	Discussion: Applicability and gap analysis of Internet protocols 
	o	IP challenges and non-IP wireless I/O models 
	o	Latency and transport: applicability and problems with existing models 
	o	exchange model: Is REST the right approach? 
	o	AAA model
"

The idea in part 1 was to extract from the ML discussions some specific properties of LP-Wan that are uncommon to even 6lo type of networks and that would lead to new approaches/solutions. This includes the devices, the MAC/PHY's, but also the way things are deployed and secure up to the application layer.

I read that Ana, who lead that discussion so far, is proposing to summarize what we have converged and upon which we can build something.

Part 2 was to determine where the IETF could contribute, maybe in the form of best practices, to the advancement of LP-WANs.

 I'll be happy to present on item 1 about IP challenges and non-IP wireless I/O models, whether and how 6LoWPAN could apply as is, or if another model like wireless I/O would be of interest.

I think Alex  proposed to participate to the discussion on CoAP and on security and present for a portion of that to be determined based on other presenters.

We are still missing work on transport. Clearly TCP is not a great choice, and UDP being transparent does not bring much either. Maybe the transport discussion can be merged with the network layer discussion?

Cheers,

Pascal

> -----Original Message-----
> From: lp-wan [mailto:[email-masked]] On Behalf Of Donald
> Eastlake
> Sent: mercredi 9 mars 2016 05:39
> To: [email-masked]
> Subject: Re: [lp-wan] meeting in B-A IETF 95
> 
> Hi,
> 
> I have started a skeletal agenda. People interested in presenting should
> contact me. This list is a reasonable place to discuss what presentations we
> want and their relative importance.
> 
> Thanks,
> Donald
>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]
> 
> 
> > IP challenges and non-IP wireless I/O models Latency and transport:
> > applicability and problems with existing models exchange model: Is
> > REST the right approach?
> > AAA model
> >
> >
> >

---

From: Rafa Marin Lopez <[email-masked]>
Date: Mon, 14 Mar 2016 16:53:03 +0100

Hi Alexander:

> El 8 mar 2016, a las 23:04, Alexander Pelov <[email-masked]> escribió:
> 
> Hi Pascal,
> 

I can help you on this part of the presentation, specially related with AAA and key management, if you think it is useful.

Best Regards.

>> Le 8 mars 2016 à 20:20, Alexander Pelov <[email-masked]> a écrit :
>> 
>>> Dear Pascal,
>>> 
>>>> 	• Discussion: Better characterization of a LPWAN. Identify target technologies
>>>> 	• Discussion: Applicability and gap analysis of Internet protocols
>>>> 		• IP challenges and non-IP wireless I/O models
>>>> 		• Latency and transport: applicability and problems with existing models
>>>> 		• exchange model: Is REST the right approach?
>>>> 		• AAA model 
>>>>  

-------------------------------------------------------
Rafael Marin Lopez, PhD
Dept. Information and Communications Engineering (DIIC)
Faculty of Computer Science-University of Murcia
30100 Murcia - Spain
Telf: +34868888501 Fax: +34868884151 e-mail: [email-masked]
-------------------------------------------------------

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 15 Mar 2016 11:31:19 +0100

Hi Rafa,

> Le 14 mars 2016 à 16:53, Rafa Marin Lopez <[email-masked]> a écrit :
> 
> Hi Alexander:
> 
> 

Thanks! That would be very helpful! I’ll be happy to present a couple of your slides.

Best,
Alexander