Subject: [lp-wan] 6LoWPAN & LPWAN

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 22 Mar 2016 16:06:55 +0000

Hi all,

Maybe it was discussed on this list already but I was wondering whether there is some experience with the use of 6LoWPAN in low-power WAN networks.
I could imagine that the desire to reduce the transmission overhead in these networks might lead to ideas to compress the IPv6 header (and the UDP header).

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 22 Mar 2016 18:04:50 +0100

Hi Hannes,

We’ve not discussed this yet on the mailing list, but I personally feel that we should provide mechanisms to have 6LP fit in 1 byte or have it implicitly defined when the L2 MAC allows it. This, in addition to draft-gomez-lpwan-fragmentation-header-01, would provide the missing link. I strongly believe having IPv6 on LP-WANs should be one of the major goals we should achieve here.  

Best,
Alexander

> Le 22 mars 2016 à 17:06, Hannes Tschofenig <[email-masked]> a écrit :
> 
> Hi all, 
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> lp-wan mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 22 Mar 2016 17:24:54 +0000

Thanks, Alexander! I contacted the authors of draft-gomez-lpwan-fragmentation-header-01 and draft-gomez-lpwan-ipv6-analysis-00

Ciao
Hannes

From: lp-wan [mailto:[email-masked]] On Behalf Of Alexander Pelov
Sent: 22 March 2016 18:05
To: Hannes Tschofenig
Cc: [email-masked]
Subject: Re: [lp-wan] 6LoWPAN & LPWAN

Hi Hannes,

We've not discussed this yet on the mailing list, but I personally feel that we should provide mechanisms to have 6LP fit in 1 byte or have it implicitly defined when the L2 MAC allows it. This, in addition to draft-gomez-lpwan-fragmentation-header-01, would provide the missing link. I strongly believe having IPv6 on LP-WANs should be one of the major goals we should achieve here.

Best,
Alexander

Le 22 mars 2016 à 17:06, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> a écrit :

Hi all,

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 24 Mar 2016 09:22:14 +0000

A short follow-up: I was particularly interested in the applicability of 6lowpan to the 3GPP NB-IoT efforts. Offlist I was told that the 3GPP currently mainly focuses on a non-IP use for their NB-IoT efforts and for use of IP they are not interested in 6lowpan but are rather focused on a robust header compression solution (instead of using the 6lowpan header compression approach). As such, my question about applicability of 6lowpan to LPWAN (and the 3GPP NB-IoT) may be irrelevant.

Ciao
Hannes

Hi Hannes,

Best,
Alexander

Hi all,

Ciao
Hannes

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 24 Mar 2016 19:38:40 +0000

Hi Hannes,

Current LTE eNB  uses ROHC . With NB-IOT, I am told 3GPP is doing a short cut currently by virtualizing some of the HC function in the local cloud. Thus they are avoiding 6LoWPAN for now. But this particular design scheme adopted by 3GPP ( due to  minimal change from current investment)  does NOT make 6LowPAN irrelevant for LoRA technology which is being developed  and brought to IETF for applying IETF protocols.

>From the architectural perspective, LPWAN is more suitable to run IPv6 with 6LoWPAN as LoRA will not be always co-located with 3GPP infrastructure and that's the whole point,

It is like having a debate on MQTT and COAP at IETF and saying COAP is not that relevant because MQTT provides message queuing and is deployed in many applications.

-Samita

From: lp-wan [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Thursday, March 24, 2016 2:22 AM
To: Alexander Pelov
Cc: [email-masked]
Subject: Re: [lp-wan] 6LoWPAN & LPWAN

Ciao
Hannes

From: lp-wan [mailto:[email-masked]] On Behalf Of Alexander Pelov
Sent: 22 March 2016 18:05
To: Hannes Tschofenig
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [lp-wan] 6LoWPAN & LPWAN

Hi Hannes,

Best,
Alexander

Hi all,

Ciao
Hannes

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Mar 2016 00:21:02 +0100

Samita Chakrabarti wrote:
> It is like having a debate on MQTT and COAP at IETF and saying COAP is
> not that relevant because MQTT provides message queuing and is deployed
> in many applications.

Yeah, except that ROHC actually is a well-designed IETF protocol...

Grüße, Carsten

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 24 Mar 2016 23:33:44 +0000

Hi Carsten,

No doubt about ROHC...  But you can explain better why 6LOWPAN decided to use IPHC stateless compression.

Thanks,
-Samita
-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, March 24, 2016 4:21 PM
To: Samita Chakrabarti
Cc: Hannes Tschofenig; Alexander Pelov; [email-masked]
Subject: Re: [lp-wan] 6LoWPAN & LPWAN

Samita Chakrabarti wrote:
> not that relevant because MQTT provides message queuing and is 
> deployed in many applications.

Grüße, Carsten

---

From: "weigengyu" <[email-masked]>
Date: Fri, 25 Mar 2016 13:13:19 +0800

Hi Alexander,

>but I personally feel that we should provide mechanisms to have 6LP fit in 1 byte or have it implicitly defined when the L2 MAC allows it. 

Compressing IPv6 address into 1 byte is not fit for a large scale networks. 
Defining a virtual IPv6 mechanisms to use 1 byte and the mapping IPv6 address and L2 MAC is probably better.

The IPv6 connected networks in whole may be a large scale network, but each branch may be small. 
So, “IPv6 over Foo” might not by the approach to interconnect the network with LP-WAN features.  

Regards,

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Alexander Pelov 
Sent: Wednesday, March 23, 2016 1:04 AM
To: Hannes Tschofenig 
Cc: [email-masked] 
Subject: Re: [lp-wan] 6LoWPAN & LPWAN

Hi Hannes,

Best,
Alexander

  Hi all, 

  Ciao
  Hannes
   
  [email-masked]

--------------------------------------------------------------------------------
_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan