Subject: [lp-wan] FW: New Version Notification for draft-ratilainen-lpwan-nb-iot-00.txt

From: Antti Ratilainen <[email-masked]>
Date: Fri, 8 Jul 2016 13:16:10 +0000

Dear all,

I have submitted a draft about NB-IoT characteristics to give some background information, see the forwarded mail below.

Best regards,
Antti

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 8. heinäkuuta 2016 16:07
To: Antti Ratilainen
Subject: New Version Notification for draft-ratilainen-lpwan-nb-iot-00.txt

A new version of I-D, draft-ratilainen-lpwan-nb-iot-00.txt
has been successfully submitted by Antti Ratilainen and posted to the IETF repository.

Name:		draft-ratilainen-lpwan-nb-iot
Revision:	00
Title:		NB-IoT characteristics
Document date:	2016-07-08
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/internet-drafts/draft-ratilainen-lpwan-nb-iot-00.txt
Status:         https://datatracker.ietf.org/doc/draft-ratilainen-lpwan-nb-iot/
Htmlized:       https://tools.ietf.org/html/draft-ratilainen-lpwan-nb-iot-00

Abstract:
   Low Power Wide Area Networks (LPWAN) are wireless technologies
   covering different Internet of Things (IoT) applications.  The common
   characteristics for LPWANs are large coverage, low bandwidth, small
   data sizes and long battery life operation.  One of these
   technologies include Narrowband Internet of Things (NB-IoT) developed
   and standardized by 3GPP.  This document is an informational overview
   to NB-IoT and gives the principal characteristics and restrictions of
   this technology in order to help with the IETF work for providing
   IPv6 connectivity to NB-IoT along with other LPWANs.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Alexander Pelov <[email-masked]>
Date: Fri, 8 Jul 2016 15:53:01 +0200

Dear Antti,

Thanks for the excellent document! It will help the understanding of the technology and with the preparation of the BoF!

A short question - in your worst-case scenario, you indicate that the throughput can be as low as 200 bps. Do you expect this to affect the max PDCP frame size? (I’d say possibly not, but to be sure). In the layers that you mention (such as RLC), are there any functions that have been disabled for Data-over-NAS? 

We may of course discuss more in length during the BoF itself.

Best,
Alexander

> Le 8 juil. 2016 à 15:16, Antti Ratilainen <[email-masked]> a écrit :
> 
> Dear all,
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Yeoh Chun-Yeow <[email-masked]>
Date: Sun, 10 Jul 2016 00:59:32 +0800

"However, a new feature was introduced for NB-IoT, as mentioned
earlier, which allows data to be transmitted from the MME directly to
the UE, while the UE is in RRC_Idle transparently to the eNodeB."

Data-over-NAS supports only DL or both UL and DL?

----
Chun-Yeow

---

From: Antti Ratilainen <[email-masked]>
Date: Thu, 14 Jul 2016 13:15:13 +0000

Dear Alexander, Yeoh,

Sorry for the late reply.
Good questions there, and a bit bad wording from me. Both uplink and downlink are supported in data over NAS solution for NB-IoT.
The basic functions of the layers are mostly supported also for the data over NAS solution, but some optimizations/modifications in the details have been implemented, such as RLC re-establishment is not supported for the NB-IoT control plane optimization. Also as mentioned, this is over control plane, so the control plane PDCP functions are considered, and therefore the header compression may not be supported. However, if RoHC is implemented in the MME with suitable compression profile, it can also be used for the data over NAS solution, but this is not required.
And the maximum PDCP SDU size is the same even for the low throughput case. So, the PDCP takes a maximum of 1600 B SDU, and forwards it to lower layers, where the data is segmented into suitable transmission block sizes, which may be quite small in the case of low throughput. In the receiving end the segments are then concatenated before delivering up to PDCP, which then delivers the packet upwards.

BR,
Antti

-----Original Message-----
From: Yeoh Chun-Yeow [mailto:[email-masked]] 
Sent: 9. heinäkuuta 2016 20:00
To: Alexander Pelov
Cc: Antti Ratilainen; [email-masked]
Subject: Re: [lp-wan] FW: New Version Notification for draft-ratilainen-lpwan-nb-iot-00.txt

"However, a new feature was introduced for NB-IoT, as mentioned earlier, which allows data to be transmitted from the MME directly to the UE, while the UE is in RRC_Idle transparently to the eNodeB."

----
Chun-Yeow