Subject: [lp-wan] rule id and fragments

From: Shoichi Sakane <[email-masked]>
Date: Mon, 13 Nov 2017 12:03:31 +0900

Hi,

It might be a stupid question.  I am missing something.

The rule id is placed in each fragment.  How can the receiver know the size of the rule id field ?

The receiver should know the size before the receiver receives the fragments.

Thanks,
Shoichi

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 13 Nov 2017 04:23:04 +0100

Hi Shoichi,

You are right: the receiver needs to know the size of the Rule ID in advance.

(The SCHC spec itself does not define the size of the Rule ID. Upcoming
SCHC-over-foo specs will provide more details on this for specific LPWAN
technologies.)

Cheers,

Carles

> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 13 Nov 2017 11:32:42 +0800

Hi Shoichi,

The size can be stored in the context.

Laurent

---

From: Shoichi Sakane <[email-masked]>
Date: Mon, 13 Nov 2017 14:59:34 +0900

make sense.

Thanks,
Shoichi

On 11/13/17 12:32, Laurent Toutain wrote:
> On Mon, Nov 13, 2017 at 11:23 AM, Carles Gomez Montenegro <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi Shoichi,
> 
>     > [email-masked] <mailto:[email-masked]>
>     > https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
>     >
> 
> 
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
> 
> 
>