Subject: [lp-wan] Feedback on your draft-SCHC over-your technology

From: Ana Minaburo <[email-masked]>
Date: Tue, 7 Nov 2017 14:29:04 +0100

Hello,

I’ve read your drafts, I thanks for this first input, I think it will give the next step for the working group. I was wondering if you will need some input about the things the SCHC specification leaves open to the different documents like yours.

I create a non exhaustive list of things that may be important to be defined in your document:

- In the architecture explain the SCHC entities, how they will be represented in the corresponding technology architecture.
- How to learn the context
- Size of the Rule id
- The way the Rule id is sent (L2 or L3) and how, describe
- Use of padding and how and when to use it
- Fragmentation delivery reliability option used over your technology and why
- Define the MAX_ACK_REQUEST
- define the number of bits of: Rule-id, FCN (N) and DTag (T)
      - Take into account that the length of rule-id+N+T + W= R and if possible is good to have a multiple of 8 bits to complete a byte and avoid padding
      - In the ACK format perhaps the idea of 1 byte length for Rule-ID + T + W bit to do optimisation more easily
- The algorithm to be used for the MIC
- The timer size for Fragmentation ACK always
- When to abort in ACK always
- MAX_ATTEMPS counter size
- In ACK on error the timer size between windows
- The L2 CRC used to increase reliability

At least these are the things that the draft-ietf-lpwan-ipv6-static-context-hc-07 leaves to be defined in this kind of documents

Cheers
Ana

Ana Minaburo

Research Division

Phone: +33 (0)2.99.12.24.14
ana at ackl.io

2 bis rue de la Châtaigneraie
35510 Cesson-Sévigné 
France 

www.acklio.com

---

From: Ivaylo Petrov <[email-masked]>
Date: Tue, 7 Nov 2017 16:29:52 +0100

Hi Ana,

Thanks for all the useful information!

Cheers
Ivaylo

Ivaylo Petrov
ivaylo at ackl.io

www.ackl.io

2 bis rue de la Châtaigneraie,
35510 Cesson Sévigné
FRANCE

2017-11-07 14:29 GMT+01:00 Ana Minaburo <[email-masked]>:

> Hello,
>
> I’ve read your drafts, I thanks for this first input, I think it will give
> the next step for the working group. I was wondering if you will need some
> input about the things the SCHC specification leaves open to the different
> documents like yours.
>
> - In the architecture explain the SCHC entities, how they will be
> represented in the corresponding technology architecture.
>       - Take into account that the length of rule-id+N+T + W= R and if
> possible is good to have a multiple of 8 bits to complete a byte and avoid
> padding
> At least these are the things that the draft-ietf-lpwan-ipv6-static-context-hc-07
> leaves to be defined in this kind of documents
>
> Cheers
> Ana
>
>
>
>
> Ana Minaburo
>
> Research Division
> Phone: +33 (0)2.99.12.24.14 <+33%202%2099%2012%2024%2014>
> ana at ackl.io
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>