Subject: [lp-wan] Dynamic Context for SCHC in LPWAN - New Paper

From: "Khaled Q. Abdelfadeel" <[email-masked]>
Date: Wed, 4 Apr 2018 16:03:18 +0100

Dear All,

We would like to share this work (
https://www.researchgate.net/publication/324210258_Dynamic_Context_for_Static_Context_Header_Compression_in_LPWANs)
with the mailing list. This paper has been accepted for publication at
DCOSS conference in June this year in New York, USA.

In this paper, we presented a novel method called dummy-mapping which can
be seen as new C/D action and matching operator within SCHC framework to
compress/decompress some header
fields of unknown flows. The idea behind the dummy mapping is to create a
fixed size list of dummy values that are dynamically mapped at the gateway
compressor to the values of headers fields. The mappings stay alive to
compress/decompress these fields until their flow ends,
and then the same dummy values can be remapped to different
header fields of different flows. The paper has an extensive evaluation
section with an analytical model and a numerical example.

We would be happy to get your feedback and answer any questions if you
have. Please consider the final version once available.

Best Regards,
Khaled

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 5 Apr 2018 10:22:41 +0200

Dear Khaled,

Thanks for performing this study and for publishing it to the community - I find it quite interesting!

Hope to see you on our next IETF meeting - in person or remotely. I think that we as a community could really benefit your knowledge and contributions.
(Also, there is the Hackathon running the weekend before the IETF - and you can test your ideas on a real network)

Cheers,
Alexander

> Le 4 avr. 2018 à 17:03, Khaled Q. Abdelfadeel <[email-masked]> a écrit :
> 
> Dear All,
> 
> We would like to share this work (https://www.researchgate.net/publication/324210258_Dynamic_Context_for_Static_Context_Header_Compression_in_LPWANs <https://www.researchgate.net/publication/324210258_Dynamic_Context_for_Static_Context_Header_Compression_in_LPWANs>) with the mailing list. This paper has been accepted for publication at DCOSS conference in June this year in New York, USA. 
> 
> In this paper, we presented a novel method called dummy-mapping which can be seen as new C/D action and matching operator within SCHC framework to compress/decompress some header
> fields of unknown flows. The idea behind the dummy mapping is to create a fixed size list of dummy values that are dynamically mapped at the gateway compressor to the values of headers fields. The mappings stay alive to compress/decompress these fields until their flow ends,
> header fields of different flows. The paper has an extensive evaluation section with an analytical model and a numerical example.
> 
> We would be happy to get your feedback and answer any questions if you have. Please consider the final version once available.
> 
> 
> Best Regards,
> Khaled
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan