Subject: [lp-wan] Ticket #11 ACK Format

From: ana minaburo <[email-masked]>
Date: Tue, 17 Apr 2018 10:22:23 +0200

Hello,

Here is the link, with all the description:

https://trac.ietf.org/trac/lpwan/ticket/11

* The question was: Does Padding is needed for ACK?

But this question also gives us the input that padding was not clearly
explained.

- We add a new Section 8 to explain the default solution for Padding.
  * Padding is not mandatory and depends on LP-WAN technology
  * The corresponding technology documents will define the use of padding
- There are two specific section for padding after compression and padding
after fragmentation (Section 6.3 and section 7.2).

- To answer directly to the question, in section 7.4.3 SCHC ACK format, the
padding is optionally used.

Do we need to add something else about padding? May I close the Ticket?

Ana

---

From: <[email-masked]>
Date: Tue, 24 Apr 2018 16:16:57 +0000

Hello Ana,

While section 7.4.3 does indeed describe SCHC ACK padding, section 8 does not even mention it.

Since section 8 is "Padding management", I recommend it does mention SCHC ACK padding, benefiting the readers who want an overview of padding in SCHC without having to dive into the specific sections.

Nit: the text in section 7.2 could be much improved.
"Padding (P). If it is needed, the number of bits used for padding

      is not defined and depends on the size of the Rule ID, DTag and
      FCN fields, and on the L2 payload size (see Section 8).  Some SCHC
      ACKs are byte-aligned and do not need padding (see

      Section 7.4.3.1)."

I'll provide suggestions for improvements.

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of ana minaburo <[email-masked]<mailto:[email-masked]>>
Date : Tuesday 17 April 2018 10:22
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] Ticket #11 ACK Format

Hello,

But this question also gives us the input that padding was not clearly explained.

- We add a new Section 8 to explain the default solution for Padding.
  * Padding is not mandatory and depends on LP-WAN technology
  * The corresponding technology documents will define the use of padding
- There are two specific section for padding after compression and padding after fragmentation (Section 6.3 and section 7.2).

- To answer directly to the question, in section 7.4.3 SCHC ACK format, the padding is optionally used.

Ana

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.