Subject: Re: [lp-wan] SCHC, single padding proposal

From: <[email-masked]>
Date: Tue, 5 Jun 2018 07:28:37 +0000

Dear all,

If you care about padding and haven't expressed your opinion so far, please do so in the next few days so that we can move forward.
Thanks, and a great day to all!

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Date : Wednesday 30 May 2018 19:05
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] SCHC, single padding proposal

Dear all,

In the current revision of the SCHC draft, draft-ietf-lpwan-ipv6-static-context-hc-13<https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-13>, the generic SCHC mechanism does padding at most twice for each datagram:
- A first time after header compression.
- A second time after fragmentation (on the last fragment only).
This results in at most 14 superfluous bits be transmitted for each datagram (when padding to bytes). See Section 8<https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-13#section-8>.

At today's interim meeting, I presented a proposal to do padding at most once. This result in a most 7 superfluous bits per datagram. The proposal also better compresses the SCHC ACK bitmaps.
See my slides at https://datatracker.ietf.org/meeting/interim-2018-lpwan-05/materials/slides-interim-2018-lpwan-05-sessa-aggregated-slides, pages 7  to 21.
At the interim meeting, the attendees agreed with the proposed change.
The implementers with Acklio agreed that the code change is small.
The draft text is already on GitHub, in a separate branch, and can be merged promptly.
See the minutes of the interim meeting https://datatracker.ietf.org/meeting/interim-2018-lpwan-05/materials/minutes-interim-2018-lpwan-05-201805301700
The proposed changes to the draft can be seen at https://github.com/lp-wan/ip-compression/pull/20/files

If anybody was not at today's interim meeting and cares about padding, please express your opinion within the next few days so that the WG can make a decision on this change.
Thanks,

Dominique

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Laurent Toutain <[email-masked]>
Date: Tue, 5 Jun 2018 09:33:18 +0200

Hi Dominique,

As we discuss during the interim meeting, this is an elegant solution,
avoiding to transport any length at L3 and with a maximum overhead of 7
bits. So I'm in favor of this algorithm.

Laurent

On Tue, Jun 5, 2018 at 9:29 AM <[email-masked]> wrote:

> Dear all,
>
> If you care about padding and haven't expressed your opinion so far,
> please do so in the next few days so that we can move forward.
> De : lp-wan <[email-masked]> on behalf of Dominique Barthel <
> [email-masked]>
> À : "[email-masked]" <[email-masked]>
> Cc : "[email-masked]" <
> [email-masked]>
> In the current revision of the SCHC draft,
> draft-ietf-lpwan-ipv6-static-context-hc-13
> <https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-13>,
> the generic SCHC mechanism does padding at most twice for each datagram:
> This results in at most 14 superfluous bits be transmitted for each
> datagram (when padding to bytes). See Section 8
> <https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-13#section-8>
> .
>
> At today's interim meeting, I presented a proposal to do padding at most
> once. This result in a most 7 superfluous bits per datagram. The proposal
> also better compresses the SCHC ACK bitmaps.
> See my slides at
> https://datatracker.ietf.org/meeting/interim-2018-lpwan-05/materials/slides-interim-2018-lpwan-05-sessa-aggregated-slides,
> pages 7  to 21.
> See the minutes of the interim meeting
> https://datatracker.ietf.org/meeting/interim-2018-lpwan-05/materials/minutes-interim-2018-lpwan-05-201805301700
> The proposed changes to the draft can be seen at
> https://github.com/lp-wan/ip-compression/pull/20/files
>
> If anybody was not at today's interim meeting and cares about padding,
> please express your opinion within the next few days so that the WG can
> make a decision on this change.
> Thanks,
>
> Dominique
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Nicolas Sornin <[email-masked]>
Date: Tue, 5 Jun 2018 14:30:09 +0000

Dear Dominique.
After review, Semtech is in favor of the new proposed padding scheme.

Nicolas Sornin.

From: lp-wan [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 05 June 2018 09:29
To: BARTHEL Dominique IMT/OLS <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [lp-wan] SCHC, single padding proposal

WARNING - External Email
________________________________
Dear all,

Dominique

Dear all,

Dominique

Thank you.

Thank you.

---

From: AUDEBERT Vincent <[email-masked]>
Date: Wed, 6 Jun 2018 23:37:04 +0000

Hi Dominique,

I am in favour of the new padding solution.

Regards

Vincent

Vincent AUDEBERT
Chef de projet
EDF – R&D Lab Saclay
MIRE
7 Bd Gaspard Monge
91120 PALAISEAU

[email-masked]
Tél. : + 33 1 78 19 45 64
Tél. mobile : + 33 6 14 13 23 22

Un geste simple pour l'environnement, n'imprimez ce message que si vous en avez l'utilité.

De : [email-masked] [mailto:[email-masked]]
Envoyé : mardi 5 juin 2018 09:29
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : Re: [lp-wan] SCHC, single padding proposal

Dear all,

Dominique

Dear all,

Dominique

Thank you.

Thank you.

Ce message et toutes les pièces jointes (ci-après le 'Message') sont établis à l'intention exclusive des destinataires et les informations qui y figurent sont strictement confidentielles. Toute utilisation de ce Message non conforme à sa destination, toute diffusion ou toute publication totale ou partielle, est interdite sauf autorisation expresse.

Si vous n'êtes pas le destinataire de ce Message, il vous est interdit de le copier, de le faire suivre, de le divulguer ou d'en utiliser tout ou partie. Si vous avez reçu ce Message par erreur, merci de le supprimer de votre système, ainsi que toutes ses copies, et de n'en garder aucune trace sur quelque support que ce soit. Nous vous remercions également d'en avertir immédiatement l'expéditeur par retour du message.

Il est impossible de garantir que les communications par messagerie électronique arrivent en temps utile, sont sécurisées ou dénuées de toute erreur ou virus.
____________________________________________________

This message and any attachments (the 'Message') are intended solely for the addressees. The information contained in this Message is confidential. Any use of information contained in this Message not in accord with its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval.

If you are not the addressee, you may not copy, forward, disclose or use any part of it. If you have received this message in error, please delete it and all copies from your system and notify the sender immediately by return message.

E-mail communication cannot be guaranteed to be timely secure, error or virus-free.

---

From: Edgar Ramos <[email-masked]>
Date: Mon, 11 Jun 2018 10:12:15 +0000

Thanks for the proposal Dominique. I also support the change

Br

Edgar Ramos

From: lp-wan [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: 05 June 2018 09:29
To: BARTHEL Dominique IMT/OLS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [lp-wan] SCHC, single padding proposal

WARNING - External Email

Dominique

Dear all,

Dominique

Thank you.

Thank you.

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 13 Jun 2018 02:52:58 +0000

Hello Dominique,

Thanks again for the work. As expressed in the meeting, I also support the single padding proposal.

Best,

Juan Carlos

Sent: June 5, 2018 3:29 AM

Dear all,

Dominique

Dear all,

Dominique

Thank you.

Thank you.