Subject: [lp-wan] authorize position 0

From: Laurent Toutain <[email-masked]>
Date: Sat, 20 Jul 2019 21:20:51 +0200

Hi,

I've a  proposal to make for coap compression. We process the same way
uri-path and the uri-query and we have a position field in the rule telling
where we find the elements. For instance

/foo/bar

will generate on a simplified rule containing the FID, the FP and the TV

URI-PATH 1 foo ...
URI-PATH 2 bar

The position is important to avoid confusion with /bar/foo.

But for the query we may not need this order, for instance, it looks that
date=monday&value=max
maybe equivalent to value=max&date=monday

so we may have something like:

URI-QUERY 0 value=
URI-QUERY 0 date=

where a rule will be selected if these 2 elements are present ignoring the
order. The decompressed message will follow the order given by the rule.

What do you think of that change? if you find interest, do we make the
change on -19 or un the coap draft ?

Laurent

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 20 Jul 2019 22:30:12 +0000

Looks like a great idea Laurent; we need to retrofit it in SCHC before its published.
Do you think you can do that Dominique?

Pascal

From: lp-wan <[email-masked]> On Behalf Of Laurent Toutain
Sent: samedi 20 juillet 2019 12:21
To: lp-wan <[email-masked]>
Subject: [lp-wan] authorize position 0

Hi,

I've a  proposal to make for coap compression. We process the same way uri-path and the uri-query and we have a position field in the rule telling where we find the elements. For instance

/foo/bar

URI-PATH 1 foo ...
URI-PATH 2 bar

But for the query we may not need this order, for instance, it looks that date=monday&value=max
maybe equivalent to value=max&date=monday

URI-QUERY 0 value=
URI-QUERY 0 date=

where a rule will be selected if these 2 elements are present ignoring the order. The decompressed message will follow the order given by the rule.

What do you think of that change? if you find interest, do we make the change on -19 or un the coap draft ?

Laurent

---

From: <[email-masked]>
Date: Sun, 21 Jul 2019 02:24:17 +0000

Hello all,

Sure, that's an easy one.
I'll publish a new version on Monday, so that people have the time to review the change by our meeting on Friday.
Thanks

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Date : Saturday 20 July 2019 18:30
À : Laurent Toutain <[email-masked]<mailto:[email-masked]>>, lp-wan <[email-masked]<mailto:[email-masked]>>
Objet : Re: [lp-wan] authorize position 0

Pascal

From: lp-wan <[email-masked]<mailto:[email-masked]>> On Behalf Of Laurent Toutain
Sent: samedi 20 juillet 2019 12:21
To: lp-wan <[email-masked]<mailto:[email-masked]>>
Subject: [lp-wan] authorize position 0

Hi,

/foo/bar

URI-PATH 1 foo ...
URI-PATH 2 bar

URI-QUERY 0 value=
URI-QUERY 0 date=

Laurent

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.