Subject: [lp-wan] Example with a possible error in LoRaWAN profile definition

From: Rodrigo Muñoz Lara <[email-masked]>
Date: Tue, 16 Jul 2019 22:23:32 -0400

Dear Author,

On page 19, in the draft "draft-ietf-lpwan-schc-over-lorawan-02", cap.
A.2.  Uplink - Compression and fragmentation example.

In the description of the example, said: "An applicative payload of 478
bytes is passed to SCHC compression layer using rule 1, allowing to
compress it to 440 bytes: 21 bits residue + 138 bytes payload."

Why 440 bytes is equal to 21 bits residue + 138 bytes payload?

The same problem exist on page 20. cap A.3.  Downlink. The example said:
"An applicative payload of 43 bytes is passed to SCHC compression layer
using rule 1, allowing to compress it to 24 bytes and 5 bits: 21 bits
residue + 22 bytes payload.". Here the numbers is OK, but the figure is not
aligned with the description

| RuleID | Compression residue |  Payload  |
+ ------ + ------------------- + --------- +
|   1    |       21 bits       |  18 bytes |

Why 18 bytes if the description said 22 bytes?

Thanks and Regards

-------------------------------------
Rodrigo Munoz Lara
Department of Electrical Engineering
Universidad de Chile
Santiago, Chile
[email-masked]

---

From: Olivier Gimenez <[email-masked]>
Date: Tue, 23 Jul 2019 16:16:08 +0000

Hi Rodrigo,

You are right, thank you for spotting the issues.
Please find the correction here: https://github.com/Acklio/schc-over-lorawan/commit/832624dd02d27ec6cae7f2481140abf8ef288d7a

Best regards
Olivier

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.