Subject: [lp-wan] LoRaWAN profile definition

From: Rodrigo Muñoz Lara <[email-masked]>
Date: Tue, 16 Jul 2019 00:06:25 -0400

Dear Author,

On page 42, in the draft "draft-ietf-lpwan-ipv6-static-context-hc-19",
indicates that each profile must define the following:

 * if the last tile is carried in a Regular SCHC Fragment or an All-1
SCHC Fragment (see Section 8.4.3.1)
 * if the penultimate tile MAY be one L2 Word smaller than the regular
tile size.  In this case, the regular tile size MUST be at least twice
the L2 Word size.

But when I read the draft "draft-ietf-lpwan-schc-over-lorawan-02" I
can't find where this definition is indicated for the LoRaWAN
protocol. It may be implicitly indicated, but I prefer to be sure
before proceeding with my solution. Can you help me with this?

Thanks and Regards

-------------------------------------
Rodrigo Munoz Lara
Department of Electrical Engineering
Universidad de Chile
Santiago, Chile
[email-masked]

---

From: <[email-masked]>
Date: Tue, 16 Jul 2019 12:47:38 +0000

Hello Rodrigo, all,

Thanks for rightfully pointing this out.
I'm not one of the authors. However, from reading "draft-ietf-lpwan-schc-over-lorawan-02", I gather:
Regarding your first question,

  *   for uplink fragmentation using the FportUpDefault, Appendix A.2 shows tiles after the MIC and 5.5.1.2 shows "Last tile, if any" after the MIC, therefore the answer is "the last tile is carried in the All-1 Fragment"
  *   For uplink fragmentation using FportUpShort, 5.5.1.1 misses the description of the All-1 Fragment, and no example is shown in Appendix, so I don't know the answer
  *   For downlink fragmentation, the mode is ACK-Always, therefore the question is irrelevant. The last tile is carried in the All-1 Fragment as stated by 8.4.2.1 of "draft-ietf-lpwan-ipv6-static-context-hc-19"

Regarding your second question, the authors of "draft-ietf-lpwan-schc-over-lorawan-02" are taking great care to byte-align the headers, therefore this feature is not needed. (for information, this is only needed in Ack-on-Error mode in case of unaligned headers/payloads). Therefore, I can bet that the answer is "the penultimate tile has the same size as the other tiles, but the last one."

Authors, can you please answer the question for the missing case (FPortUpShort) and make sure these answers are explicitly mentioned in the text, in the next revision?
Thanks

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Rodrigo Muñoz Lara <[email-masked]<mailto:[email-masked]>>
Date : Tuesday 16 July 2019 06:06
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : Juan Millan Castillo <[email-masked]<mailto:[email-masked]>>, Sandra Cespedes <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] LoRaWAN profile definition

Dear Author,

On page 42, in the draft "draft-ietf-lpwan-ipv6-static-context-hc-19", indicates that each profile must define the following:

 * if the last tile is carried in a Regular SCHC Fragment or an All-1 SCHC Fragment (see Section 8.4.3.1)
 * if the penultimate tile MAY be one L2 Word smaller than the regular tile size.  In this case, the regular tile size MUST be at least twice the L2 Word size.

But when I read the draft "draft-ietf-lpwan-schc-over-lorawan-02" I can't find where this definition is indicated for the LoRaWAN protocol. It may be implicitly indicated, but I prefer to be sure before proceeding with my solution. Can you help me with this?

Thanks and Regards

-------------------------------------
Rodrigo Munoz Lara
Department of Electrical Engineering
Universidad de Chile
Santiago, Chile
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Olivier Gimenez <[email-masked]>
Date: Tue, 23 Jul 2019 08:58:27 +0000

Dear,

Q1: Last tile in uplink fragmentation session can be carried in the All-1 fragment using FPortUpDefault or FPortUpShort. I will update the document to clarify it.
Q2: As an All-1 fragment can carry the last tile, I do not see why the penultimate should not carry regular tiles size. So I agree with Dominique answer: the penultimate tile has the same size as the other tiles, but the last one

Olivier

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.