Subject: Re: [lp-wan] Flow validation in ACK-on-error Mode

From: Rodrigo Muñoz <[email-masked]>
Date: Wed, 9 Oct 2019 01:07:40 -0300

Hi Olivier

Sorry for the delay in responding. About the uplink communication.  When I
read the following:

> At the end of a window or a
> fragmentation session, corresponding ACK (s) is (are) transmitted
> by the network gateway (LoRaWAN application server) in the RX1 or
> RX2 receive slot of end-device

I think that you are working in Ack-always mode and not in Ack-on-error
mode because the draft is always forcing the response of an ACK.

If I'm wrong, How does the end device know that when the network server
does not send an ack it is because everything went well and not because the
ACK was lost?.

Regards

--
Rodrigo

El lun., 23 sept. 2019 a las 8:14, Olivier Gimenez (<[email-masked]>)
escribió:

> Hi Rodrigo,
>
> From what I understand the second image your question is: “How does the
> transmitter knows when to send the All-1 SCHC message” ?
> In LoRaWAN class A there is no way to initiate communication from the
> network, device has to send an uplink so it can open RX windows.
>
> So the device can send the All-1 as soon as RX1, RX2 widows are over
> without downlink. Please see attached picture
>
> I propose to change the following sentence of §5.1.1, it is clearer for
> you ?
>
> > At the end of a window or a
> > fragmentation session, corresponding ACK(s) is (are) transmitted
> > by the network gateway (LoRaWAN application server) in the RX1 or
> > RX2 receive slot of end-device.  If this ACK is not received the
> > end-device sends an all-0 (or an all-1) fragment with no payload
> > to request an SCHC ACK retransmission.
>
> to
>
> > At the end of a window or a
> > fragmentation session, corresponding ACK(s) is (are) transmitted
> > by the network gateway (LoRaWAN application server) in the RX1 or
> > RX2 receive slot of end-device.  If this ACK is not received *by* the
> > end-device *at the end of its RX windows, it* sends an all-0 (or an
> all-1) fragment with no payload
> > to request an SCHC ACK retransmission.
>
> To view our privacy policy, including the types of personal information we
> collect, process and share, and the rights and options you have in this
> respect, see www.semtech.com/legal.
>

-- 
-------------------------------------------
*Rodrigo Muñoz Lara*

---

From: Olivier Gimenez <[email-masked]>
Date: Wed, 9 Oct 2019 07:02:19 +0000

Hi Rodrigo,

I am not sure to understand your comment.

·         Ack-Always mode: ACK is send after each fragmented packet

·         Ack-On-Error: ACK is send after each fragmentation session to indicate to the sender that reconstruction is ok (C=1) or not (C=0) or may reply an ACK with missing tiles at the end of a windows as per draft-ietf-lpwan-ipv6-static-context-hc-21 §8.4.3.2.  Receiver behaviour

So, could you please clarify ?

Best regards
Olivier

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.