Subject: Re: [lp-wan] C Implementation of SCHC ?

From: <[email-masked]>
Date: Fri, 18 Oct 2019 16:11:02 +0000

Hello Hannes,

I don't know of a SCHC implementation at this time.
The closest I know to an implementation is the RiOT guys intention of adding SCHC to RioT. AFAIK, they were debating whether to rewrite SCHC in C or run micropython over RioT.

Regarding papers, I'm aware of a paper being submitted by S. Aguilar et al. (IMT Atlantique, Rennes and UPC, Barcelona) but I'm not sure what its status exactly is.
I'll let the authors come out of the wood.
A quick search on ieeeexplore with the keyword "SCHC" returned two relevant papers (published this summer), YMMV.
What performance are you interested in ? Compression, fragmentation, .. ?

Best regards

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date : Friday 18 October 2019 16:55
À : lp-wan <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] C Implementation of SCHC ?

Hi all,

I was searching for a C implementation of SCHC and only found Python and JavaScript implementations. Can someone send me a pointer to a C implementation?

I also recall a paper being distributed about the performance of SCHC but I cannot find that either. A pointer would be great.

Thanks.

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Khaled Q. Abdelfadeel" <[email-masked]>
Date: Fri, 18 Oct 2019 17:21:38 +0100

Hi Hanna,

we have published the following papers around SCHC:

1- LSCHC: Layered Static Context Header Compression for LPWANs
2- Dynamic Context for Static Context Header compression in LPWANs

Best,
Khaled

On Fri, Oct 18, 2019 at 5:11 PM <[email-masked]> wrote:

> The closest I know to an implementation is the RiOT guys intention of
> adding SCHC to RioT. AFAIK, they were debating whether to rewrite SCHC in C
> or run micropython over RioT.
>
> Regarding papers, I'm aware of a paper being submitted by S. Aguilar et
> al. (IMT Atlantique, Rennes and UPC, Barcelona) but I'm not sure what its
> status exactly is.
> A quick search on ieeeexplore with the keyword "SCHC" returned two
> relevant papers (published this summer), YMMV.
> De : lp-wan <[email-masked]> on behalf of Hannes Tschofenig <
> [email-masked]>
> À : lp-wan <[email-masked]>
> I was searching for a C implementation of SCHC and only found Python and
> JavaScript implementations. Can someone send me a pointer to a C
> implementation?
>
>
>
> I also recall a paper being distributed about the performance of SCHC but
> I cannot find that either. A pointer would be great.
>
>
>
> Thanks.
>
>
>
> Ciao
>
> Hannes
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sat, 19 Oct 2019 07:50:21 +0200

Hello Hannes,

> I'll let the authors come out of the wood.

The paper by S. Aguilar et al analyzes the ACK overhead of ACK-on-Error
fragmentation mode, and it is currently under review.

The SCHC authors wrote another paper which is currently in "Minor
revision", which gives a tutorial-like overview and simple evaluation of
SCHC header compression and fragmentation.

Just in case, we'll keep you updated.

Cheers,

Carles

> adding SCHC to RioT. AFAIK, they were debating whether to rewrite SCHC in
> C or run micropython over RioT.
>
> De : lp-wan <[email-masked]<mailto:[email-masked]>> on
> behalf of Hannes Tschofenig
> <[email-masked]<mailto:[email-masked]>>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 19 Oct 2019 15:11:01 +0000

Hi Khaled,

I found those papers searching the web but, given my lack of familiarity with SCHC, I wasn’t sure whether these two papers provide data related to the work being in the drafts or propose extensions to it. At least the titles gave me that impression (layered SCHC and dynamic context for SCHC).

Ciao
Hannes

From: Khaled Q. Abdelfadeel <[email-masked]>
Sent: Freitag, 18. Oktober 2019 18:22
To: [email-masked]
Cc: Hannes Tschofenig <[email-masked]>; lp-wan <[email-masked]>
Subject: Re: [lp-wan] C Implementation of SCHC ?

Hi Hanna,

Best,
Khaled

On Fri, Oct 18, 2019 at 5:11 PM <[email-masked]<mailto:[email-masked]>> wrote:
Hello Hannes,

Best regards

Dominique

Hi all,

Thanks.

Ciao
Hannes

Thank you.
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 19 Oct 2019 16:08:46 +0000

Thanks, Dominique.

Regarding the implementation question I cannot really help because I don’t know what the RIoT guys are trying to accomplish.

I was actually surprised to see that the work on static header compression is actually much more than compression. It includes a protocol for fragmentation and reassembly as well as support for reliable transmission of packets.

Ciao
Hannes

From: [email-masked] <[email-masked]>
Sent: Freitag, 18. Oktober 2019 18:11
To: Hannes Tschofenig <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: Re: [lp-wan] C Implementation of SCHC ?

Hello Hannes,

Best regards

Dominique

Hi all,

Thanks.

Ciao
Hannes

Thank you.

---

From: <[email-masked]>
Date: Sun, 20 Oct 2019 06:48:17 +0000

Hello Hannes,

Indeed, I agree that the SCHC acronym is kind of a misnomer.
SCHC&FR would be technically more accurate, but totally un-pronounceable.
The common part is SC (Static Context). HC (Header Compression) and FR (Fragmentation/Reassembly) are mostly independent, except they share the same RuleID (name)space.
>  as well as support for reliable transmission of packets.
Actually,  it includes support for reliable transmission of fragments. If the packet is compressed but not fragmented, there Is no reliability mechanism added.
Unless the implementer decides to use the fragmentation mechanics just for the benefit of reliability, even if fragmentation itself is not required.
Best regards,

Dominique

De : Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date : Saturday 19 October 2019 18:08
À : Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Cc : lp-wan <[email-masked]<mailto:[email-masked]>>
Objet : RE: [lp-wan] C Implementation of SCHC ?

Thanks, Dominique.

Ciao
Hannes

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Freitag, 18. Oktober 2019 18:11
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Cc: lp-wan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] C Implementation of SCHC ?

Hello Hannes,

Best regards

Dominique

Hi all,

Thanks.

Ciao
Hannes

Thank you.

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 31 Oct 2019 07:21:26 +0100

Hello again,

> SCHC header compression and fragmentation.

... And now we are happy to announce that the paper has been accepted for
publication at IEEE Wireless Communications magazine. Should you be
interested, a "postprint" version is already available:
https://www.researchgate.net/publication/336915597_IPv6_over_LPWANs_connecting_Low_Power_Wide_Area_Networks_to_the_Internet_of_Things

Cheers,

Carles (on behalf of all authors)