Subject: [lp-wan] Question about SCHC drafts field length naming

From: Sergio Aguilar <[email-masked]>
Date: Wed, 22 Jan 2020 11:35:12 +0100

Hello authors,

I have a couple of questions to the authors regarding the SCHC-over-LoRaWAN, SCHC-over-sigfox and SCHC-over-nbiot drafts (in the latest uploaded version).

First regarding the SCHC-over-LoRaWAN:

- In section  5.6.2. Uplink fragmentation: From device to SCHC gateway it states:

o Window index: encoded on W = 2 bits. So 4 windows are available.
 
Question: Why “W” is used as the size of the “W” field instead of using “M” as in the schc draft?

Regarding the SCHC-over-Sigfox draft:

In section 5.2.1. Uplink No-ACK mode it states:
“the Message Integrity Check (MIC) size, M: TBD bits”

Question: Why “M” is used as the size of the MIC (RCS in schc draft v23) instead of “U” as in the schc draft?

In section 5.2.3. Uplink ACK-on-Error mode it states:
“Window (W) size is: 2 bits. “

Question: Why “W” is used as the size of the “W” field instead of using “M” as in the schc draft?

Regarding the SCHC-over-nbiot draft:

In section 6.3.2 Fragmentation Parameters it states: 
“W (number of bits)”

Question: Why “W” is used as the size of the “W” field instead of using “M” as in the schc draft?

I just ask these questions because coming from the schc draft it can be confusing and it is not straight forward to move from one draft to another. Also, the field length names have been already defined in the schc draft, so I don’t know why they are not used, or if there is any restriction that leads to these new definitions.  

Thanks for your time

Best regards, 

Sergio Aguilar

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 22 Jan 2020 14:27:47 +0000

Hello Sergio,

Thanks for your comments. It is true that we have concentrated efforts on the SCHC baseline draft publication lately and we have not had time yet to update the different SCHC-over-foo drafts accordingly.

Regarding the SCHC-over-Sigfox draft, we are planning to publish an update soon and we will take your inputs into account to remove the discrepancies.

Best,

Juan Carlos

From: lp-wan <[email-masked]> On Behalf Of Sergio Aguilar
Sent: January 22, 2020 5:35 AM
To: lp-wan <[email-masked]>
Cc: Rafael Vidal <[email-masked]>; [email-masked]
Subject: [lp-wan] Question about SCHC drafts field length naming

Hello authors,

  *   In section 5.2.1. Uplink No-ACK mode it states:
“the Message Integrity Check (MIC) size, M: TBD bits”

  *   In section 5.2.3. Uplink ACK-on-Error mode it states:
“Window (W) size is: 2 bits. “

  *   In section 6.3.2 Fragmentation Parameters it states:
“W (number of bits)”

Thanks for your time

Best regards,

Sergio Aguilar

---

From: Ana Minaburo <[email-masked]>
Date: Thu, 23 Jan 2020 09:07:47 +0100

Hello,
Thank you for your input, as Juan Carlos explain you we were focused on the
SCHC-baseline draft, but it is time to go forward and the next step is to
use the current terminology to be compliant.

Thanks
Ana

On Wed, Jan 22, 2020 at 11:35 AM Sergio Aguilar <
[email-masked]> wrote:

> Hello authors,
>
> I have a couple of questions to the authors regarding the
> SCHC-over-LoRaWAN, SCHC-over-sigfox and SCHC-over-nbiot drafts (in the
> latest uploaded version).
>
>    - In section 5.2.1. Uplink No-ACK mode it states:
>
>    - In section 5.2.3. Uplink ACK-on-Error mode it states:
>
>    - In section 6.3.2 Fragmentation Parameters it states:
>
> “W (number of bits)”
>
> I just ask these questions because coming from the schc draft it can be
> confusing and it is not straight forward to move from one draft to another.
> Also, the field length names have been already defined in the schc draft,
> so I don’t know why they are not used, or if there is any restriction that
> leads to these new definitions.
>
> Thanks for your time
>
> Best regards,
>
> Sergio Aguilar
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>