Subject: Re: [lp-wan] Call for agenda items - interim meeting

From: Laurent Toutain <[email-masked]>
Date: Tue, 7 Jan 2020 09:37:23 +0100

Hi Alex and happy SCHC year,

We can talk about the yang data model.

Laurent

On Thu, Dec 19, 2019 at 5:51 PM Alexander Pelov <[email-masked]> wrote:

> Dear all,
>
> We will have our next interim meeting on January 8th (the Secretariat will
> send the invites shortly).
>
> Please send your request for presentation slot to the mailing list or the
> Chairs, so that we can prepare the Agenda.
>
> Regards,
> Pascal and Alexander
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>

---

From: Olivier Gimenez <[email-masked]>
Date: Wed, 8 Jan 2020 13:23:44 +0000

Hi,

Happy new year all. If it is not too late to add a subject to the call I would like to discuss the IID computation methods I proposed to the mail list the on the 20th of December:

We proposed an algorithm for IID which is close to the discussion we had with Dave Thaler during IETF-106, the idea is to create a hash derived from DevEUI and AppSKey. AppSkey is the only candidate we can find shared by the SCHC gateway and the device, which changes over time (RFC8065), in our case after each join/rejoin. This should also be validated by LoRaWAN security group to know if we can reuse AppSKey for such purpose

There is another proposition based on RFC7217 which the IID is "stable for each subnet": RID = F(Prefix, Net_Iface, Network_ID, DAD_Counter, secret_key), where Net_Iface can be DevEUI and Network_ID the LoRaWAN netid.

I prefer the first proposition as it will mitigate correlation over time, the drawback is that we reuse AppSKey for something else than payload LoRaWAN protection.

The second proposition need a way to share the secret_key before communication and using LoRaWAN Netid might be an issue in passive roaming.

Sorry I missed the call for agenda email

Best regards
Olivier

On Thu, Dec 19, 2019 at 5:51 PM Alexander Pelov <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

We will have our next interim meeting on January 8th (the Secretariat will send the invites shortly).

Please send your request for presentation slot to the mailing list or the Chairs, so that we can prepare the Agenda.

Regards,
Pascal and Alexander

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Jan 2020 14:02:39 +0000

Hello Olivier

Do you have a slide?

Regards,

Pascal

Le 8 janv. 2020 à 14:24, Olivier Gimenez <[email-masked]> a écrit :

Hi,

Best regards
Olivier

Regards,
Pascal and Alexander