Subject: Re: [lp-wan] SCHC RFC-to-be title?

From: <[email-masked]>
Date: Mon, 10 Feb 2020 09:01:34 +0000

Hello all,

If you have an opinion on this and haven't responded yet, please chime in by end of business day today.
Thanks

Dominique

De : lp-wan <[email-masked]<mailto:[email-masked]>> on behalf of Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Date : Thursday 6 February 2020 10:55
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : [lp-wan] SCHC RFC-to-be title?

Hello all,

This was discussed yesterday at the interim meeting and I want to give everybody a chance to chime in.
The SCHC draft is currently in AUTH48 stage, with the RFC Editor, and now is the time to do the last editorial changes.

One thing we want to do right is the RFC title. It currently says "Static Context Header Compression (SCHC) and fragmentation for LPWAN, application to UDP/IPv6".
We want to change it for a better title, one that reflects the most important contributions of this RFC.

  *   I believe the UDP/IPv6 section is secondary, it's more of an example of application. Having UDP/IPv6 in the title distracts from the fact that the rest of the draft is a generic mechanism, IMHO.
  *    We have a little tension between using SCHC as an acronym (expliciting Compression) and the use of expressions like "'SCHC Fragmentation" and "SCHC Compression".
  *   Thoughts have been expressed that the applicability of the generic SCHC algorithm is not limited to LPWANs, therefore it should not appear in the title. The rest of the text could still say that "SCHC was originally developed with LPWANs in mind".
  *   Thoughts have been expressed that "static context" is a distinguishing feature, and as such, it should stay in the title.

Can I please get your votes about the following two points:

A) "SCHC"
A.1 remains an acronym meaning "Static Context Header Compression", and we live with the tension described above.
A.2 becomes the acronym to mean "Static Context Header Compression and fragmentation", even though the F does not show in the acronym
A.3 becomes SCHCF and means "Static Context Header Compression and Fragmentation", and we will later figure a pronunciation for it.
A.4 becomes a proper noun, a name that is not spelled out. The text can still mention that the name originated as an acronym for "Static Context Header Compression".

B) RFC title:
B.1 "SCHC: generic framework for header compression and fragmentation using a static context"
B.2 "SCHC: static context header compression and fragmentation for Low-Power Wide Area Networks (LPWANs)"
B.3 ""Static Context Header Compression and fragmentation (SCHC)"
B.4 ""Static Context Header Compression and fragmentation (SCHC) for Low-Power Wide Area Networks (LPWANs)"
B.5 suggest your own!

Your votes by the end of the week would be very much appreciated!
Thanks

Dominique & the co-authors gang

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: AUDEBERT Vincent <[email-masked]>
Date: Mon, 10 Feb 2020 17:07:07 +0000

Hi All,

I would go for A2, B3.

Regards

Vincent

Vincent AUDEBERT
IoT & Telecom Expert
EDF – R&D Lab Saclay
MIRE
7 Bd Gaspard Monge
91120 PALAISEAU

[email-masked]
Phone : + 33 1 78 19 45 64
Mobile : + 33 6 14 13 23 22

Un geste simple pour l'environnement, n'imprimez ce message que si vous en avez l'utilité.

De : lp-wan [mailto:[email-masked]] De la part de [email-masked]
Envoyé : lundi 10 février 2020 10:02
À : [email-masked]
Objet : Re: [lp-wan] SCHC RFC-to-be title?

Hello all,

Dominique

Hello all,

A) "SCHC"

B) RFC title:

Thank you.

Thank you.

Ce message et toutes les pièces jointes (ci-après le 'Message') sont établis à l'intention exclusive des destinataires et les informations qui y figurent sont strictement confidentielles. Toute utilisation de ce Message non conforme à sa destination, toute diffusion ou toute publication totale ou partielle, est interdite sauf autorisation expresse.

Si vous n'êtes pas le destinataire de ce Message, il vous est interdit de le copier, de le faire suivre, de le divulguer ou d'en utiliser tout ou partie. Si vous avez reçu ce Message par erreur, merci de le supprimer de votre système, ainsi que toutes ses copies, et de n'en garder aucune trace sur quelque support que ce soit. Nous vous remercions également d'en avertir immédiatement l'expéditeur par retour du message.

Il est impossible de garantir que les communications par messagerie électronique arrivent en temps utile, sont sécurisées ou dénuées de toute erreur ou virus.
____________________________________________________

This message and any attachments (the 'Message') are intended solely for the addressees. The information contained in this Message is confidential. Any use of information contained in this Message not in accord with its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval.

If you are not the addressee, you may not copy, forward, disclose or use any part of it. If you have received this message in error, please delete it and all copies from your system and notify the sender immediately by return message.

E-mail communication cannot be guaranteed to be timely secure, error or virus-free.