Subject: Re: [lp-wan] Comments on the lorawan draft-10

From: Olivier Gimenez <[email-masked]>
Date: Fri, 2 Oct 2020 14:18:27 +0000

Hello Arun,

Thank you for your comments

Comment 1
Could you please provide an example? I am not sure to understand the issue:
If the last tile is less than an L2 word (1 byte for LoRaWAN) it should be padded. Why “borrowing” an L2 word from the penultimate ? It will not solve the byte miss-alignment issue

Comment 2
It is used to avoid any issue when the SCHC Fragment is retransmitted, so it is from the same session. Is the following ok for you ?
The sender MUST ascertain that the receiver will not receive the last tile through both a Regular SCHC Fragment and an All-1 SCHC Fragment during the same session

Best regards
Olivier

To view our privacy policy, including the types of personal information we collect, process and share, and the rights and options you have in this respect, see www.semtech.com/legal.

---

From: Arunprabhu Kandasamy <[email-masked]>
Date: Fri, 2 Oct 2020 17:34:01 +0200

Hi Olivier,
please find my comments inline.

On Fri, Oct 2, 2020 at 4:18 PM Olivier Gimenez <[email-masked]> wrote:

> *Comment 1*
> If the last tile is less than an L2 word (1 byte for LoRaWAN) it should be
> padded. Why “borrowing” an L2 word from the penultimate ? It will not solve
> the byte miss-alignment issue
>
>
>
[Arun] yes, you are right. in the lorawan draft since we have the
byte-aligned fragment_header, my comment will be invalid. you can ignore my
comments.

> *Comment 2*
>
> It is used to avoid any issue when the SCHC Fragment is retransmitted, so
> it is from the same session. Is the following ok for you ?
>
> *The sender MUST ascertain that the receiver will not receive the last
> tile through both a Regular SCHC Fragment and an All-1 SCHC Fragment during
> the same session*
>
>
>
[Arun] ok for me!

> Best regards
>
> Olivier
>
> To view our privacy policy, including the types of personal information we
> collect, process and share, and the rights and options you have in this
> respect, see www.semtech.com/legal.
>

-- 

<https://t.sidekickopen05.com/s1t/c/5/f18dQhb0S7lM8dDMPbW2n0x6l2B9nMJN7t5X-FfhMynW4Wr-Yl7d-0fCW56dGqW1GQ8t2102?t=https%3A%2F%2Fackl.io%2F&si=7000000001059340&pi=5991da3d-efb6-4959-f4d5-a627f1b5eb8b>

*Arunprabhu KANDASAMY *R&D Engineer-IPCore
+33 2 22 06 05 77

www.ackl.io

 <https://www.linkedin.com/company/acklio/> [image:
W3Schools] <https://twitter.com/acklio>

---

From: Olivier Gimenez <[email-masked]>
Date: Mon, 5 Oct 2020 09:52:05 +0000

Hello Arun,

Thank you. Proposed changes included in commit e2de41c<https://github.com/Acklio/schc-over-lorawan/pull/35/commits/e2de41cfd1aec4176300559a8c890b539f5b4902>

Olivier

From: Arunprabhu Kandasamy <[email-masked]>

Comment 2

[Arun] ok for me!